aboutsummaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure315
1 files changed, 234 insertions, 81 deletions
diff --git a/configure b/configure
index d543cd9..32e9e9d 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.64 for Phidget21 C Library 2.1.8.20120216.
+# Generated by GNU Autoconf 2.64 for Phidget21 C Library 2.1.8.20120507.
#
# Report bugs to <support@phidgets.com>.
#
@@ -698,8 +698,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='Phidget21 C Library'
PACKAGE_TARNAME='libphidget'
-PACKAGE_VERSION='2.1.8.20120216'
-PACKAGE_STRING='Phidget21 C Library 2.1.8.20120216'
+PACKAGE_VERSION='2.1.8.20120507'
+PACKAGE_STRING='Phidget21 C Library 2.1.8.20120507'
PACKAGE_BUGREPORT='support@phidgets.com'
PACKAGE_URL='www.phidgets.com'
@@ -749,6 +749,8 @@ INTERNAL_UNICONV_FALSE
INTERNAL_UNICONV_TRUE
RUN_LDCONFIG_FALSE
RUN_LDCONFIG_TRUE
+NEW_LIBUSB_FALSE
+NEW_LIBUSB_TRUE
LABVIEW_FALSE
LABVIEW_TRUE
ZEROCONF_LOOKUP_FALSE
@@ -887,6 +889,7 @@ enable_debug
enable_zeroconf
enable_zeroconf_lookup
enable_labview
+enable_oldlibusb
enable_ldconfig
'
ac_precious_vars='build_alias
@@ -1440,7 +1443,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures Phidget21 C Library 2.1.8.20120216 to adapt to many kinds of systems.
+\`configure' configures Phidget21 C Library 2.1.8.20120507 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1510,7 +1513,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of Phidget21 C Library 2.1.8.20120216:";;
+ short | recursive ) echo "Configuration of Phidget21 C Library 2.1.8.20120507:";;
esac
cat <<\_ACEOF
@@ -1532,6 +1535,7 @@ Optional Features:
--enable-zeroconf Turn on zeroconf, choose avahi or bonjour
--enable-zeroconf-lookup Turn on zeroconf lookup
--enable-labview Turn on Labview support
+ --enable-oldlibusb Use libusb-0.1 instead of 1.0
--disable-ldconfig do not update dynamic linker cache using ldconfig
Optional Packages:
@@ -1619,7 +1623,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-Phidget21 C Library configure 2.1.8.20120216
+Phidget21 C Library configure 2.1.8.20120507
generated by GNU Autoconf 2.64
Copyright (C) 2009 Free Software Foundation, Inc.
@@ -1897,7 +1901,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by Phidget21 C Library $as_me 2.1.8.20120216, which was
+It was created by Phidget21 C Library $as_me 2.1.8.20120507, which was
generated by GNU Autoconf 2.64. Invocation command line was
$ $0 $@
@@ -2705,7 +2709,7 @@ fi
# Define the identity of the package.
PACKAGE='libphidget'
- VERSION='2.1.8.20120216'
+ VERSION='2.1.8.20120507'
cat >>confdefs.h <<_ACEOF
@@ -4382,13 +4386,13 @@ if test "${lt_cv_nm_interface+set}" = set; then :
else
lt_cv_nm_interface="BSD nm"
echo "int some_variable = 0;" > conftest.$ac_ext
- (eval echo "\"\$as_me:4385: $ac_compile\"" >&5)
+ (eval echo "\"\$as_me:4389: $ac_compile\"" >&5)
(eval "$ac_compile" 2>conftest.err)
cat conftest.err >&5
- (eval echo "\"\$as_me:4388: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
+ (eval echo "\"\$as_me:4392: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
(eval "$NM \"conftest.$ac_objext\"" 2>conftest.err > conftest.out)
cat conftest.err >&5
- (eval echo "\"\$as_me:4391: output\"" >&5)
+ (eval echo "\"\$as_me:4395: output\"" >&5)
cat conftest.out >&5
if $GREP 'External.*some_variable' conftest.out > /dev/null; then
lt_cv_nm_interface="MS dumpbin"
@@ -5594,7 +5598,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 5597 "configure"' > conftest.$ac_ext
+ echo '#line 5601 "configure"' > conftest.$ac_ext
if { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_compile\""; } >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -7120,11 +7124,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7123: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7127: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7127: \$? = $ac_status" >&5
+ echo "$as_me:7131: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -7459,11 +7463,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7462: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7466: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7466: \$? = $ac_status" >&5
+ echo "$as_me:7470: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -7564,11 +7568,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7567: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7571: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:7571: \$? = $ac_status" >&5
+ echo "$as_me:7575: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -7619,11 +7623,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7622: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7626: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:7626: \$? = $ac_status" >&5
+ echo "$as_me:7630: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -10002,7 +10006,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
-#line 10005 "configure"
+#line 10009 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -10098,7 +10102,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
-#line 10101 "configure"
+#line 10105 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -11230,63 +11234,6 @@ else
as_fn_error "Missing libpthread!" "$LINENO" 5
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing usb_find_busses" >&5
-$as_echo_n "checking for library containing usb_find_busses... " >&6; }
-if test "${ac_cv_search_usb_find_busses+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- ac_func_search_save_LIBS=$LIBS
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-/* Override any GCC internal prototype to avoid an error.
- Use char because int might match the return type of a GCC
- builtin and then its argument prototype would still apply. */
-#ifdef __cplusplus
-extern "C"
-#endif
-char usb_find_busses ();
-int
-main ()
-{
-return usb_find_busses ();
- ;
- return 0;
-}
-_ACEOF
-for ac_lib in '' usb; do
- if test -z "$ac_lib"; then
- ac_res="none required"
- else
- ac_res=-l$ac_lib
- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
- fi
- if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_search_usb_find_busses=$ac_res
-fi
-rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext
- if test "${ac_cv_search_usb_find_busses+set}" = set; then :
- break
-fi
-done
-if test "${ac_cv_search_usb_find_busses+set}" = set; then :
-
-else
- ac_cv_search_usb_find_busses=no
-fi
-rm conftest.$ac_ext
-LIBS=$ac_func_search_save_LIBS
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_usb_find_busses" >&5
-$as_echo "$ac_cv_search_usb_find_busses" >&6; }
-ac_res=$ac_cv_search_usb_find_busses
-if test "$ac_res" != no; then :
- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
-
-else
- as_fn_error "Missing libusb!" "$LINENO" 5
-fi
# we need iconv - if it's not available in libc, look for the 'libiconv' function from libiconv.so
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing iconv" >&5
@@ -11523,6 +11470,204 @@ else
fi
+# Check whether --enable-oldlibusb was given.
+if test "${enable_oldlibusb+set}" = set; then :
+ enableval=$enable_oldlibusb; case "${enableval}" in
+ yes) newlibusb=false ;;
+ no) newlibusb=true ;;
+ *) as_fn_error "bad value ${enableval} for --enable-oldlibusb" "$LINENO" 5 ;;
+esac
+else
+ newlibusb=true
+fi
+
+
+if test "$newlibusb" = "true"; then
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing libusb_init" >&5
+$as_echo_n "checking for library containing libusb_init... " >&6; }
+if test "${ac_cv_search_libusb_init+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_func_search_save_LIBS=$LIBS
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char libusb_init ();
+int
+main ()
+{
+return libusb_init ();
+ ;
+ return 0;
+}
+_ACEOF
+for ac_lib in '' usb-1.0; do
+ if test -z "$ac_lib"; then
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_libusb_init=$ac_res
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext
+ if test "${ac_cv_search_libusb_init+set}" = set; then :
+ break
+fi
+done
+if test "${ac_cv_search_libusb_init+set}" = set; then :
+
+else
+ ac_cv_search_libusb_init=no
+fi
+rm conftest.$ac_ext
+LIBS=$ac_func_search_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_libusb_init" >&5
+$as_echo "$ac_cv_search_libusb_init" >&6; }
+ac_res=$ac_cv_search_libusb_init
+if test "$ac_res" != no; then :
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+ newlibusb=true
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing usb_find_busses" >&5
+$as_echo_n "checking for library containing usb_find_busses... " >&6; }
+if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_func_search_save_LIBS=$LIBS
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char usb_find_busses ();
+int
+main ()
+{
+return usb_find_busses ();
+ ;
+ return 0;
+}
+_ACEOF
+for ac_lib in '' usb; do
+ if test -z "$ac_lib"; then
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_usb_find_busses=$ac_res
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext
+ if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+ break
+fi
+done
+if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+
+else
+ ac_cv_search_usb_find_busses=no
+fi
+rm conftest.$ac_ext
+LIBS=$ac_func_search_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_usb_find_busses" >&5
+$as_echo "$ac_cv_search_usb_find_busses" >&6; }
+ac_res=$ac_cv_search_usb_find_busses
+if test "$ac_res" != no; then :
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+ newlibusb=false
+else
+ as_fn_error "Missing libusb!" "$LINENO" 5
+fi
+
+fi
+
+else
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing usb_find_busses" >&5
+$as_echo_n "checking for library containing usb_find_busses... " >&6; }
+if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_func_search_save_LIBS=$LIBS
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char usb_find_busses ();
+int
+main ()
+{
+return usb_find_busses ();
+ ;
+ return 0;
+}
+_ACEOF
+for ac_lib in '' usb; do
+ if test -z "$ac_lib"; then
+ ac_res="none required"
+ else
+ ac_res=-l$ac_lib
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ fi
+ if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_search_usb_find_busses=$ac_res
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext
+ if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+ break
+fi
+done
+if test "${ac_cv_search_usb_find_busses+set}" = set; then :
+
+else
+ ac_cv_search_usb_find_busses=no
+fi
+rm conftest.$ac_ext
+LIBS=$ac_func_search_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_usb_find_busses" >&5
+$as_echo "$ac_cv_search_usb_find_busses" >&6; }
+ac_res=$ac_cv_search_usb_find_busses
+if test "$ac_res" != no; then :
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+ newlibusb=false
+else
+ as_fn_error "Missing libusb!" "$LINENO" 5
+fi
+
+fi
+
+ if test x$newlibusb = xtrue; then
+ NEW_LIBUSB_TRUE=
+ NEW_LIBUSB_FALSE='#'
+else
+ NEW_LIBUSB_TRUE='#'
+ NEW_LIBUSB_FALSE=
+fi
+
+
# Check whether --enable-ldconfig was given.
if test "${enable_ldconfig+set}" = set; then :
enableval=$enable_ldconfig;
@@ -11548,8 +11693,11 @@ else
fi
+
ac_config_files="$ac_config_files Makefile examples/Makefile"
+ac_config_files="$ac_config_files libphidget21.pc"
+
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
@@ -11731,6 +11879,10 @@ if test -z "${LABVIEW_TRUE}" && test -z "${LABVIEW_FALSE}"; then
as_fn_error "conditional \"LABVIEW\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
fi
+if test -z "${NEW_LIBUSB_TRUE}" && test -z "${NEW_LIBUSB_FALSE}"; then
+ as_fn_error "conditional \"NEW_LIBUSB\" was never defined.
+Usually this means the macro was only invoked conditionally." "$LINENO" 5
+fi
if test -z "${RUN_LDCONFIG_TRUE}" && test -z "${RUN_LDCONFIG_FALSE}"; then
as_fn_error "conditional \"RUN_LDCONFIG\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
@@ -12147,7 +12299,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by Phidget21 C Library $as_me 2.1.8.20120216, which was
+This file was extended by Phidget21 C Library $as_me 2.1.8.20120507, which was
generated by GNU Autoconf 2.64. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -12203,7 +12355,7 @@ Phidget21 C Library home page: <www.phidgets.com>."
_ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_version="\\
-Phidget21 C Library config.status 2.1.8.20120216
+Phidget21 C Library config.status 2.1.8.20120507
configured by $0, generated by GNU Autoconf 2.64,
with options \\"`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
@@ -12572,6 +12724,7 @@ do
"libtool") CONFIG_COMMANDS="$CONFIG_COMMANDS libtool" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"examples/Makefile") CONFIG_FILES="$CONFIG_FILES examples/Makefile" ;;
+ "libphidget21.pc") CONFIG_FILES="$CONFIG_FILES libphidget21.pc" ;;
*) as_fn_error "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac