aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 793dbd8..5e0ccf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,9 @@
AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/utils -I$(top_srcdir)/dict -I$(top_srcdir)/linux -I$(top_srcdir)/include -D_LINUX
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libphidget21.pc
+
lib_LTLIBRARIES = libphidget21.la
# Rules for unpdating the libtool version:
@@ -85,7 +88,6 @@ libphidget21_la_SOURCES = cphidget.c \
cthread.h \
phidget21.c \
phidget21int.h \
- linux/cusblinux.c \
dict/pdict.c \
dict/pdict.h \
dict/pdictclient.c \
@@ -119,6 +121,7 @@ EXTRA_DIST = examples/ifkit.c \
hotplug/phidgets.usermap \
hotplug/phidgets \
version.sh \
+ libphidget21.pc.in \
Java/com/phidgets/DictionaryKeyListener.java \
Java/com/phidgets/TextLCDPhidget.java \
Java/com/phidgets/SpatialEventData.java \
@@ -231,6 +234,12 @@ libphidget21_la_SOURCES += utils/cvtutf.c
libphidget21_la_SOURCES += utils/cvtutf.h
AM_CFLAGS += -DUSE_INTERNAL_UNICONV
endif
+
+if NEW_LIBUSB
+libphidget21_la_SOURCES += linux/cusblinux-1.0.c
+else
+libphidget21_la_SOURCES += linux/cusblinux.c
+endif
if ZEROCONF_AVAHI
libphidget21_la_SOURCES += linux/zeroconf_avahi.c \
@@ -355,11 +364,13 @@ phidget21matlab.h:
@echo "Making $@"
@echo "/*" > $@
@echo " * Phidget21 Header for Matlab" >> $@
- @echo " * -All pointers to structs have been changed to long, as Matlab seems" >> $@
+ @echo " * -All pointers to structs have been changed to void *, as Matlab seems" >> $@
@echo " * to be unhappy with either the undefined stucts or the double pointers." >> $@
@echo " */" >> $@
- @$(CC) -g -E -P -D_LINUX -DEXTERNALPROTO -DREMOVE_DEPRECATED phidget21int.h | sed -e "s/extern \"C\" //g" | sed -e "s/struct [a-zA-Z_]* \*/long /" >> $@
+ @cat cppheader >> $@
+ @$(CC) -g -E -P -D_LINUX -DEXTERNALPROTO -DREMOVE_DEPRECATED phidget21int.h | sed -e "s/extern \"C\" //g" | sed -e "s/struct [a-zA-Z_]* \*/void * /" >> $@
@cat cphidgetconstants.h >> $@
+ @cat cppfooter >> $@
phidget21.jar:
@echo "Making $@"