aboutsummaryrefslogtreecommitdiffstats
path: root/Java/phidget_jni.h
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2013-03-03 20:04:36 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2013-03-03 20:04:36 +0000
commit571d570e1be6f783a2e8ef0dafa838e9d82f923e (patch)
tree9b18682751acba56d650129922ecc4c5f12a3469 /Java/phidget_jni.h
parent62172377c57ff85bce35a43e0ca3e76f67a473ad (diff)
parent4e6290d8e2dc4dcd784102bdab18d7e1854e11c0 (diff)
downloadlibphidget21-squeeze-backports.tar.gz
Merge branch 'master' into squeeze-backportssqueeze-backports
Conflicts: debian/changelog
Diffstat (limited to 'Java/phidget_jni.h')
-rw-r--r--Java/phidget_jni.h1
1 files changed, 1 insertions, 0 deletions
diff --git a/Java/phidget_jni.h b/Java/phidget_jni.h
index 2325fd0..61c675d 100644
--- a/Java/phidget_jni.h
+++ b/Java/phidget_jni.h
@@ -109,6 +109,7 @@ void com_phidgets_##Pname##Phidget_OnLoad(JNIEnv *env) \
if (!(eobj = (*env)->NewObject(env, ph_exception_class, ph_exception_cons, errno, edesc))) \
JNI_ABORT_STDERR("Couldn't get NewObject ph_exception_class"); \
(*env)->Throw(env, (jthrowable)eobj); \
+ (*env)->ExceptionClear(env); \
}
#define JNI_INDEXED_SETFUNC(pname, fname, lfname, type) \