aboutsummaryrefslogtreecommitdiffstats
path: root/Java/com_phidgets_LEDPhidget.h
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2013-03-03 20:04:36 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2013-03-03 20:04:36 +0000
commit571d570e1be6f783a2e8ef0dafa838e9d82f923e (patch)
tree9b18682751acba56d650129922ecc4c5f12a3469 /Java/com_phidgets_LEDPhidget.h
parent62172377c57ff85bce35a43e0ca3e76f67a473ad (diff)
parent4e6290d8e2dc4dcd784102bdab18d7e1854e11c0 (diff)
downloadlibphidget21-squeeze-backports.tar.gz
Merge branch 'master' into squeeze-backportssqueeze-backports
Conflicts: debian/changelog
Diffstat (limited to 'Java/com_phidgets_LEDPhidget.h')
-rw-r--r--Java/com_phidgets_LEDPhidget.h36
1 files changed, 34 insertions, 2 deletions
diff --git a/Java/com_phidgets_LEDPhidget.h b/Java/com_phidgets_LEDPhidget.h
index be631c8..0fe8e65 100644
--- a/Java/com_phidgets_LEDPhidget.h
+++ b/Java/com_phidgets_LEDPhidget.h
@@ -180,7 +180,7 @@ JNIEXPORT jlong JNICALL Java_com_phidgets_LEDPhidget_create
* Method: getCurrentLimit
* Signature: ()I
*/
-JNIEXPORT jint JNICALL Java_com_phidgets_LEDPhidget_getCurrentLimit
+JNIEXPORT jint JNICALL Java_com_phidgets_LEDPhidget_getCurrentLimit__
(JNIEnv *, jobject);
/*
@@ -188,7 +188,7 @@ JNIEXPORT jint JNICALL Java_com_phidgets_LEDPhidget_getCurrentLimit
* Method: setCurrentLimit
* Signature: (I)V
*/
-JNIEXPORT void JNICALL Java_com_phidgets_LEDPhidget_setCurrentLimit
+JNIEXPORT void JNICALL Java_com_phidgets_LEDPhidget_setCurrentLimit__I
(JNIEnv *, jobject, jint);
/*
@@ -231,6 +231,38 @@ JNIEXPORT jint JNICALL Java_com_phidgets_LEDPhidget_getDiscreteLED
JNIEXPORT void JNICALL Java_com_phidgets_LEDPhidget_setDiscreteLED
(JNIEnv *, jobject, jint, jint);
+/*
+ * Class: com_phidgets_LEDPhidget
+ * Method: getBrightness
+ * Signature: (I)D
+ */
+JNIEXPORT jdouble JNICALL Java_com_phidgets_LEDPhidget_getBrightness
+ (JNIEnv *, jobject, jint);
+
+/*
+ * Class: com_phidgets_LEDPhidget
+ * Method: setBrightness
+ * Signature: (ID)V
+ */
+JNIEXPORT void JNICALL Java_com_phidgets_LEDPhidget_setBrightness
+ (JNIEnv *, jobject, jint, jdouble);
+
+/*
+ * Class: com_phidgets_LEDPhidget
+ * Method: getCurrentLimit
+ * Signature: (I)D
+ */
+JNIEXPORT jdouble JNICALL Java_com_phidgets_LEDPhidget_getCurrentLimit__I
+ (JNIEnv *, jobject, jint);
+
+/*
+ * Class: com_phidgets_LEDPhidget
+ * Method: setCurrentLimit
+ * Signature: (ID)V
+ */
+JNIEXPORT void JNICALL Java_com_phidgets_LEDPhidget_setCurrentLimit__ID
+ (JNIEnv *, jobject, jint, jdouble);
+
#ifdef __cplusplus
}
#endif