aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 22:56:23 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 22:56:23 +0000
commit429e46051dba814e7d6c74368eb1bba550222cbe (patch)
treeed1dd43cd23c69f156aae2165006a16a66262cef /configure.ac
parent58bf1382be0cbcf3f9649286fd2719b789a1595f (diff)
downloadlibconfig-429e46051dba814e7d6c74368eb1bba550222cbe.tar.gz
Imported Upstream version 1.4.8upstream/1.4.8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 37 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index c142217..b73e1fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,19 +1,27 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(libconfig.c)
+AC_INIT(libconfig, 1.4.8, hyperrealm@gmail.com, libconfig,
+ [http://www.hyperrealm.com/main.php?s=libconfig])
+AC_CONFIG_AUX_DIR([aux-build])
+AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE(libconfig, 1.3.2)
-
+AM_INIT_AUTOMAKE
AM_CONFIG_HEADER(ac_config.h)
+
+AC_MSG_NOTICE([libconfig - made with pride in California])
+sleep 3
+
AC_DEFINE_UNQUOTED(TARGET, "${target}", [Configured target name.])
-AH_TEMPLATE(_GNU_SOURCE)
-AC_DEFINE(_GNU_SOURCE)
+# Enable GNU extensions.
+AC_GNU_SOURCE
+
+LT_INIT()
dnl Checks for programs.
-dnl AC_PROG_INSTALL
AC_PROG_CC
-AC_PROG_RANLIB
+AM_PROG_CC_C_O
+AC_PROG_CXX
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
@@ -47,8 +55,8 @@ dnl Enable warnings, if we can determine an appropriate switch...
case "${CC}" in
gcc)
- warn_c_sw="-Wall -Wshadow -Wdeclaration-after-statement"
- warn_cxx_sw="-Wall -Wshadow";;
+ warn_c_sw="-Wall -Wshadow -Wextra -Wdeclaration-after-statement -Wno-unused-parameter"
+ warn_cxx_sw="-Wall -Wshadow -Wextra -Wno-unused-parameter";;
*)
warn_cxx_sw=""
warn_c_sw="";;
@@ -83,13 +91,24 @@ AC_ARG_ENABLE(cxx,
AS_HELP_STRING([--disable-cxx], [Disable building of the C++ library]),
[if test "$enableval" = "no"; then docxx="no"; fi],
[
-AC_PROG_CXX
docxx=yes
]
)
AM_CONDITIONAL(BUILDCXX, test x$docxx = xyes)
+doexamples=yes
+
+AC_ARG_ENABLE(examples,
+AS_HELP_STRING([--disable-examples], [Disable building of the example programs]),
+[if test "$enableval" = "no"; then doexamples="no"; fi],
+[
+doexamples=yes
+]
+)
+
+AM_CONDITIONAL(BUILDEXAMPLES, test x$doexamples = xyes)
+
dnl Check for MinGW. Workaround for libtool's DLL_EXPORT stupidity.
case "$target" in
@@ -103,11 +122,14 @@ dnl Checks for library functions.
AC_OUTPUT(
Makefile
+ lib/Makefile
+ lib/libconfig.pc
+ lib/libconfig++.pc
doc/Makefile
- samples/Makefile
- samples/c/Makefile
- samples/c++/Makefile
- libconfig.pc
- libconfig++.pc
+ examples/Makefile
+ examples/c/Makefile
+ examples/c++/Makefile
+ tinytest/Makefile
+ tests/Makefile
libconfig.spec
)