aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 22:56:23 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2011-12-01 22:56:23 +0000
commit429e46051dba814e7d6c74368eb1bba550222cbe (patch)
treeed1dd43cd23c69f156aae2165006a16a66262cef /ChangeLog
parent58bf1382be0cbcf3f9649286fd2719b789a1595f (diff)
downloadlibconfig-429e46051dba814e7d6c74368eb1bba550222cbe.tar.gz
Imported Upstream version 1.4.8upstream/1.4.8
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog230
1 files changed, 230 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 18816e0..1df3387 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,233 @@
+ ----- version 1.4.8 ------
+
+2011-08-04 Mark Lindner <markl@neuromancer>
+
+ * tests/Makefile.am - marked 'libconfig_tests' as non-installable
+ * lib/scanner.l, lib/grammar.y - grammar changes to make trailing
+ semicolons optional (and to allow commas as an alternative)
+ * lib/libconfig.c - bugfixes for lack of auto-conversion handling in
+ the config_lookup*() functions (reported by Feng Yu), and some
+ fixes for compiler warnings
+ * lib/Makefile.am - bump .so version
+ * configure.ac - bump version, add '-Wno-unused-parameter' compiler
+ switch to disable "unused parameter" warnings
+ * doc/libconfig.texi - documentation updates; added a chapter that
+ calls attention to the bundled example programs
+ * lib/libconfig.h, lib/libconfig.h++ - bump versions
+
+ ----- version 1.4.7 ------
+
+2011-03-11 Mark Lindner <markl@neuromancer>
+
+ * doc/libconfig.texi - fixed typo; updated docs
+ * TODO - updated list
+ * lib/libconfig.c, lib/libconfig.h, lib/libconfigcpp.c++,
+ lib/libconfig.h++ - added config{get,set}_default_format(),
+ Config::{get,set}DefaultFormat()
+
+2011-03-10 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c - fixed memory leak when encountering a parse error
+ in an @include'd file
+ * lib/libconfig.h, lib/libconfig.h++, lib/Makefile.am, configure.ac,
+ doc/libconfig.texi - bump versions
+
+ ----- version 1.4.6 ------
+
+2010-09-10 Mark Lindner <markl@neuromancer>
+
+ * doc/libconfig.texi - documentation updates
+ * lib/libconfig.c, lib/libconfigcpp.c++, lib/libconfig.h,
+ lib/libconfig.h++, lib/wincompat.h, lib/scanctx.c - added support
+ for specifying an include directory
+ * m4/* - added local m4 directory
+ * contrib/* - added user-contributed files
+
+2010-09-07 Mark Lindner <markl@neuromancer>
+
+ * lib/scanner.l - bugfix for parse error when there is a missing
+ newline at the end of the file
+ * lib/libconfig.h, lib/libconfig.h++, lib/Makefile.am - bump version
+ * tinytest/* - added a simple unit testing framework
+ * tests/* - added preliminary unit tests
+ * configure.ac, ac_config.h, ac_config.h.in, Makefile.am,
+ lib/Makefile.am, libtool, doc/libconfig.texi - bump versions/dates
+ * lib/grammar.h, lib/grammar.c - regenerated with newer version of
+ Bison
+ * lib/libconfig.c - bugfix: explicitly set starting line number to 1
+ when parsing from strings; otherwise line numbers reported in parse
+ errors are undefined
+
+ ----- version 1.4.5 ------
+
+2010-05-04 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.h, lib/libconfig.h++, lib/Makefile.am - bumped version
+ numbers; removed #include for <map> and added one for <exception>
+ * lib/libconfigcpp.c++ - bugfix: properly handle TypeInt64 in add() and
+ assertType()
+ * aux-build/*, ac_config.h, configure.ac, ac_config.h.in, libtool -
+ regenerated with newer autotools
+ * libconfig.c - added declaration of libconfig_yylex_init_extra() to
+ eliminate compiler warning
+ * scanner.l - added #define YY_NO_INPUT to prevent compiler warning
+ * libconfig.texi - Added example code for operator=()
+
+ ----- version 1.4.4 ------
+
+2010-04-12 Mark Lindner <markl@neuromancer>
+
+ * lib/Makefile.am - fixed shared library version info
+ * lib/libconfig.h++ - added Setting::c_str() method
+ * configure.ac, ac_config.h, libconfig.spec, lib/libconfig.h,
+ lib/libconfig.h++ - bump versions
+ * lib/wincompat.h - fixed MinGW build error
+ * doc/libconfig.texi - doc updates
+ * README - added MinGW info
+
+ ----- version 1.4.3 ------
+
+2010-02-13 Mark Lindner <markl@neuromancer>
+
+ * lib/scanner.l - bugfix for matching @include with preceding
+ whitespace
+
+ ----- version 1.4.2 ------
+
+2010-01-19 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfigcpp.c++, lib/libconfig.h++ - bugfix for crash; added
+ copy constructor for ParseException (from Frederic Heitzmann)
+ * lib/libconfig.h, lib/libconfig.h++, lib/Makefile.am,
+ ac_config.h, libconfig.spec, configure.ac - bump versions
+
+2010-01-09 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfigcpp.c++ - bugfix in ParseException constructor (from
+ Ilya Dogolazky)
+ * debian/* - more cleanup, and added debug rules (from Ilya Dogolazky)
+
+ ----- version 1.4.1 ------
+
+2009-12-31 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c - bugfix for crash; removed unnecessary buffer delete
+ in __config_read()
+ * examples/c/Makefile.am, examples/c++/Makefile.am - fixed build issue
+ * configure.ac, Makefile.am - Added `--disable-examples' configure
+ option
+ * configure.ac, lib/Makefile.am, libconfig.spec, ac_config.h - bumped
+ version numbers
+
+ ----- version 1.4 ------
+
+2009-10-24 Mark Lindner <markl@neuromancer>
+
+ * grammar.y, scanner.l - properly report @include errors
+ * exmaples/example4.cpp - new example added
+
+2009-10-14 Mark Lindner <markl@neuromancer>
+
+ * debian/* - more fixes; from Klaus Schneider-Zapp
+ * libconfig.c - when writing strings, escape only control characters
+ with \x
+
+ ----- version 1.4b4 ------
+
+2009-09-09 Mark Lindner <markl@neuromancer>
+
+ * lib/Makefile.am - fixed MinGW build issues
+
+ ----- version 1.4b3 ------
+
+2009-09-04 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c, lib/scanner.l, lib/grammar.y - fixed all memory
+ leaks reported by Valgrind; removed an unncessary strdup()/free().
+
+2009-09-01 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c, lib/libconfig.h, lib/libconfigcpp.c++,
+ lib/libconfig.h++ - added config_error_type() and fixed a segfault
+ when throwing a ParseException.
+ * doc/libconfig.texi - doc updates
+
+ ----- version 1.4b2 ------
+
+2009-08-29 Mark Lindner <markl@neuromancer>
+
+ * examples/* - added new example programs to replace the less
+ practical ones in samples/
+
+2009-08-25 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c, lib/libconfig.h, lib/libconfigcpp.c++,
+ lib/libconfig.h++ - added config_set_tab_width(),
+ config_get_tab_width() and Config::setTabWidth(),
+ Config::getTabWidth().
+ * doc/libconfig.texi - doc updates
+
+ ----- version 1.4b1 ------
+
+2009-08-21 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.h++, lib/libconfigcpp.c++ - broke the public
+ dependency on libconfig.h; updated VC++ projects on Windows so that
+ the C++ DLL no longer exports any of the C API functions
+ * debian/* - updated for version 1.4
+ * lib/libconfig.c - fixed an isprint() assertion on Windows
+
+2009-08-20 Mark Lindner <markl@neuromancer>
+
+ * lib/parsectx.c, lib/parsectx.h, lib/scanctx.c, lib/scanctx.h,
+ lib/strbuf.c, lib/strbuf.h - code refactoring to reduce library size
+ lib/Makefile.am - fixed 'make install' error
+
+ ----- version 1.4b ------
+
+2009-08-16 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c, lib/libconfig.h, lib/scanctx.c, lib/scanctx.h,
+ lib/grammar.y, lib/grammar.c, lib/grammar.h - added
+ config_read_string(); added config_setting_source_file() and
+ management of list of input file names; added #ifdef guard for
+ DllMain() function so that it's not included for static library
+ builds
+ * lib/libconfigcpp.c++, lib/libconfig.h++ - added filename to
+ ParseException; bugfix in Setting::setFormat(); made what() methods
+ of exceptions public; added Setting::getSourceFile(),
+ Config::readString().
+ * doc/libconfig.texi - documentation updates
+ * lib/Makefile.am - bump .so version
+ * ac_config.h, configure.ac, libtool - bump version
+
+2009-07-19 Mark Lindner <markl@neuromancer>
+
+ * lib/libconfig.c, lib/libconfig.h, lib/libconfigcpp.c++,
+ lib/libconfig.h++ - added config_read_string() and
+ Config::readString() functions (contributed by Matthias Weisser).
+
+2009-07-02 Mark Lindner <markl@neuromancer>
+
+ * lib/parsectx.c, lib/parsectx.h, lib/scanctx.c, lib/scanctx.h,
+ lib/scanner.l, lib/grammar.y, lib/private.h, lib/Makefile.am,
+ lib/libconfig.c, lib/libconfig.h - replaced ugly C code in scanner.l
+ for processing strings with a new <STRING> scanner state and
+ associated rules; added support for hex character literals (\xNN) in
+ strings; refactored scanner and parser context into separate source
+ files; added preliminary support for include files ("@include"
+ directive).
+
+2009-05-27 Mark Lindner <markl@neuromancer>
+
+ * ltmain.sh, ac_config.h, ac_config.h.in, configure.ac, libconfig.spec,
+ libtool - upgraded to newer versions of autotools
+ * grammar.y, grammar.h, grammar.c, libconfigcpp.c++, libconfig.h++,
+ libconfig.c, libconfig.h - added LIBCONFIG_VER_* macros, changed API
+ to replace 'long' and 'unsigned long' with 'int' and 'unsigned int'
+ to resolve a portability problem; added 'const' to declarations of
+ getLine() and getError() methods on ParseException
+ * <multiple> - directory structure reorg
----- version 1.3.2 ------