aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-04-26 19:14:33 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-04-28 13:52:15 +0100
commit8372701cac22aa2bc3529a9e8cf04e7103417dc7 (patch)
tree6ebd96c674eb3de47cae98f0c77ec0f0fd5b4bf9
parentae8fe03ecbed9c7ebb32edcd6adcad80d3b9d1d1 (diff)
downloadlibconfig-8372701cac22aa2bc3529a9e8cf04e7103417dc7.tar.gz
Switch to dh_9 style rules file
Hardened buildflags now provided automatically Fixes E-binary-arch-produces-all buildd warning
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules102
2 files changed, 16 insertions, 94 deletions
diff --git a/debian/changelog b/debian/changelog
index 08a5e84..706eb12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libconfig (1.4.8-5) UNRELEASED; urgency=low
+
+ * Switch to dh_9 style rules file
+ - Hardened buildflags now provided automatically
+ - Fixes E-binary-arch-produces-all buildd warning
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Fri, 27 Apr 2012 01:50:40 +0100
+
libconfig (1.4.8-4) unstable; urgency=low
* Add C++ hardened buildflags
diff --git a/debian/rules b/debian/rules
index 4de4b58..b070a1e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,101 +1,15 @@
#!/usr/bin/make -f
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-
-CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
-CFLAGS += -Wall -g
-CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
-CXXFLAGS += -Wall -g
-LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
-LDFLAGS += -Wl,-z,defs
-CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
-export CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
-
-# shared library versions, option 1
-version=9
-major=9
-minor=0
-
-
-config.status: configure
- dh_testdir
- test -e config.sub -a -L config.sub || \
- ln -sf /usr/share/misc/config.sub config.sub
- test -e config.guess -a -L config.guess || \
- ln -sf /usr/share/misc/config.guess config.guess
-
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info
-
-build: build-arch build-indep
-
-build-arch: build-stamp
-
-build-indep: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
+# Uncomment this to turn on verbose mode.
+# # export DH_VERBOSE=1
+override_dh_auto_build:
$(MAKE) -C doc pdf
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
-
- [ ! -f Makefile ] || $(MAKE) distclean
-
- rm -f build-stamp
-
- $(RM) config.guess config.sub config.log
- dh_clean
+ dh_auto_build
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- # Add here commands to install the package into debian/tmp
- $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
- $(RM) .libs/*.la
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_install
- dh_installinfo
- dh_installman
- dh_link
+override_dh_strip:
dh_strip -p libconfig9 --dbg-package=libconfig-dbg
dh_strip -p libconfig++9 --dbg-package=libconfig++-dbg
- dh_compress
- dh_fixperms
- dh_makeshlibs -p libconfig9
- dh_makeshlibs -p libconfig++9
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+
+%:
+ dh $@ --with autotools-dev