aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 2 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 746e4a8..c2121c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,9 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -37,9 +31,6 @@ config.status: configure
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
--bindir=/usr/sbin \
- --with-x \
- --x-includes=/usr/include \
- --x-lib=/usr/lib \
--with-python
# call this target to update config.sub and config.guess
@@ -70,12 +61,9 @@ install: build
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/lcd4linux
+binary-indep:
+# No arch independent things to do here...
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot