aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bffb449..f3509d9 100644
--- a/configure.in
+++ b/configure.in
@@ -58,8 +58,14 @@ AC_CHECK_HEADERS(usb.h, [has_usb="true"], [has_usb="false"])
AC_CHECK_HEADERS(serdisplib/serdisp.h, [has_serdisplib="true"], [has_serdisplib="false"])
# check for python
-sinclude(python.m4)
-AC_PYTHON_DEVEL
+AC_MSG_CHECKING(if python support is wanted)
+AC_ARG_WITH(python,
+[ --with-python enable python support [[default=no]]],
+[AC_MSG_RESULT($withval)], [AC_MSG_RESULT(no)])
+if test "$with_python" = "yes"; then
+ sinclude(python.m4)
+ AC_PYTHON_DEVEL
+fi
# drivers
sinclude(drivers.m4)