aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 19ca835..84af611 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
-# $Id: configure.in 1158 2011-07-28 02:09:16Z michael $
+# $Id: configure.in 1165 2011-12-26 06:28:05Z michael $
# $URL: https://ssl.bulix.org/svn/lcd4linux/trunk/configure.in $
@@ -105,7 +105,11 @@ if test "$with_python" = "yes"; then
fi
# check for parport
-#AC_CHECK_HEADERS(asm/io.h)
+AC_MSG_CHECKING(if raw port I/O is wanted)
+AC_ARG_WITH(outb,
+[ --with-outb enable raw port I/O support [[default=no]]],
+[AC_MSG_RESULT($withval)], [AC_MSG_RESULT(no)])
+
AC_CHECK_HEADERS([asm/io.h] [linux/parport.h linux/ppdev.h], [has_parport="true"], [has_parport="false"])
# drivers
@@ -157,10 +161,10 @@ AC_OUTPUT
AC_MSG_RESULT(
[-----------------------------------------]
-[including drivers:]
+[included drivers:]
[ $DRIVERS]
[-----------------------------------------]
-[including plugins:]
+[included plugins:]
[ $PLUGINS]
[-----------------------------------------]
)