aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 38 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 4142656..3e2ed42 100644
--- a/configure.in
+++ b/configure.in
@@ -2,13 +2,13 @@
# Process this file with autoconf to produce a configure script.
-# $Id: configure.in 773 2007-02-25 12:39:09Z michael $
-# $URL: https://ssl.bulix.org/svn/lcd4linux/branches/0.10.1/configure.in $
+# $Id: configure.in 1069 2009-11-21 18:19:09Z edman007 $
+# $URL: https://ssl.bulix.org/svn/lcd4linux/trunk/configure.in $
# LCD4Linux autoconf script
#
-# Copyright (C) 1999, 2000, 2001, 2002, 2003 Michael Reinelt <reinelt@eunet.at>
+# Copyright (C) 1999, 2000, 2001, 2002, 2003 Michael Reinelt <michael@reinelt.co.at>
# Copyright (C) 2004, 2005, 2006, 2007 The LCD4Linux Team <lcd4linux-devel@users.sourceforge.net>
#
# This file is part of LCD4Linux.
@@ -28,9 +28,9 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
AC_PREREQ(2.59)
-AC_INIT([LCD4Linux],[0.10.1-RC2],[lcd4linux-users@lists.sourceforge.net])
+AC_INIT([LCD4Linux],[0.11.0-SVN],[lcd4linux-users@lists.sourceforge.net])
AC_CONFIG_SRCDIR([lcd4linux.c])
-AM_INIT_AUTOMAKE([lcd4linux],0.10.1-RC2)
+AM_INIT_AUTOMAKE([lcd4linux],0.11.0-SVN)
AM_CONFIG_HEADER(config.h)
# Checks for programs.
@@ -39,6 +39,7 @@ AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
+PKG_PROG_PKG_CONFIG
# dmalloc
AM_WITH_DMALLOC
@@ -65,6 +66,9 @@ fi
# check for gd.h
AC_CHECK_HEADERS(gd/gd.h gd.h, [has_gd="true"; break], [has_gd="false"])
+# check for sys/io.h (RouterBoard driver)
+AC_CHECK_HEADERS(sys/io.h, [has_io_h="true"], [has_io_h="false"])
+
# check for usb.h
AC_CHECK_HEADERS(usb.h, [has_usb="true"], [has_usb="false"])
@@ -74,19 +78,33 @@ AC_CHECK_HEADERS(luise.h, [has_luise="true"], [has_luise="false"])
# check for serdisplib
AC_CHECK_HEADERS(serdisplib/serdisp.h, [has_serdisplib="true"], [has_serdisplib="false"])
+# check for st2205 libs
+AC_CHECK_HEADERS(st2205.h, [has_st2205="true"], [has_st2205="false"])
+
+# check for vncserver libs
+AC_CHECK_HEADERS(rfb/rfb.h, [has_vncserverlib="true"], [has_vncserverlib="false"])
+
# check for LCD-Linux
AC_CHECK_HEADERS(linux/lcd-linux.h linux/hd44780.h, [has_lcd_linux="true"], [has_lcd_linux="false"; break])
+# check for ftdi.h (ULA200)
+AC_CHECK_HEADERS(ftdi.h, [has_ftdi="true"], [has_ftdi="false"; break])
+
# check for python
AC_MSG_CHECKING(if python support is wanted)
AC_ARG_WITH(python,
[ --with-python enable python support [[default=no]]],
[AC_MSG_RESULT($withval)], [AC_MSG_RESULT(no)])
+
if test "$with_python" = "yes"; then
- sinclude(ax_python_devel.m4)
- AC_PYTHON_DEVEL
+ sinclude(ax_python_devel.m4)
+ AC_PYTHON_DEVEL
fi
+# check for parport
+#AC_CHECK_HEADERS(asm/io.h)
+AC_CHECK_HEADERS([asm/io.h] [linux/parport.h linux/ppdev.h], [has_parport="true"], [has_parport="false"])
+
# drivers
sinclude(drivers.m4)
@@ -97,8 +115,6 @@ sinclude(plugins.m4)
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h sys/vfs.h syslog.h termios.h unistd.h])
-AC_CHECK_HEADERS(sys/io.h asm/io.h)
-AC_CHECK_HEADERS(linux/parport.h linux/ppdev.h)
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -135,3 +151,16 @@ AC_CHECK_FUNCS([dup2 floor gethostbyname gettimeofday memmove memset pow putenv
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
+
+AC_MSG_RESULT(
+[-----------------------------------------]
+[including drivers:]
+[ $DRIVERS]
+[-----------------------------------------]
+[including plugins:]
+[ $PLUGINS]
+[-----------------------------------------]
+)
+
+AC_CONFIG_MACRO_DIR([m4])
+LT_INIT