aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f835144..dd40acd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,6 @@
+# $Id: Makefile.am 760 2007-02-04 06:29:55Z michael $
+# $URL: https://ssl.bulix.org/svn/lcd4linux/branches/0.10.1/Makefile.am $
+
# Process this file with automake to produce Makefile.in
AUTOMAKE_OPTIONS = gnu
@@ -15,7 +18,7 @@ lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
lcd4linux_SOURCES = \
-lcd4linux.c \
+lcd4linux.c svn_version.h \
cfg.c cfg.h \
debug.c debug.h \
drv.c drv.h \
@@ -66,6 +69,7 @@ drv_BWCT.c \
drv_Crystalfontz.c \
drv_Curses.c \
drv_Cwlinux.c \
+drv_EA232graphic.c \
drv_G15.c \
drv_HD44780.c \
drv_Image.c \
@@ -80,6 +84,7 @@ drv_MatrixOrbital.c \
drv_MilfordInstruments.c \
drv_Noritake.c \
drv_NULL.c \
+drv_picoLCD.c \
drv_RouterBoard.c \
drv_Sample.c \
drv_serdisplib.c \
@@ -92,6 +97,7 @@ drv_WincorNixdorf.c \
drv_X11.c \
\
font_6x8.h \
+font_6x8_bold.h \
widget_image.c widget_image.h \
\
lcd4linux_i2c.h \
@@ -103,6 +109,7 @@ plugin_dvb.c \
plugin_exec.c \
plugin_file.c \
plugin_i2c_sensors.c \
+plugin_iconv.c \
plugin_imon.c \
plugin_isdn.c \
plugin_kvv.c \
@@ -125,20 +132,29 @@ plugin_xmms.c
EXTRA_DIST = \
+svn_version.sh \
lcd4linux.conf.sample \
lcd4kde.conf \
lcd4linux.kdelnk \
lcd4linux.xpm \
lcd4linux.lsm \
+ac_python_devel.m4 \
curses.m4 \
+drivers.m4 \
+plugins.m4 \
AUTHORS \
CREDITS \
-FAQ \
NEWS \
TODO \
README \
-README.Drivers \
-README.Plugins \
-README.KDE \
plugin_sample.c
+
+
+# create subversion version
+
+.PHONY: svn_version
+
+svn_version:
+ svn_version.sh
+