aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 37 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 6469f9a..ed5a4e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
-# $Id: Makefile.am 773 2007-02-25 12:39:09Z michael $
-# $URL: https://ssl.bulix.org/svn/lcd4linux/branches/0.10.1/Makefile.am $
+# $Id: Makefile.am 1137 2011-01-02 00:39:10Z michael $
+# $URL: https://ssl.bulix.org/svn/lcd4linux/trunk/Makefile.am $
# Process this file with automake to produce Makefile.in
@@ -11,12 +11,14 @@ PLUGINS=@PLUGINS@
bin_PROGRAMS = lcd4linux
# Fixme: -W should be renamed to -Wextra someday...
-AM_CFLAGS = -D_GNU_SOURCE -Wall -W -fno-strict-aliasing
+AM_CFLAGS = -D_GNU_SOURCE -Wall -Wextra -fno-strict-aliasing
+LIBTOOL=libtool
+ACLOCAL_AMFLAGS=-I m4
# use this for lots of warnings
-#AM_CFLAGS = -D_GNU_SOURCE -std=c90 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
+#AM_CFLAGS = -D_GNU_SOURCE -std=c99 -m64 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
-lcd4linux_LDFLAGS =
+lcd4linux_LDFLAGS =
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
@@ -32,10 +34,12 @@ hash.c hash.h \
layout.c layout.h \
pid.c pid.h \
timer.c timer.h \
+timer_group.c timer_group.h \
thread.c thread.h \
udelay.c udelay.h \
qprintf.c qprintf.h \
rgb.c rgb.h \
+event.c event.h \
\
widget.c widget.h \
widget_text.c widget_text.h \
@@ -67,35 +71,51 @@ drv_generic_i2c.c \
drv_generic_i2c.h \
drv_generic_keypad.c \
drv_generic_keypad.h \
+drv_ASTUSB.c \
drv_BeckmannEgle.c \
drv_BWCT.c \
drv_Crystalfontz.c \
drv_Curses.c \
drv_Cwlinux.c \
+drv_D4D.c \
drv_EA232graphic.c \
+drv_EFN.c \
+drv_FW8888.c \
drv_G15.c \
+drv_GLCD2USB.c glcd2usb.h \
drv_HD44780.c \
drv_Image.c \
+drv_IRLCD.c \
drv_LCD2USB.c \
drv_LCDLinux.c \
drv_LCDTerm.c \
drv_LEDMatrix.c \
drv_LPH7508.c \
drv_LUIse.c \
+drv_LW_ABP.c \
drv_M50530.c \
drv_MatrixOrbital.c \
+drv_MatrixOrbitalGX.c \
drv_MilfordInstruments.c \
drv_Noritake.c \
drv_NULL.c \
+drv_Pertelian.c \
+drv_PHAnderson.c \
+drv_PICGraphic.c \
drv_picoLCD.c \
+drv_picoLCDGraphic.c \
drv_RouterBoard.c \
drv_Sample.c \
+drv_st2205.c \
drv_serdisplib.c \
+drv_ShuttleVFD.c \
drv_SimpleLCD.c \
drv_T6963.c \
drv_Trefon.c \
+drv_ula200.c \
drv_USBHUB.c \
drv_USBLCD.c \
+drv_vnc.c \
drv_WincorNixdorf.c \
drv_X11.c \
\
@@ -106,11 +126,18 @@ widget_image.c widget_image.h \
lcd4linux_i2c.h \
\
plugin_apm.c \
+plugin_asterisk.c \
+plugin_button_exec.c \
plugin_cpuinfo.c \
+plugin_dbus.c \
plugin_diskstats.c \
plugin_dvb.c \
plugin_exec.c \
+plugin_fifo.c \
plugin_file.c \
+plugin_gps.c \
+plugin_hddtemp.c \
+plugin_huawei.c \
plugin_i2c_sensors.c \
plugin_iconv.c \
plugin_imon.c \
@@ -119,17 +146,21 @@ plugin_kvv.c \
plugin_loadavg.c \
plugin_meminfo.c \
plugin_mpd.c \
+plugin_mpris_dbus.c \
plugin_mysql.c \
plugin_netdev.c \
+plugin_netinfo.c \
plugin_pop3.c \
plugin_ppp.c \
plugin_proc_stat.c \
plugin_python.c \
+plugin_qnaplog.c \
plugin_sample.c \
plugin_seti.c \
plugin_statfs.c \
plugin_uname.c \
plugin_uptime.c \
+plugin_w1retap.c \
plugin_wireless.c \
plugin_xmms.c
@@ -141,7 +172,7 @@ lcd4kde.conf \
lcd4linux.kdelnk \
lcd4linux.xpm \
lcd4linux.lsm \
-ac_python_devel.m4 \
+ax_python_devel.m4 \
curses.m4 \
drivers.m4 \
plugins.m4 \