aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rwxr-xr-xdebian/config7
-rw-r--r--debian/control16
-rw-r--r--debian/copyright11
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs9
-rw-r--r--debian/init.d47
-rwxr-xr-xdebian/rules95
-rw-r--r--debian/templates7
10 files changed, 201 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ab55325
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+lcd4linux (0.9.11-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Samuel Mimram <samuel.mimram@ens-lyon.org> Wed, 10 Dec 2003 11:48:10 +0100
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/config b/debian/config
new file mode 100755
index 0000000..d84a76e
--- /dev/null
+++ b/debian/config
@@ -0,0 +1,7 @@
+#!/bin/sh -e
+
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
+db_input high lcd4linux/conf
+db_go
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ec0861d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: lcd4linux
+Section: utils
+Priority: extra
+Maintainer: Samuel Mimram <samuel.mimram@ens-lyon.org>
+Build-Depends: debhelper (>= 4.0.0), debconf
+Standards-Version: 3.6.0
+
+Package: lcd4linux
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Display informations on an external liquid crystal display
+ Grab informations from the kernel and some subsystems and display it on an
+ external liquid crystal display.
+ .
+ The use of special sequences (tokens) gives you full control of the layout,
+ and therefore lcd4linux is completely independent from the display size.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..238b93e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,11 @@
+This package was debianized by Samuel Mimram <samuel.mimram@ens-lyon.org> on
+Wed, 10 Dec 2003 11:48:10 +0100.
+
+It was downloaded from http://lcd4linux.sourceforge.net/
+
+Upstream Author: Michael Reinelt <reinelt@eunet.at>
+
+Copyright:
+
+Lcd4linux is placed under GPL.
+Please refer to /usr/share/common-licenses/GPL.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..527b78f
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/lib
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..ff25d8a
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,9 @@
+FAQ
+NEWS
+README
+README.Drivers
+README.KDE
+README.Rows
+README.Tokens
+TODO
+lcd4linux.conf.sample
diff --git a/debian/init.d b/debian/init.d
new file mode 100644
index 0000000..207e038
--- /dev/null
+++ b/debian/init.d
@@ -0,0 +1,47 @@
+#! /bin/sh
+#
+# lcd4linux
+#
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/bin/lcd4linux
+NAME=lcd4linux
+DESC=lcd4linux
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --oknodo --stop --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON
+ echo "$NAME."
+ ;;
+ reload)
+ start-stop-daemon --stop --signal 1 --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON
+ ;;
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ start-stop-daemon --stop --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON
+ sleep 1
+ start-stop-daemon --start --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON
+ echo "$NAME."
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3bddf85
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,95 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DESTDIR=$(CURDIR)/debian/lcd4linux
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+config.status: configure
+ dh_testdir
+ CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+ $(MAKE)
+ #/usr/bin/docbook-to-man debian/lcd4linux.sgml > lcd4linux.1
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ rm -f build-stamp
+ $(MAKE) distclean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) install DESTDIR=$(DESTDIR)
+ mkdir -p $(DESTDIR)/etc
+ cp lcd4linux.conf.sample $(DESTDIR)/etc/lcd4linux.conf
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+# dh_installexamples
+ dh_install
+# dh_installmenu
+ dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+ dh_installinit
+# dh_installcron
+# dh_installinfo
+# dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/templates b/debian/templates
new file mode 100644
index 0000000..2be41c7
--- /dev/null
+++ b/debian/templates
@@ -0,0 +1,7 @@
+Template: lcd4linux/conf
+Type: note
+Description: Your must configure lcd4linux
+ By default, lcd4linux is not configured. You MUST configure it by editing
+ the /etc/lcd4linux.conf file, which holds all configuration.
+ .
+ Then, restart lcd4linux with /etc/init.d/lcd4linux restart