aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--XWindow.c6
-rwxr-xr-xconfigure2
-rw-r--r--configure.in2
-rw-r--r--lcd4linux.conf.sample8
-rw-r--r--processor.c8
5 files changed, 15 insertions, 11 deletions
diff --git a/XWindow.c b/XWindow.c
index 87dd84e..fec5936 100644
--- a/XWindow.c
+++ b/XWindow.c
@@ -1,4 +1,4 @@
-/* $Id: XWindow.c,v 1.10 2000/03/31 04:41:22 reinelt Exp $
+/* $Id: XWindow.c,v 1.11 2000/04/01 16:22:38 reinelt Exp $
*
* X11 Driver for LCD4Linux
*
@@ -20,9 +20,9 @@
*
*
* $Log: XWindow.c,v $
- * Revision 1.10 2000/03/31 04:41:22 reinelt
+ * Revision 1.11 2000/04/01 16:22:38 reinelt
*
- * X11 driver: semaphore bug fixed
+ * bug that caused a segfault in processor.c fixed (thanks to herp)
*
* Revision 1.10 2000/03/31 01:42:11 herp
*
diff --git a/configure b/configure
index 041e16a..800327d 100755
--- a/configure
+++ b/configure
@@ -693,7 +693,7 @@ fi
PACKAGE=lcd4linux
-VERSION=0.95
+VERSION=0.96
if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
{ echo "configure: error: source directory already configured; run "make distclean" there first" 1>&2; exit 1; }
diff --git a/configure.in b/configure.in
index a184683..0283d38 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(lcd4linux.c)
-AM_INIT_AUTOMAKE(lcd4linux, 0.95)
+AM_INIT_AUTOMAKE(lcd4linux, 0.96)
dnl Checks for programs.
AC_PROG_AWK
diff --git a/lcd4linux.conf.sample b/lcd4linux.conf.sample
index 1e50a6c..8281295 100644
--- a/lcd4linux.conf.sample
+++ b/lcd4linux.conf.sample
@@ -14,14 +14,14 @@
#background \#80d000
Display X11
-size 20x5
+size 20x6
font 5x8
pixel 5+1
-gap 5x5
+gap 6x6
border 3
foreground \#102000
-halfground \#70c000
-background \#80d000
+halfground \#90c000
+background \#a0d000
#Row1 "*** %o %v ***"
#Row2 "%p CPU %r MB RAM"
diff --git a/processor.c b/processor.c
index c381e72..f388813 100644
--- a/processor.c
+++ b/processor.c
@@ -1,4 +1,4 @@
-/* $Id: processor.c,v 1.2 2000/03/23 07:24:48 reinelt Exp $
+/* $Id: processor.c,v 1.3 2000/04/01 16:22:38 reinelt Exp $
*
* main data processing
*
@@ -20,6 +20,10 @@
*
*
* $Log: processor.c,v $
+ * Revision 1.3 2000/04/01 16:22:38 reinelt
+ *
+ * bug that caused a segfault in processor.c fixed (thanks to herp)
+ *
* Revision 1.2 2000/03/23 07:24:48 reinelt
*
* PPM driver up and running (but slow!)
@@ -378,7 +382,7 @@ void process_init (void)
for (i=1; i<=rows; i++) {
snprintf (buffer, sizeof(buffer), "row%d", i);
- row[i]=strdup(parse(cfg_get(buffer), supported_bars, token_usage));
+ row[i]=strdup(parse(cfg_get(buffer)?:"", supported_bars, token_usage));
}
}