aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile.generic
diff options
context:
space:
mode:
authorreinelt <>2005-05-06 05:36:59 +0000
committerreinelt <>2005-05-06 05:36:59 +0000
commit2b068848691202d26100cdf75c62c460313983ec (patch)
treefb295eb27941bbc9959886f37ae4cd240f4b5fa6 /documentation/Makefile.generic
parent9e6200afe91ee60ab080c3a8c23e8630c22f4055 (diff)
downloadlcd4linux-2b068848691202d26100cdf75c62c460313983ec.tar.gz
[lcd4linux @ 2005-05-06 05:36:58 by reinelt]
removed documentation again :-(
Diffstat (limited to 'documentation/Makefile.generic')
-rw-r--r--documentation/Makefile.generic59
1 files changed, 0 insertions, 59 deletions
diff --git a/documentation/Makefile.generic b/documentation/Makefile.generic
deleted file mode 100644
index 2519f22..0000000
--- a/documentation/Makefile.generic
+++ /dev/null
@@ -1,59 +0,0 @@
-# Path
-DIR = $(notdir $(PWD))
-OUTPUT = ../HTML
-
-ifeq "$(DIR)" "lcd4linux"
- DIR =
-endif
-
-ifeq "$(DIR)" ""
- XSLTPROC = xsltproc
-else
- XSLTPROC = xsltproc --stringparam class $(DIR) --stringparam root "../"
-endif
-
-XMLVALID = xmllint --noout --valid
-
-NAMES=$(shell find . -name "*.xml" -exec basename {} .xml \;)
-
-html: $(patsubst %.xml,%.html,$(wildcard *.xml))
-html-forced: $(patsubst %.xml,%.html-forced,$(wildcard *.xml))
-
-%.html: %.xml %.xml-check output
- $(XSLTPROC) $< > $(OUTPUT)/$(DIR)/$@
-
-%.html-forced: %.xml output
- $(XSLTPROC) $< > $(OUTPUT)/$(DIR)/$(patsubst %.xml,%.html,$<)
-
-check: $(patsubst %.xml, %.xml-check, $(wildcard *.xml))
-
-%.xml-check: %.xml
- @echo "*** Validation of $<"
- $(XMLVALID) $<
-
-output:
- test -d $(OUTPUT) || `mkdir $(OUTPUT); cp ../data/doc.css $(OUTPUT); cp -R ../data/images $(OUTPUT)`
- test -d $(OUTPUT)/$(DIR) || mkdir $(OUTPUT)/$(DIR)
-
-clean:
- rm -f $(OUTPUT)/$(DIR)/*.html
-
-clean-bak:
- rm -f *~ *.bak
-
-help:
- @echo -e ""
- @echo -e "Usage :"
- @echo -e "-------"
- @echo -e "make or make html : builds all possible html pages from xml files"
- @echo -e "make %.html : builds the %.html page from %.xml"
- @echo -e ""
- @echo -e "make html-forced : builds all possible html pages from xml files (no validity check)"
- @echo -e "make %.html-forced : builds the %.html page from %.xml (no validity check)"
- @echo -e ""
- @echo -e "make check : checks the validity of all possible xml files"
- @echo -e "make %.xml-check : checks the validity of %.xml"
- @echo -e ""
- @echo -e "make clean : deletes all generated html pages"
- @echo -e "make clean-bak : deletes *~ and *.bak files"
- @echo -e ""