aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <>2002-04-29 11:00:28 +0000
committerreinelt <>2002-04-29 11:00:28 +0000
commitb56cb43712ed521aec956ffff5179c15d1a1f0e3 (patch)
treef8b0a611d773d5bd691d9156392ee3704d79d2fc /configure.in
parent08aa9cb22d81fd0d020544c5f8deadec5970fd21 (diff)
downloadlcd4linux-b56cb43712ed521aec956ffff5179c15d1a1f0e3.tar.gz
[lcd4linux @ 2002-04-29 11:00:25 by reinelt]
added Toshiba T6963 driver added ndelay() with nanosecond resolution
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8f6cca0..35d967d 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(lcd4linux.c)
-AM_INIT_AUTOMAKE(lcd4linux, 0.98)
+AM_INIT_AUTOMAKE(lcd4linux, 0.99)
AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
@@ -29,7 +29,7 @@ AC_ARG_WITH(
[ drivers may be excluded with 'all,!<driver>',]
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
- [ BeckmannEgle, CrystalFontz, HD44780, M50530]
+ [ BeckmannEgle, CrystalFontz, HD44780, M50530, T6963]
[ MatrixOrbital, PalmPilot, PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
@@ -55,6 +55,7 @@ for driver in $drivers; do
CRYSTALFONTZ="yes"
HD44780="yes"
M50530="yes"
+ T6963="yes"
MATRIXORBITAL="yes"
PALMPILOT="yes"
PNG="yes"
@@ -74,6 +75,9 @@ for driver in $drivers; do
M50530)
M50530=$val
;;
+ T6963)
+ T6963=$val
+ ;;
MatrixOrbital)
MATRIXORBITAL=$val
;;
@@ -128,6 +132,11 @@ if test "$M50530" = "yes"; then
AC_DEFINE(WITH_M50530)
fi
+if test "$T6963" = "yes"; then
+ DRIVERS="$DRIVERS T6963.o"
+ AC_DEFINE(WITH_T6963)
+fi
+
if test "$MATRIXORBITAL" = "yes"; then
DRIVERS="$DRIVERS MatrixOrbital.o"
AC_DEFINE(WITH_MATRIXORBITAL)