aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <>2001-09-10 13:55:53 +0000
committerreinelt <>2001-09-10 13:55:53 +0000
commit832041ab49ceed247aa6b8caf1033266e11025d3 (patch)
treecd36ee97db1d992d09285343ef1c2c08417d7b43 /configure.in
parent7eeb474f0f2baad920a2f08d458b86d5836b59b9 (diff)
downloadlcd4linux-832041ab49ceed247aa6b8caf1033266e11025d3.tar.gz
[lcd4linux @ 2001-09-10 13:55:53 by reinelt]
M50530 driver
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e8a080d..8f6cca0 100644
--- a/configure.in
+++ b/configure.in
@@ -29,7 +29,7 @@ AC_ARG_WITH(
[ drivers may be excluded with 'all,!<driver>',]
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
- [ BeckmannEgle, CrystalFontz, HD44780,]
+ [ BeckmannEgle, CrystalFontz, HD44780, M50530]
[ MatrixOrbital, PalmPilot, PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
@@ -54,6 +54,7 @@ for driver in $drivers; do
BECKMANNEGLE="yes"
CRYSTALFONTZ="yes"
HD44780="yes"
+ M50530="yes"
MATRIXORBITAL="yes"
PALMPILOT="yes"
PNG="yes"
@@ -69,6 +70,9 @@ for driver in $drivers; do
;;
HD44780)
HD44780=$val
+ ;;
+ M50530)
+ M50530=$val
;;
MatrixOrbital)
MATRIXORBITAL=$val
@@ -119,6 +123,11 @@ if test "$HD44780" = "yes"; then
AC_DEFINE(WITH_HD44780)
fi
+if test "$M50530" = "yes"; then
+ DRIVERS="$DRIVERS M50530.o"
+ AC_DEFINE(WITH_M50530)
+fi
+
if test "$MATRIXORBITAL" = "yes"; then
DRIVERS="$DRIVERS MatrixOrbital.o"
AC_DEFINE(WITH_MATRIXORBITAL)