aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <>2003-09-29 06:58:37 +0000
committerreinelt <>2003-09-29 06:58:37 +0000
commit74bcb3f0eca15fffeb63fbdbc8102c4fc9d686be (patch)
tree219b2b249576d73ba2eedd6a10804e8faaf3ab60 /configure.in
parent0023926a82ccc300f2fdbc01c91244cc3180d261 (diff)
downloadlcd4linux-74bcb3f0eca15fffeb63fbdbc8102c4fc9d686be.tar.gz
[lcd4linux @ 2003-09-29 06:58:36 by reinelt]
new driver for Milford Instruments MI420 by Andy Baxter
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1888dfb..cdb6d7a 100644
--- a/configure.in
+++ b/configure.in
@@ -43,8 +43,8 @@ AC_ARG_WITH(
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
[ BeckmannEgle, CrystalFontz, Cwlinux, HD44780,]
- [ M50530, T6963, USBLCD, MatrixOrbital, PalmPilot]
- [ PNG, PPM, X11, Text],
+ [ M50530, T6963, USBLCD, MatrixOrbital,]
+ [ MilfordInstruments, PalmPilot, PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
)
@@ -73,6 +73,7 @@ for driver in $drivers; do
T6963="yes"
USBLCD="yes"
MATRIXORBITAL="yes"
+ MILINST="yes"
PALMPILOT="yes"
PNG="yes"
PPM="yes"
@@ -103,6 +104,9 @@ for driver in $drivers; do
MatrixOrbital)
MATRIXORBITAL=$val
;;
+ MilfordInstruments)
+ MILINST=$val
+ ;;
PalmPilot)
PALMPILOT=$val
;;
@@ -178,6 +182,11 @@ if test "$MATRIXORBITAL" = "yes"; then
AC_DEFINE(WITH_MATRIXORBITAL,1,[junk])
fi
+if test "$MILINST" = "yes"; then
+ DRIVERS="$DRIVERS MilfordInstruments.o"
+ AC_DEFINE(WITH_MILINST,1,[junk])
+fi
+
if test "$PALMPILOT" = "yes"; then
DRIVERS="$DRIVERS PalmPilot.o"
AC_DEFINE(WITH_PALMPILOT,1,[junk])