aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <>2002-09-11 05:16:33 +0000
committerreinelt <>2002-09-11 05:16:33 +0000
commit2f52ad6d174cf677d3c1e8e286f658b79a8b1b07 (patch)
tree0a0e28cfaf7570295e0544af9a4b8c1da2f18411 /configure.in
parent33a43b7658084eaaf169b516e5c18d5e879cb2d2 (diff)
downloadlcd4linux-2f52ad6d174cf677d3c1e8e286f658b79a8b1b07.tar.gz
[lcd4linux @ 2002-09-11 05:16:32 by reinelt]
added Cwlinux driver
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a668fa1..619ace0 100644
--- a/configure.in
+++ b/configure.in
@@ -29,8 +29,9 @@ AC_ARG_WITH(
[ drivers may be excluded with 'all,!<driver>',]
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
- [ BeckmannEgle, CrystalFontz, HD44780, M50530, T6963]
- [ USBLCD, MatrixOrbital, PalmPilot, PNG, PPM, X11, Text],
+ [ BeckmannEgle, CrystalFontz, Cwlinux, HD44780,]
+ [ M50530, T6963, USBLCD, MatrixOrbital, PalmPilot]
+ [ PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
)
@@ -53,6 +54,7 @@ for driver in $drivers; do
all)
BECKMANNEGLE="yes"
CRYSTALFONTZ="yes"
+ CWLINUX="yes"
HD44780="yes"
M50530="yes"
T6963="yes"
@@ -70,6 +72,9 @@ for driver in $drivers; do
CrystalFontz)
CRYSTALFONTZ=$val
;;
+ Cwlinux)
+ CWLINUX=$val
+ ;;
HD44780)
HD44780=$val
;;
@@ -126,6 +131,11 @@ if test "$CRYSTALFONTZ" = "yes"; then
AC_DEFINE(WITH_CRYSTALFONTZ)
fi
+if test "$CWLINUX" = "yes"; then
+ DRIVERS="$DRIVERS Cwlinux.o"
+ AC_DEFINE(WITH_CWLINUX)
+fi
+
if test "$HD44780" = "yes"; then
DRIVERS="$DRIVERS HD44780.o"
AC_DEFINE(WITH_HD44780)