aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorreinelt <>2003-08-17 08:25:30 +0000
committerreinelt <>2003-08-17 08:25:30 +0000
commitb9f0cbbd27ef10ee727a30e8ee9dc61ef2ede842 (patch)
tree117191c2fed65d774408588f1f72eed0c0452e6d /Makefile.am
parentb8ce24183e70feb522c99a3d535bba84ccabc5ff (diff)
downloadlcd4linux-b9f0cbbd27ef10ee727a30e8ee9dc61ef2ede842.tar.gz
[lcd4linux @ 2003-08-17 08:25:30 by reinelt]
preparations for liblcd4linux; minor bugs in SIN.c and Skeleton.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b7a425e..1be1d54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,7 @@ AUTOMAKE_OPTIONS = gnu
CLEANFILES = *~
bin_PROGRAMS = lcd4linux
+noinst_LIBRARIES = liblcd4linux.a
AM_CFLAGS = $(X_CFLAGS) -D_GNU_SOURCE -Wall
lcd4linux_LDFLAGS = $(X_LIBS)
@@ -51,6 +52,23 @@ Skeleton.c \
XWindow.c \
Text.c
+liblcd4linux_a_SOURCES = \
+parport.c parport.h \
+BeckmannEgle.c \
+Crystalfontz.c \
+Cwlinux.c \
+HD44780.c \
+M50530.c \
+T6963.c \
+USBLCD.c \
+MatrixOrbital.c \
+PalmPilot.c \
+Raster.c \
+SIN.c \
+Skeleton.c \
+XWindow.c \
+Text.c
+
EXTRA_DIST = \
lcd4linux.conf.sample \
lcd4kde.conf \