aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-05-17 01:21:00 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-05-17 01:21:00 +0100
commite278a818278efb34e1bb81e5e22984ad4d8a2a7e (patch)
tree104908734d976995e036b6234d0fa6395d4970b6
parent6a0840fb98fedd47812467032357a22941bf0166 (diff)
downloadlcd4linux-e278a818278efb34e1bb81e5e22984ad4d8a2a7e.tar.gz
d/rules: Add get-orig-source target
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/get-svn-source.sh19
-rwxr-xr-xdebian/rules3
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 53c25ac..eee6f8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ lcd4linux (0.11.0~svn1188-1) UNRELEASED; urgency=low
* New upstream snapshot
- Adds Hex support to the evaluator
- Fixes -Wimplicit-function-declaration build warnings
+ * d/rules: Add get-orig-source target
-- Jonathan McCrohan <jmccrohan@gmail.com> Thu, 17 May 2012 01:14:40 +0100
diff --git a/debian/get-svn-source.sh b/debian/get-svn-source.sh
new file mode 100755
index 0000000..e55e0a3
--- /dev/null
+++ b/debian/get-svn-source.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+UPSTREAM_VERSION=$(dpkg-parsechangelog | sed -e '/^Version/!d' -e 's/^Version: //g' -e 's/-.*//g')
+UPSTREAM_REVISION=$(echo ${UPSTREAM_VERSION} | sed -e 's/.*svn/-r/')
+UPSTREAM_SVN=https://ssl.bulix.org/svn/lcd4linux/trunk/
+UPSTREAM_CHECKOUT=lcd4linux-${UPSTREAM_VERSION}
+OLDDIR=${PWD}
+GOS_DIR=${OLDDIR}/get-orig-source
+
+if [ -z ${UPSTREAM_VERSION} ]; then
+ echo 'Please run this script from the sources root directory.'
+ exit 1
+fi
+
+rm -rf ${GOS_DIR}
+mkdir ${GOS_DIR} && cd ${GOS_DIR}
+svn export ${UPSTREAM_REVISION} ${UPSTREAM_SVN} ${UPSTREAM_CHECKOUT}
+tar -zcf ../../lcd4linux_${UPSTREAM_VERSION}.orig.tar.gz ${UPSTREAM_CHECKOUT}
+rm -rf ${GOS_DIR}
diff --git a/debian/rules b/debian/rules
index b24e7d2..025a326 100755
--- a/debian/rules
+++ b/debian/rules
@@ -94,3 +94,6 @@ binary-arch: build install
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
+
+get-orig-source:
+ debian/get-svn-source.sh