aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2006-08-27 16:27:38 +0200
committerReinhard Tartler <siretart@tauware.de>2006-08-27 16:27:38 +0200
commitdf430dd12f7fdcd349b71178a86a74bbd8d85e8d (patch)
tree14038dd6ac7d553f49d3cf72ec70031be5c71eab
parent2f6d81cacb8d97d88e61d1b764aec427def74689 (diff)
downloadlcd4linux-df430dd12f7fdcd349b71178a86a74bbd8d85e8d.tar.gz
cleanup init script
-rw-r--r--debian/changelog2
-rw-r--r--debian/init.d35
2 files changed, 3 insertions, 34 deletions
diff --git a/debian/changelog b/debian/changelog
index d64934f..1287b83 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -23,7 +23,7 @@ lcd4linux (0.10.0+cvs20060825-1) unstable; urgency=medium
and amd64 only. (Closes: #336017).
* Removing outdated NEWS, FAQ, README.KDE on upstream request.
- --
+ -- Reinhard Tartler <siretart@tauware.de> Sun, 27 Aug 2006 14:55:39 +0200
lcd4linux (0.10.0+cvs20051015-3.1) unstable; urgency=low
diff --git a/debian/init.d b/debian/init.d
index b18176b..70b47c4 100644
--- a/debian/init.d
+++ b/debian/init.d
@@ -1,14 +1,4 @@
#! /bin/sh
-#
-# skeleton example file to build /etc/init.d/ scripts.
-# This file should be used to construct scripts for /etc/init.d.
-#
-# Written by Miquel van Smoorenburg <miquels@cistron.nl>.
-# Modified for Debian
-# by Ian Murdock <imurdock@gnu.ai.mit.edu>.
-#
-# Version: @(#)skeleton 1.9 26-Feb-2001 miquels@cistron.nl
-#
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/lcd4linux
@@ -16,11 +6,7 @@ NAME=lcd4linux
DESC=lcd4linux
test -x $DAEMON || exit 0
-
-# Include lcd4linux defaults if available
-if [ -f /etc/default/lcd4linux ] ; then
- . /etc/default/lcd4linux
-fi
+test -f /etc/lcd4linux.conf || exit 0
set -e
@@ -35,27 +21,10 @@ case "$1" in
stop)
echo -n "Stopping $DESC: "
start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid \
- --exec $DAEMON
+ --exec $DAEMON || true
echo "$NAME."
;;
- #reload)
- #
- # If the daemon can reload its config files on the fly
- # for example by sending it SIGHUP, do it here.
- #
- # If the daemon responds to changes in its config file
- # directly anyway, make this a do-nothing entry.
- #
- # echo "Reloading $DESC configuration files."
- # start-stop-daemon --stop --signal 1 --quiet --pidfile \
- # /var/run/$NAME.pid --exec $DAEMON
- #;;
restart|force-reload)
- #
- # If the "reload" option is implemented, move the "force-reload"
- # option to the "reload" entry above. If not, "force-reload" is
- # just the same as "restart".
- #
echo -n "Restarting $DESC: "
start-stop-daemon --stop --quiet --pidfile \
/var/run/$NAME.pid --exec $DAEMON