aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2006-08-14 05:54:04 +0000
committerreinelt <>2006-08-14 05:54:04 +0000
commitc263ef0295d2483c40973942bfc050e9936bfa9e (patch)
tree9deacddbcd9b53939d28bcebeca70c38be8b2a8f
parent8eb09e832fb1722c7e4009a6e24e87d6af4d13cc (diff)
downloadlcd4linux-c263ef0295d2483c40973942bfc050e9936bfa9e.tar.gz
[lcd4linux @ 2006-08-14 05:54:03 by reinelt]
minor warnings fixed, CFLAGS changed (no-strict-aliasing)
-rw-r--r--Makefile.am2
-rw-r--r--Makefile.in2
-rw-r--r--drv_LEDMatrix.c8
-rw-r--r--drv_USBHUB.c9
-rw-r--r--lcd4linux.conf.sample32
-rw-r--r--property.h7
-rw-r--r--widget.h6
7 files changed, 51 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index c4d286a..359dd2e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@ PLUGINS=@PLUGINS@
bin_PROGRAMS = lcd4linux
-AM_CFLAGS = -D_GNU_SOURCE -Wall -W
+AM_CFLAGS = -D_GNU_SOURCE -Wall -Wextra -fno-strict-aliasing
lcd4linux_LDFLAGS =
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
diff --git a/Makefile.in b/Makefile.in
index 89c7472..6a3da74 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -184,7 +184,7 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
AUTOMAKE_OPTIONS = gnu
CLEANFILES = *~
-AM_CFLAGS = -D_GNU_SOURCE -Wall -W
+AM_CFLAGS = -D_GNU_SOURCE -Wall -Wextra -fno-strict-aliasing
lcd4linux_LDFLAGS =
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
diff --git a/drv_LEDMatrix.c b/drv_LEDMatrix.c
index 2df74fd..313942d 100644
--- a/drv_LEDMatrix.c
+++ b/drv_LEDMatrix.c
@@ -1,4 +1,4 @@
-/* $Id: drv_LEDMatrix.c,v 1.7 2006/08/13 18:45:25 harbaum Exp $
+/* $Id: drv_LEDMatrix.c,v 1.8 2006/08/14 05:54:04 reinelt Exp $
*
* LED matrix driver for LCD4Linux
* (see http://www.harbaum.org/till/ledmatrix for hardware)
@@ -23,6 +23,9 @@
*
*
* $Log: drv_LEDMatrix.c,v $
+ * Revision 1.8 2006/08/14 05:54:04 reinelt
+ * minor warnings fixed, CFLAGS changed (no-strict-aliasing)
+ *
* Revision 1.7 2006/08/13 18:45:25 harbaum
* Little cleanup ...
*
@@ -117,7 +120,8 @@ static void drv_LEDMatrix_blit(const int row, const int col, const int height, c
struct timeval tv;
unsigned char reply[256];
struct sockaddr_in cli_addr;
- int fromlen, ack = 0;
+ socklen_t fromlen;
+ int ack = 0;
int timeout = 10;
for (r = row; r < row + height; r++) {
diff --git a/drv_USBHUB.c b/drv_USBHUB.c
index 55e80ca..1b68cc0 100644
--- a/drv_USBHUB.c
+++ b/drv_USBHUB.c
@@ -1,4 +1,4 @@
-/* $Id: drv_USBHUB.c,v 1.2 2006/08/13 06:46:51 reinelt Exp $
+/* $Id: drv_USBHUB.c,v 1.3 2006/08/14 05:54:04 reinelt Exp $
*
* new style driver for USBLCD displays
*
@@ -25,6 +25,9 @@
*
*
* $Log: drv_USBHUB.c,v $
+ * Revision 1.3 2006/08/14 05:54:04 reinelt
+ * minor warnings fixed, CFLAGS changed (no-strict-aliasing)
+ *
* Revision 1.2 2006/08/13 06:46:51 reinelt
* T6963 soft-timing & enhancements; indent
*
@@ -179,7 +182,7 @@ static int drv_UH_set(const int num, const int val)
}
-static int drv_UH_start(const char *section, const int quiet)
+static int drv_UH_start(const char *section, const __attribute__ ((unused)) int quiet)
{
char *buf;
@@ -275,7 +278,7 @@ int drv_UH_init(const char *section, const int quiet)
int ret;
int i;
- info("%s: %s", Name, "$Revision: 1.2 $");
+ info("%s: %s", Name, "$Revision: 1.3 $");
diff --git a/lcd4linux.conf.sample b/lcd4linux.conf.sample
index c55f33b..b64b7d1 100644
--- a/lcd4linux.conf.sample
+++ b/lcd4linux.conf.sample
@@ -358,13 +358,24 @@ Display T6963-240x64 {
Port '/dev/parports/0'
Size '240x64'
Font '6x8'
- FontStyle 'bold'
Wire.CE 'STROBE'
Wire.CD 'SLCTIN'
Wire.RD 'AUTOFD'
Wire.WR 'INIT'
}
+Display T6963-240x128 {
+ Driver 'T6963'
+ Port '/dev/parports/0'
+ Size '240x128'
+ Font '6x8'
+ Wire.CE 'STROBE'
+ Wire.CD 'SLCTIN'
+ Wire.RD 'AUTOFD'
+ Wire.WR 'INIT'
+ Timing.fuzz 120
+}
+
Display LPH7508 {
Driver 'LPH7508'
@@ -822,7 +833,7 @@ Widget Test {
Widget Test1 {
class 'Text'
expression 'ABCDEFGHIJKLMNOPQRSTUVWXYZ1234567890'
- width 80
+ width 40
align 'M'
speed 100
}
@@ -830,7 +841,7 @@ Widget Test1 {
Widget Test2 {
class 'Text'
expression '1234567890abcdefghijklmnopqrstuvwxyz'
- width 80
+ width 40
align 'M'
speed 150
}
@@ -1048,6 +1059,14 @@ Layout Test {
Row14.Col1 'Test1'
Row15.Col1 'Test1'
Row16.Col1 'Test1'
+ Row17.Col1 'Test1'
+ Row18.Col1 'Test1'
+ Row19.Col1 'Test1'
+ Row20.Col1 'Test1'
+ Row21.Col1 'Test1'
+ Row22.Col1 'Test1'
+ Row23.Col1 'Test1'
+ Row24.Col1 'Test1'
}
Layout Test2 {
@@ -1108,7 +1127,8 @@ Layout Debug {
#Display 'SimpleLCD'
#Display 'BA63'
#Display 'CT20x4'
-Display 'T6963-240x64'
+Display 'T6963-240x128'
+#Display 'T6963-240x64'
#Display 'XWindow'
#Display 'USBLCD'
#Display 'BWCT'
@@ -1119,7 +1139,7 @@ Display 'T6963-240x64'
#Display 'LPH7508'
#Display 'ctinclud'
-Layout 'Default'
+#Layout 'Default'
#Layout 'TestLayer'
#Layout 'TestImage'
#Layout 'L8x2'
@@ -1127,7 +1147,7 @@ Layout 'Default'
#Layout 'L16x2'
#Layout 'L20x2'
#Layout 'L40x2'
-#Layout 'Test'
+Layout 'Test'
#Layout 'Test2'
#Layout 'TestGPO'
#Layout 'Debug'
diff --git a/property.h b/property.h
index d1020c0..a227ca1 100644
--- a/property.h
+++ b/property.h
@@ -1,4 +1,4 @@
-/* $Id: property.h,v 1.2 2006/08/13 11:38:20 reinelt Exp $
+/* $Id: property.h,v 1.3 2006/08/14 05:54:04 reinelt Exp $
*
* dynamic properties
*
@@ -23,6 +23,9 @@
*
*
* $Log: property.h,v $
+ * Revision 1.3 2006/08/14 05:54:04 reinelt
+ * minor warnings fixed, CFLAGS changed (no-strict-aliasing)
+ *
* Revision 1.2 2006/08/13 11:38:20 reinelt
* text widget uses dynamic properties
*
@@ -35,6 +38,8 @@
#ifndef _PROPERTY_H_
#define _PROPERTY_H_
+#include "evaluator.h"
+
typedef struct {
char *name;
diff --git a/widget.h b/widget.h
index 42fa365..2b5c359 100644
--- a/widget.h
+++ b/widget.h
@@ -1,4 +1,4 @@
-/* $Id: widget.h,v 1.21 2006/08/09 17:25:34 harbaum Exp $
+/* $Id: widget.h,v 1.22 2006/08/14 05:54:04 reinelt Exp $
*
* generic widget handling
*
@@ -23,6 +23,9 @@
*
*
* $Log: widget.h,v $
+ * Revision 1.22 2006/08/14 05:54:04 reinelt
+ * minor warnings fixed, CFLAGS changed (no-strict-aliasing)
+ *
* Revision 1.21 2006/08/09 17:25:34 harbaum
* Better bar color support and new bold font
*
@@ -150,5 +153,6 @@ int widget_register(WIDGET_CLASS * widget);
void widget_unregister(void);
int widget_add(const char *name, const int type, const int layer, const int row, const int col);
WIDGET *widget_find(int type, void *needle);
+int widget_color(const char *section, const char *name, const char *key, RGBA * C);
#endif