aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2001-05-27 07:19:28 +0000
committerreinelt <>2001-05-27 07:19:28 +0000
commit6314ec05ca453676a3464fdc43c332b28ccf4b37 (patch)
treeb6d6f6584679fd315d9da25e8fc9c153578ec500
parent1666ad847898075d9b6d7a6f2fc375c7b8a1d626 (diff)
downloadlcd4linux-6314ec05ca453676a3464fdc43c332b28ccf4b37.tar.gz
[lcd4linux @ 2001-05-27 07:19:28 by reinelt]
fixed a warning in pixmap.c temporarily fixed a bug in isdn.c (ISDN_MAX_CHANNELS is no longer defined?) fixed a bug in configure.in (--with-drivers=xyz did not work)
-rwxr-xr-xconfigure2
-rw-r--r--configure.in2
-rw-r--r--isdn.c13
-rw-r--r--pixmap.c10
4 files changed, 22 insertions, 5 deletions
diff --git a/configure b/configure
index 499aad8..8c97626 100755
--- a/configure
+++ b/configure
@@ -2277,7 +2277,7 @@ if test "$RASTER" = "yes"; then
fi
-if test "$DRVLIBS" = ""; then
+if test "$DRIVERS" = ""; then
{ echo "configure: error: You should include at least one driver..." 1>&2; exit 1; }
fi
diff --git a/configure.in b/configure.in
index e182668..376be74 100644
--- a/configure.in
+++ b/configure.in
@@ -171,7 +171,7 @@ if test "$RASTER" = "yes"; then
fi
-if test "$DRVLIBS" = ""; then
+if test "$DRIVERS" = ""; then
AC_MSG_ERROR([You should include at least one driver...])
fi
diff --git a/isdn.c b/isdn.c
index 3247270..7a2f570 100644
--- a/isdn.c
+++ b/isdn.c
@@ -1,4 +1,4 @@
-/* $Id: isdn.c,v 1.8 2000/08/10 18:42:20 reinelt Exp $
+/* $Id: isdn.c,v 1.9 2001/05/27 07:19:28 reinelt Exp $
*
* ISDN specific functions
*
@@ -20,6 +20,12 @@
*
*
* $Log: isdn.c,v $
+ * Revision 1.9 2001/05/27 07:19:28 reinelt
+ *
+ * fixed a warning in pixmap.c
+ * temporarily fixed a bug in isdn.c (ISDN_MAX_CHANNELS is no longer defined?)
+ * fixed a bug in configure.in (--with-drivers=xyz did not work)
+ *
* Revision 1.8 2000/08/10 18:42:20 reinelt
*
* fixed some bugs with the new syslog code
@@ -73,6 +79,11 @@
#include <sys/types.h>
#include <linux/isdn.h>
+// Fixme: ISDN_MAX_CHANNELS seems undefined in recent kernels
+#ifndef ISDN_MAX_CHANNELS
+#define ISDN_MAX_CHANNELS 64
+#endif
+
#include "debug.h"
#include "isdn.h"
#include "filter.h"
diff --git a/pixmap.c b/pixmap.c
index e7c13f3..9baa7ed 100644
--- a/pixmap.c
+++ b/pixmap.c
@@ -1,4 +1,4 @@
-/* $Id: pixmap.c,v 1.8 2001/04/27 05:04:57 reinelt Exp $
+/* $Id: pixmap.c,v 1.9 2001/05/27 07:19:28 reinelt Exp $
*
* generic pixmap driver
*
@@ -20,6 +20,12 @@
*
*
* $Log: pixmap.c,v $
+ * Revision 1.9 2001/05/27 07:19:28 reinelt
+ *
+ * fixed a warning in pixmap.c
+ * temporarily fixed a bug in isdn.c (ISDN_MAX_CHANNELS is no longer defined?)
+ * fixed a bug in configure.in (--with-drivers=xyz did not work)
+ *
* Revision 1.8 2001/04/27 05:04:57 reinelt
*
* replaced OPEN_MAX with sysconf()
@@ -159,7 +165,7 @@ int pix_bar (int type, int row, int col, int max, int len1, int len2)
time_t old;
} vals[N_BAR_T];
time_t now;
- int i;
+ int i=0;
row*=YRES;
col*=XRES;