aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorreinelt <>2002-08-19 04:41:20 +0000
committerreinelt <>2002-08-19 04:41:20 +0000
commit14f4600010f07dfd1e6b91e1038c468b40c8f748 (patch)
treec97b9dd85328464e0c75fe7780e7cec6004ba92e
parentd9d3e35a7b8ebe1f2aab0b8c010b5030f1c3e9df (diff)
downloadlcd4linux-14f4600010f07dfd1e6b91e1038c468b40c8f748.tar.gz
[lcd4linux @ 2002-08-19 04:41:20 by reinelt]
introduced bar.c, moved bar stuff from display.h to bar.h
-rw-r--r--BeckmannEgle.c6
-rw-r--r--Crystalfontz.c6
-rw-r--r--HD44780.c6
-rw-r--r--M50530.c6
-rw-r--r--Makefile.am1
-rw-r--r--Makefile.in6
-rw-r--r--MatrixOrbital.c6
-rw-r--r--PalmPilot.c6
-rw-r--r--Raster.c6
-rw-r--r--T6963.c6
-rw-r--r--Text.c7
-rw-r--r--USBLCD.c6
-rw-r--r--XWindow.c6
-rw-r--r--bar.c37
-rw-r--r--bar.h45
-rw-r--r--display.c6
-rw-r--r--display.h18
-rw-r--r--parser.c6
-rw-r--r--pixmap.c6
-rw-r--r--processor.c6
20 files changed, 166 insertions, 32 deletions
diff --git a/BeckmannEgle.c b/BeckmannEgle.c
index 51bf98e..2607397 100644
--- a/BeckmannEgle.c
+++ b/BeckmannEgle.c
@@ -1,4 +1,4 @@
-/* $Id: BeckmannEgle.c,v 1.6 2001/04/27 05:04:57 reinelt Exp $
+/* $Id: BeckmannEgle.c,v 1.7 2002/08/19 04:41:20 reinelt Exp $
*
* driver for Beckmann+Egle mini terminals
*
@@ -20,6 +20,9 @@
*
*
* $Log: BeckmannEgle.c,v $
+ * Revision 1.7 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.6 2001/04/27 05:04:57 reinelt
*
* replaced OPEN_MAX with sysconf()
@@ -72,6 +75,7 @@
#include "cfg.h"
#include "lock.h"
#include "display.h"
+#include "bar.h"
#define XRES 5
#define YRES 8
diff --git a/Crystalfontz.c b/Crystalfontz.c
index 599ff0a..0a87f81 100644
--- a/Crystalfontz.c
+++ b/Crystalfontz.c
@@ -1,4 +1,4 @@
-/* $Id: Crystalfontz.c,v 1.7 2001/04/27 05:04:57 reinelt Exp $
+/* $Id: Crystalfontz.c,v 1.8 2002/08/19 04:41:20 reinelt Exp $
*
* driver for display modules from Crystalfontz
*
@@ -19,6 +19,9 @@
* Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*
* $Log: Crystalfontz.c,v $
+ * Revision 1.8 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.7 2001/04/27 05:04:57 reinelt
*
* replaced OPEN_MAX with sysconf()
@@ -59,6 +62,7 @@
#include "cfg.h"
#include "lock.h"
#include "display.h"
+#include "bar.h"
#include "Crystalfontz.h"
#define XRES 6
diff --git a/HD44780.c b/HD44780.c
index 11cae9b..48aefb0 100644
--- a/HD44780.c
+++ b/HD44780.c
@@ -1,4 +1,4 @@
-/* $Id: HD44780.c,v 1.22 2002/08/17 14:14:21 reinelt Exp $
+/* $Id: HD44780.c,v 1.23 2002/08/19 04:41:20 reinelt Exp $
*
* driver for display modules based on the HD44780 chip
*
@@ -20,6 +20,9 @@
*
*
* $Log: HD44780.c,v $
+ * Revision 1.23 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.22 2002/08/17 14:14:21 reinelt
*
* USBLCD fixes
@@ -168,6 +171,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "udelay.h"
#define XRES 5
diff --git a/M50530.c b/M50530.c
index 9207fd1..1928cc3 100644
--- a/M50530.c
+++ b/M50530.c
@@ -1,4 +1,4 @@
-/* $Id: M50530.c,v 1.2 2002/04/30 07:20:15 reinelt Exp $
+/* $Id: M50530.c,v 1.3 2002/08/19 04:41:20 reinelt Exp $
*
* driver for display modules based on the M50530 chip
*
@@ -20,6 +20,9 @@
*
*
* $Log: M50530.c,v $
+ * Revision 1.3 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.2 2002/04/30 07:20:15 reinelt
*
* implemented the new ndelay(nanoseconds) in all parallel port drivers
@@ -61,6 +64,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "udelay.h"
#define XRES 5
diff --git a/Makefile.am b/Makefile.am
index 1ddc5eb..f82c998 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,7 @@ filter.c filter.h \
udelay.c udelay.h \
display.c display.h \
pixmap.c pixmap.h \
+bar.c bar.h \
fontmap.c fontmap.h \
exec.c exec.h \
mail2.c \
diff --git a/Makefile.in b/Makefile.in
index 9e278bb..b6515ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -78,7 +78,7 @@ lcd4linux_LDFLAGS = $(X_LIBS)
lcd4linux_LDADD = @DRIVERS@ @DRVLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@
-lcd4linux_SOURCES = lcd4linux.c debug.c debug.h cfg.c cfg.h lock.c lock.h parser.c parser.h processor.c processor.h system.c system.h isdn.c isdn.h mail.c mail.h seti.c seti.h battery.c battery.h filter.c filter.h udelay.c udelay.h display.c display.h pixmap.c pixmap.h fontmap.c fontmap.h exec.c exec.h mail2.c socket.c socket.h
+lcd4linux_SOURCES = lcd4linux.c debug.c debug.h cfg.c cfg.h lock.c lock.h parser.c parser.h processor.c processor.h system.c system.h isdn.c isdn.h mail.c mail.h seti.c seti.h battery.c battery.h filter.c filter.h udelay.c udelay.h display.c display.h pixmap.c pixmap.h bar.c bar.h fontmap.c fontmap.h exec.c exec.h mail2.c socket.c socket.h
EXTRA_lcd4linux_SOURCES = acconfig.h BeckmannEgle.c Crystalfontz.c Crystalfontz.h HD44780.c M50530.c T6963.c USBLCD.c MatrixOrbital.c PalmPilot.c Raster.c SIN.c Skeleton.c XWindow.c Text.c
@@ -103,7 +103,7 @@ X_EXTRA_LIBS = @X_EXTRA_LIBS@
X_PRE_LIBS = @X_PRE_LIBS@
lcd4linux_OBJECTS = lcd4linux.o debug.o cfg.o lock.o parser.o \
processor.o system.o isdn.o mail.o seti.o battery.o filter.o udelay.o \
-display.o pixmap.o fontmap.o exec.o mail2.o socket.o
+display.o pixmap.o bar.o fontmap.o exec.o mail2.o socket.o
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
@@ -120,7 +120,7 @@ GZIP_ENV = --best
DEP_FILES = .deps/BeckmannEgle.P .deps/Crystalfontz.P .deps/HD44780.P \
.deps/M50530.P .deps/MatrixOrbital.P .deps/PalmPilot.P .deps/Raster.P \
.deps/SIN.P .deps/Skeleton.P .deps/T6963.P .deps/Text.P .deps/USBLCD.P \
-.deps/XWindow.P .deps/battery.P .deps/cfg.P .deps/debug.P \
+.deps/XWindow.P .deps/bar.P .deps/battery.P .deps/cfg.P .deps/debug.P \
.deps/display.P .deps/exec.P .deps/filter.P .deps/fontmap.P \
.deps/isdn.P .deps/lcd4linux.P .deps/lock.P .deps/mail.P .deps/mail2.P \
.deps/parser.P .deps/pixmap.P .deps/processor.P .deps/seti.P \
diff --git a/MatrixOrbital.c b/MatrixOrbital.c
index 6c35632..1b3f443 100644
--- a/MatrixOrbital.c
+++ b/MatrixOrbital.c
@@ -1,4 +1,4 @@
-/* $Id: MatrixOrbital.c,v 1.22 2001/04/27 05:04:57 reinelt Exp $
+/* $Id: MatrixOrbital.c,v 1.23 2002/08/19 04:41:20 reinelt Exp $
*
* driver for Matrix Orbital serial display modules
*
@@ -20,6 +20,9 @@
*
*
* $Log: MatrixOrbital.c,v $
+ * Revision 1.23 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.22 2001/04/27 05:04:57 reinelt
*
* replaced OPEN_MAX with sysconf()
@@ -139,6 +142,7 @@
#include "cfg.h"
#include "lock.h"
#include "display.h"
+#include "bar.h"
#define XRES 5
#define YRES 8
diff --git a/PalmPilot.c b/PalmPilot.c
index 66eeb0c..8a4be9c 100644
--- a/PalmPilot.c
+++ b/PalmPilot.c
@@ -1,4 +1,4 @@
-/* $Id: PalmPilot.c,v 1.6 2001/04/27 05:04:57 reinelt Exp $
+/* $Id: PalmPilot.c,v 1.7 2002/08/19 04:41:20 reinelt Exp $
*
* driver for 3Com Palm Pilot
*
@@ -20,6 +20,9 @@
*
*
* $Log: PalmPilot.c,v $
+ * Revision 1.7 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.6 2001/04/27 05:04:57 reinelt
*
* replaced OPEN_MAX with sysconf()
@@ -73,6 +76,7 @@
#include "cfg.h"
#include "lock.h"
#include "display.h"
+#include "bar.h"
#include "pixmap.h"
#define BARS ( BAR_L | BAR_R | BAR_U | BAR_D | BAR_H2 | BAR_V2 | BAR_T)
diff --git a/Raster.c b/Raster.c
index 48ecfb3..b61f7d2 100644
--- a/Raster.c
+++ b/Raster.c
@@ -1,4 +1,4 @@
-/* $Id: Raster.c,v 1.19 2001/09/10 13:55:53 reinelt Exp $
+/* $Id: Raster.c,v 1.20 2002/08/19 04:41:20 reinelt Exp $
*
* driver for raster formats
*
@@ -20,6 +20,9 @@
*
*
* $Log: Raster.c,v $
+ * Revision 1.20 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.19 2001/09/10 13:55:53 reinelt
* M50530 driver
*
@@ -138,6 +141,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "pixmap.h"
#define BARS ( BAR_L | BAR_R | BAR_U | BAR_D | BAR_H2 | BAR_V2 | BAR_T )
diff --git a/T6963.c b/T6963.c
index 690a628..b76d510 100644
--- a/T6963.c
+++ b/T6963.c
@@ -1,4 +1,4 @@
-/* $Id: T6963.c,v 1.2 2002/08/17 12:54:08 reinelt Exp $
+/* $Id: T6963.c,v 1.3 2002/08/19 04:41:20 reinelt Exp $
*
* driver for display modules based on the Toshiba T6963 chip
*
@@ -20,6 +20,9 @@
*
*
* $Log: T6963.c,v $
+ * Revision 1.3 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.2 2002/08/17 12:54:08 reinelt
* minor T6963 changes
*
@@ -62,6 +65,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "udelay.h"
#include "pixmap.h"
diff --git a/Text.c b/Text.c
index 983af51..65747f7 100644
--- a/Text.c
+++ b/Text.c
@@ -1,4 +1,4 @@
-/* $Id: Text.c,v 1.4 2001/03/16 16:40:17 ltoetsch Exp $
+/* $Id: Text.c,v 1.5 2002/08/19 04:41:20 reinelt Exp $
*
* pure ncurses based text driver
*
@@ -20,6 +20,9 @@
*
*
* $Log: Text.c,v $
+ * Revision 1.5 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.4 2001/03/16 16:40:17 ltoetsch
* implemented time bar
*
@@ -75,6 +78,8 @@ int main(int argc, char *argv[])
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
+
extern int foreground;
static LCD Lcd;
diff --git a/USBLCD.c b/USBLCD.c
index 4f22f69..4702590 100644
--- a/USBLCD.c
+++ b/USBLCD.c
@@ -1,4 +1,4 @@
-/* $Id: USBLCD.c,v 1.3 2002/08/18 08:11:11 reinelt Exp $
+/* $Id: USBLCD.c,v 1.4 2002/08/19 04:41:20 reinelt Exp $
*
* Driver for USBLCD ( see http://www.usblcd.de )
* This Driver is based on HD44780.c
@@ -22,6 +22,9 @@
*
*
* $Log: USBLCD.c,v $
+ * Revision 1.4 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.3 2002/08/18 08:11:11 reinelt
* USBLCD buffered I/O
*
@@ -62,6 +65,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "udelay.h"
#define GET_HARD_VERSION 1
diff --git a/XWindow.c b/XWindow.c
index ac7d6fe..4518491 100644
--- a/XWindow.c
+++ b/XWindow.c
@@ -1,4 +1,4 @@
-/* $Id: XWindow.c,v 1.26 2001/08/05 17:13:29 reinelt Exp $
+/* $Id: XWindow.c,v 1.27 2002/08/19 04:41:20 reinelt Exp $
*
* X11 Driver for LCD4Linux
*
@@ -20,6 +20,9 @@
*
*
* $Log: XWindow.c,v $
+ * Revision 1.27 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.26 2001/08/05 17:13:29 reinelt
*
* cleaned up inlude of sys/time.h and time.h
@@ -143,6 +146,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
#include "pixmap.h"
/* glibc 2.1 requires defining semun ourselves */
diff --git a/bar.c b/bar.c
new file mode 100644
index 0000000..f0df581
--- /dev/null
+++ b/bar.c
@@ -0,0 +1,37 @@
+/* $Id: bar.c,v 1.1 2002/08/19 04:41:20 reinelt Exp $
+ *
+ * generic bar handling
+ *
+ * Copyright 2002 by Michael Reinelt (reinelt@eunet.at)
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ *
+ *
+ * $Log: bar.c,v $
+ * Revision 1.1 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
+ *
+ */
+
+/*
+ * exported functions:
+ *
+ *
+ */
+
+#include "bar.h"
+#include "debug.h"
+
diff --git a/bar.h b/bar.h
new file mode 100644
index 0000000..4b932d4
--- /dev/null
+++ b/bar.h
@@ -0,0 +1,45 @@
+/* $Id: bar.h,v 1.1 2002/08/19 04:41:20 reinelt Exp $
+ *
+ * generic bar handling
+ *
+ * Copyright 2002 by Michael Reinelt (reinelt@eunet.at)
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ *
+ *
+ * $Log: bar.h,v $
+ * Revision 1.1 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
+ *
+ */
+
+#ifndef _BAR_H_
+#define _BAR_H_
+
+#define BAR_L (1<<0)
+#define BAR_R (1<<1)
+#define BAR_U (1<<2)
+#define BAR_D (1<<3)
+#define BAR_H2 (1<<4)
+#define BAR_V2 (1<<5)
+#define BAR_LOG (1<<6)
+#define BAR_T (1<<7)
+
+#define BAR_H (BAR_L | BAR_R)
+#define BAR_V (BAR_U | BAR_D | BAR_T)
+#define BAR_HV (BAR_H | BAR_V)
+
+#endif
diff --git a/display.c b/display.c
index f4a5f9f..4c038d0 100644
--- a/display.c
+++ b/display.c
@@ -1,4 +1,4 @@
-/* $Id: display.c,v 1.31 2002/08/17 13:10:23 reinelt Exp $
+/* $Id: display.c,v 1.32 2002/08/19 04:41:20 reinelt Exp $
*
* framework for device drivers
*
@@ -20,6 +20,9 @@
*
*
* $Log: display.c,v $
+ * Revision 1.32 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.31 2002/08/17 13:10:23 reinelt
* USBLCD driver added
*
@@ -191,6 +194,7 @@
#include "debug.h"
#include "cfg.h"
#include "display.h"
+#include "bar.h"
extern LCD BeckmannEgle[];
extern LCD Crystalfontz[];
diff --git a/display.h b/display.h
index 3afc736..8d3db89 100644
--- a/display.h
+++ b/display.h
@@ -1,4 +1,4 @@
-/* $Id: display.h,v 1.14 2001/03/16 16:40:17 ltoetsch Exp $
+/* $Id: display.h,v 1.15 2002/08/19 04:41:20 reinelt Exp $
*
* framework for device drivers
*
@@ -20,6 +20,9 @@
*
*
* $Log: display.h,v $
+ * Revision 1.15 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.14 2001/03/16 16:40:17 ltoetsch
* implemented time bar
*
@@ -84,19 +87,6 @@
#ifndef _DISPLAY_H_
#define _DISPLAY_H_
-#define BAR_L (1<<0)
-#define BAR_R (1<<1)
-#define BAR_U (1<<2)
-#define BAR_D (1<<3)
-#define BAR_H2 (1<<4)
-#define BAR_V2 (1<<5)
-#define BAR_LOG (1<<6)
-#define BAR_T (1<<7)
-
-#define BAR_H (BAR_L | BAR_R)
-#define BAR_V (BAR_U | BAR_D | BAR_T)
-#define BAR_HV (BAR_H | BAR_V)
-
typedef struct LCD {
char *name;
int rows;
diff --git a/parser.c b/parser.c
index 246a639..64544e7 100644
--- a/parser.c
+++ b/parser.c
@@ -1,4 +1,4 @@
-/* $Id: parser.c,v 1.16 2001/03/16 16:40:17 ltoetsch Exp $
+/* $Id: parser.c,v 1.17 2002/08/19 04:41:20 reinelt Exp $
*
* row definition parser
*
@@ -20,6 +20,9 @@
*
*
* $Log: parser.c,v $
+ * Revision 1.17 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.16 2001/03/16 16:40:17 ltoetsch
* implemented time bar
*
@@ -114,6 +117,7 @@
#include "debug.h"
#include "display.h"
+#include "bar.h"
#include "parser.h"
typedef struct {
diff --git a/pixmap.c b/pixmap.c
index 9baa7ed..26f3b2f 100644
--- a/pixmap.c
+++ b/pixmap.c
@@ -1,4 +1,4 @@
-/* $Id: pixmap.c,v 1.9 2001/05/27 07:19:28 reinelt Exp $
+/* $Id: pixmap.c,v 1.10 2002/08/19 04:41:20 reinelt Exp $
*
* generic pixmap driver
*
@@ -20,6 +20,9 @@
*
*
* $Log: pixmap.c,v $
+ * Revision 1.10 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.9 2001/05/27 07:19:28 reinelt
*
* fixed a warning in pixmap.c
@@ -88,6 +91,7 @@
#include <time.h>
#include "display.h"
+#include "bar.h"
#include "pixmap.h"
#include "fontmap.h"
#include "debug.h"
diff --git a/processor.c b/processor.c
index 5747ecc..b53eb56 100644
--- a/processor.c
+++ b/processor.c
@@ -1,4 +1,4 @@
-/* $Id: processor.c,v 1.26 2001/05/06 10:01:27 reinelt Exp $
+/* $Id: processor.c,v 1.27 2002/08/19 04:41:20 reinelt Exp $
*
* main data processing
*
@@ -20,6 +20,9 @@
*
*
* $Log: processor.c,v $
+ * Revision 1.27 2002/08/19 04:41:20 reinelt
+ * introduced bar.c, moved bar stuff from display.h to bar.h
+ *
* Revision 1.26 2001/05/06 10:01:27 reinelt
*
* fixed a bug which prevented extendet tokens to be used for GPO's
@@ -154,6 +157,7 @@
#include "isdn.h"
#include "parser.h"
#include "display.h"
+#include "bar.h"
#include "processor.h"
#include "mail.h"
#include "battery.h"