aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Laviola <claviola@debian.org>2006-10-26 23:01:19 -0300
committerJonathan McCrohan <jmccrohan@gmail.com>2012-05-08 14:48:35 +0100
commit6fe0872d9b672ea1a6fd4f811dde799f94f44245 (patch)
tree604fc6131e6fd3ee7a2aa8a96cc4844c685680d2
parente8ed9bd2e7597f7aefdfc7004a308f0e291c3ca7 (diff)
downloadfiglet-6fe0872d9b672ea1a6fd4f811dde799f94f44245.tar.gz
Imported Debian patch 2.2.2-1debian/2.2.2-1
-rw-r--r--chkfont.c63
-rw-r--r--debian/README.Debian7
-rw-r--r--debian/changelog152
-rw-r--r--debian/chkfont.652
-rw-r--r--debian/control21
-rw-r--r--debian/copyright76
-rw-r--r--debian/dirs1
-rw-r--r--debian/docs5
-rw-r--r--debian/examples/moolets14
-rw-r--r--debian/figlet.el50
-rw-r--r--debian/figlist.652
-rw-r--r--debian/manpages4
-rw-r--r--debian/postinst10
-rw-r--r--debian/prerm10
-rwxr-xr-xdebian/rules80
-rw-r--r--debian/showfigfonts.667
-rw-r--r--figlet.62
17 files changed, 645 insertions, 21 deletions
diff --git a/chkfont.c b/chkfont.c
index 8272207..0607511 100644
--- a/chkfont.c
+++ b/chkfont.c
@@ -1,6 +1,14 @@
#include <stdio.h>
#include <string.h>
#include <ctype.h>
+#ifdef __STDC__
+#include <stdlib.h>
+#endif
+
+#ifndef EXIT_SUCCESS
+#define EXIT_SUCCESS (0)
+#define EXIT_FAILURE (1)
+#endif
#define DATE "20 Feb 1996"
#define VERSION "2.2"
@@ -19,18 +27,24 @@
full o' bugs ....
*/
+/* Squashed some warnings and a double free(): Kenneth Davies Mar 14 2005 */
+
/* #define CHECKBLANKS */
#define FONTFILESUFFIX ".flf"
#define FONTFILEMAGICNUMBER "flf2"
-char posshardblanks[9] = { '!', '@', '#', '$', '%', '&', '*', 0x7f, 0 };
+
+const char
+posshardblanks[9] = { '!', '@', '#', '$', '%', '&', '*', '\177', '\0' };
char *myname,*fontfilename;
FILE *fontfile;
char hardblank;
-int charheight,upheight,maxlen=0,old_layout;
+int charheight,upheight,old_layout;
int spectagcnt;
-char *fileline;
-int maxlinelength=0,currline;
+char *fileline = NULL;
+int currline;
+int maxlinelength=0;
+int maxlen=0;
int ec,wc;
int incon_endmarkwarn,endmark_countwarn,nonincrwarn;
@@ -38,8 +52,8 @@ int bigcodetagwarn,deutschcodetagwarn,asciicodetagwarn;
int codetagcnt;
int gone;
-void weregone(really)
-int really;
+void
+weregone(int really)
{
if (!really && 2*ec+wc<=40) {
return;
@@ -60,23 +74,23 @@ printf("------------------------------------------------------------------------
gone=1;
}
-char *my_alloc(size)
-int size;
+char *
+my_alloc(size_t size)
{
char *ptr;
ptr=(char *)malloc(size);
if (ptr==NULL) {
fprintf(stderr,"%s: Out of memory\n",myname);
+ exit(EXIT_FAILURE); /* Bail out now instead of not returning anything */
}
else {
return(ptr);
}
}
-int badsuffix(path,suffix)
-char *path;
-char *suffix;
+int
+badsuffix(char *path, char *suffix)
{
char ucsuffix[10];
char *s;
@@ -93,22 +107,30 @@ char *suffix;
return 1;
}
-void usageerr()
+void
+usageerr()
{
fprintf(stderr,"chkfont by Glenn Chappell <ggc@uiuc.edu>\n");
fprintf(stderr,"Version: %s, date: %s\n",VERSION,DATE);
fprintf(stderr,"Checks figlet 2.0/2.1 font files for format errors.\n");
fprintf(stderr,"(Does not modify font files.)\n");
fprintf(stderr,"Usage: %s fontfile ...\n",myname);
-exit(1);
+exit(EXIT_FAILURE);
}
-void readchar()
+void
+readchar()
{
-int i,expected_width,k,len,newlen,diff,l;
+int i,expected_width,k,diff,l;
char endmark,expected_endmark;
int leadblanks,minleadblanks,trailblanks,mintrailblanks;
+int len, newlen;
+
+ minleadblanks=0;
+ expected_endmark='\0';
+ expected_width=0;
+ mintrailblanks=0;
for (i=0;i<charheight;i++) {
fgets(fileline,maxlen+1000,fontfile);
@@ -202,7 +224,8 @@ if (minleadblanks+mintrailblanks>0 && old_layout>=0) {
}
-void checkit()
+void
+checkit()
{
int i,k,cmtcount,numsread,ffrighttoleft,have_layout,layout;
char magicnum[5],cha;
@@ -223,7 +246,7 @@ else {
fontfile=fopen(fontfilename,"r");
if (fontfile == NULL) {
fprintf(stderr,"%s: Could not open file '%s'\n",myname,fontfilename);
- exit(1);
+ exit(EXIT_FAILURE);
}
}
@@ -258,6 +281,7 @@ numsread=sscanf(fileline,"%c %d %d %d %d %d %d %d %d",
&hardblank,&charheight,&upheight,&maxlen,&old_layout,&cmtcount,
&ffrighttoleft,&layout,&spectagcnt);
free(fileline);
+fileline = NULL;
if (numsread<7) {
ffrighttoleft=0;
}
@@ -436,9 +460,8 @@ weregone(1); if (gone) return;
}
-int main(argc,argv)
-int argc;
-char *argv[];
+int
+main(int argc, char *argv[])
{
int arg;
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..aac48d5
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,7 @@
+If you need more fonts for figlet, you can install figfonts, a package
+coming with several fonts supporting also cirillic languages.
+Unfortunately figfonts is not free, so it cannot be part of Debian;
+but you can fetch it from the ftp servers anyway, in the non-free
+section.
+
+Francesco Tapparo
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..60ea31e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,152 @@
+figlet (2.2.2-1) unstable; urgency=low
+
+ * New upstream release. (Closes: #388101)
+ * Does not suggest figlet-fonts. (Closes: #376176)
+ * chkfont.c: patched to fix nasty core dumps when attempting to read files
+ that are unexpected. Thanks to Kenneth Davies. (Closes: #300735)
+ * Include Sandro Tosi's font demonstration script. (Closes: #388099)
+ * /usr/bin/figlet is an alternative to /usr/bin/figlet-figlet now. This
+ change was made to pave the way for free figlet clones. Thanks to Sam
+ Hocevar for the patch. (Closes: #390549)
+
+ -- Carlos Laviola <claviola@debian.org> Thu, 26 Oct 2006 23:01:19 -0300
+
+figlet (2.2.1-4) unstable; urgency=high
+
+ * debian/control: forgot to change the binary package's Section from misc to
+ non-free/text. Really uploading to non-free this time.
+
+ -- Carlos Laviola <claviola@debian.org> Mon, 1 Nov 2004 15:14:52 -0300
+
+figlet (2.2.1-3) unstable; urgency=high
+
+ * debian/control: changed Section from misc to non-free/text while the
+ problems that land figlet in non-free, as brought up in bug #274950 are
+ being fixed. (Closes: #274950)
+
+ -- Carlos Laviola <claviola@debian.org> Sat, 9 Oct 2004 04:01:57 -0300
+
+figlet (2.2.1-2) unstable; urgency=low
+
+ * New maintainer.
+ * Bumped Standards-Version to 3.6.1.1.
+ * Nothing's actually installed in /usr/doc. (Closes: #190019)
+ * figlet.6: Replaced Ian Chai's e-mail address with the one he used
+ to subscribe to figlet's mailing list. (Closes: #273063)
+ * debian/control: figlet now Suggests: figfonts{-cjk}. (Closes: #271474)
+
+ -- Carlos Laviola <claviola@debian.org> Sat, 2 Oct 2004 01:36:08 -0300
+
+figlet (2.2.1-1) unstable; urgency=low
+
+ * new upstream release closes: Bug#175460
+ * removed obsolete files debian/readme and debian/changes
+ * switched to use debian/manpages
+ * updated chkfont manpage closes: Bug#93311
+ * updated figlist manpage closes: Bug#93312
+ * updated showfigfonts manpage closes: Bug#93313
+ * added a note about the existence of figfonts closes:Bug#185967
+ * set debhelper compatibility mode to 4
+ * changed the build dependency to require debhelper (>= 4)
+ * now standard version 3.5.9.0 compatible
+
+ -- Francesco Tapparo <cesco@debian.org> Sat, 5 Apr 2003 21:48:42 +0200
+
+figlet (2.2-11) unstable; urgency=low
+
+ * added the manpages of chkfont, figlist and showfigfonts: thanks
+ Jonathon Abbottjed rules
+
+ -- Francesco Tapparo <cesco@debian.org> Fri, 13 Apr 2001 11:05:54 +0200
+
+figlet (2.2-10) unstable; urgency=low
+
+ * figlet.el was misnamed (this close bug #75721)
+ * figlet now use an improved version of figlet.el (thanks to James
+ LewisMossls)
+ * renamed /usr/share/doc/figlet/changes.txt.gz to
+ /usr/share/doc/figlet/changelog.gz for a better debian policy
+ guidelines adherence
+ * veridied adherence to debian policy 3.2.1.0
+
+ -- Francesco Tapparo <cesco@debian.org> Sun, 5 Nov 2000 14:31:58 +0100
+
+figlet (2.2-9) unstable; urgency=low
+
+ * converted to debhelper
+ * some tweaks to the upstream Makefile: now it creates $(MANDIR) and it uses
+ install -d and not mkdir, and it creates the /usr/bin directory
+ * renamed changes to changes.txt
+ * moved the dynamically created changes.txt and readme.txt to the
+ debian subdir
+ * package moved to FHS
+ * added showfigfonts, figlist and chkfont to the distribution
+ * recompiled with glibc-2.1 (it was 2.0)
+ * verified compliance to policy 3.0.0.0
+ * changed the Replaces field from figfont (<< 2.2) to figfont
+ * added a Conflicts field against old version of figfonts and
+ figfonts-cjk
+
+ -- Francesco Tapparo <cesco@debian.org> Mon, 11 Oct 1999 14:44:39 +0200
+
+figlet (2.2-8) unstable; urgency=low
+
+ * updated my email address
+ * the build process is more friendly to the cross compilers now: this close
+ bug #32189
+
+ -- Francesco Tapparo <cesco@debian.org> Sun, 25 Apr 1999 21:54:08 +0200
+
+figlet (2.2-7) frozen unstable; urgency=low
+
+ * changed distribution to frozen/unstable
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Sun, 26 Apr 1998 14:09:35 +0200
+
+figlet (2.2-6) unstable; urgency=low
+
+ * move figlet.el to /usr/share/emacs/site-lisp: this solve bug #21219
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Tue, 21 Apr 1998 14:39:15 +0200
+
+figlet (2.2-5) unstable; urgency=low
+
+ * added the emacs helper figlet.el
+ * stripped the binaries (this would resolve the bug #15722)
+
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Sat, 13 Dec 1997 21:02:37 +0100
+
+figlet (2.2-4) unstable; urgency=low
+
+ * moved back to the main distribution
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Sun, 23 Nov 1997 13:42:09 +0100
+
+figlet (2.2-3) unstable; urgency=low
+
+ * now the upstream changelog file is gzipped
+ * verified adherence to debian policy 2.3.0.0
+ * removed bashisms (veryfied with ash and pdksh)
+ * now figlet don't use zipped fonts (for policy problems)
+ * added Replaces figfonts (<< 2.2). This solve bug #13343
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Sat, 25 Oct 1997 14:42:44 +0200
+
+figlet (2.2-2) unstable; urgency=low
+
+ * executable permission to showfigfonts and figlist
+ * used compressed fonts
+ * new maintainer
+
+ -- Francesco Tapparo <f.tapparo@vi.nettuno.it> Sat, 20 Sep 1997 19:14:27 +0200
+
+figlet (2.2-1) unstable; urgency=low
+
+ * New upstream source
+ * New maintaier
+ * New Standards version (Bug#9466)
+ * New section (non-free)
+
+ -- Martin Schulze <joey@finlandia.infodrom.north.de> Wed, 3 Sep 1997 21:20:58 +0200
+
diff --git a/debian/chkfont.6 b/debian/chkfont.6
new file mode 100644
index 0000000..4476d88
--- /dev/null
+++ b/debian/chkfont.6
@@ -0,0 +1,52 @@
+.\" chkfont
+.\" By Glenn Chappell <ggc@uiuc.edu>
+.\"
+.\" This program checks figlet 2.0/2.1 font files for format errors.
+.\" It also looks for signs of common problems and gives warnings.
+.\" chkfont does not modify font files.
+.\"
+.\" Usage: chkfont fontfile ...
+.\"
+.\" Note: This is very much a spare-time project. It's probably
+.\" full o' bugs.
+.\"
+.\" Manual page by Jonathon Abbott, for the Debian Project
+.\" slightly modified by Francesco Tapparo, for the Debian Project
+.TH CHKFONT 6 "9 April 2001" "v2.2.1"
+
+.SH NAME
+chkfont \- checks figlet 2.0 and up font files for format errors
+
+.SH SYNOPSIS
+.B chkfont
+[
+.I fontfile
+]
+
+.SH DESCRIPTION
+This program checks figlet 2.0 and up font files for format errors.
+It also looks for signs of common problems and gives warnings.
+chkfont does not modify font files.
+
+.SH EXAMPLES
+To use
+.B chkfont
+on the "big" font
+.RS
+
+.B example% chkfont /usr/share/figlet/big.flf
+
+.RE
+
+.SH BUGS
+Doesn't work on compressed font files.
+
+.SH AUTHORS
+chkfont was written by Glenn Chappell <ggc@uiuc.edu>
+
+This manual page was written by Jonathon Abbott for the Debian Project.
+
+.SH "SEE ALSO"
+.BR figlet (6),
+.BR showfigfonts (6),
+.BR figlist (6)
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f042c3a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: figlet
+Maintainer: Carlos Laviola <claviola@debian.org>
+Section: non-free/text
+Priority: optional
+Standards-Version: 3.6.1.1
+Build-Depends: debhelper (>= 4.0.0)
+
+Package: figlet
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: figfonts
+Suggests: figfonts, figfonts-cjk
+Conflicts: figfonts (<= 2.2-3), figfonts-cjk (<= 2.2-3)
+Section: non-free/text
+Priority: optional
+Description: Frank, Ian & Glenn's Letters
+ Figlet is a program that creates large characters out of ordinary screen
+ characters. It can create characters in many different styles and can
+ kern and "smush" these characters together in various ways. Figlet
+ output is generally reminiscent of the sort of "signatures" many people
+ like to put at the end of e-mail and Usenet messages.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..840a549
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,76 @@
+This is the Debian Linux prepackaged version of Figlet, a program for doing
+things
+ _ _ _ _ _ _
+| (_) | _____ | |_| |__ (_)___
+| | | |/ / _ \ | __| '_ \| / __|
+| | | < __/ | |_| | | | \__ \_
+|_|_|_|\_\___| \__|_| |_|_|___(_)
+
+This package was originally put together by Robert Leslie <rob@mars.org>,
+and the maintained Martin Schulze <joey@debian.org>. Now it's maintained by
+Francesco Tapparo <cesco@debian.org> with sources obtained from:
+ ftp://ftp.nicoh.com/pub/figlet/program/unix/figlet22.tar.gz
+
+ figlet (c) 1991, 1993, 1994 Glenn Chappell and Ian Chai
+ Internet: <ggc@uiuc.edu> and <chai@uiuc.edu>
+ FIGlet Copyright 1996, 1997 John Cowan^M
+ Portions written by Paul Burton^
+ figlet, along with the various figlet fonts and documentation, may be
+ freely copied and distributed.
+
+/*
+ * crc.c - CRC calculation routine
+ *
+ * Version 1.0
+ *
+ * Copyright (c) 1995, Edward B. Hamrick
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and
+ * its documentation for any purpose is hereby granted without fee, provided
+ * that
+ *
+ * (i) the above copyright notice and the text in this "C" comment block
+ * appear in all copies of the software and related documentation, and
+ *
+ * (ii) any modifications to this source file must be sent, via e-mail
+ * to the copyright owner (currently hamrick@primenet.com) within
+ * 30 days of such modification.
+ *
+ * THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
+ * WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
+ *
+ * IN NO EVENT SHALL EDWARD B. HAMRICK BE LIABLE FOR ANY SPECIAL, INCIDENTAL,
+ * INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER
+ * RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF
+ * THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
+In addition, the authors have approved the following copyright
+addendum, according to Robert Leslie:
+
+ This program may be sold as a component of the Debian Linux
+ distribution or a Linux distribution derived from the Debian
+ Linux distribution. If it is distributed in binary form, the
+ source code must be included in the distribution as well.
+
+You may wish to visit the following Figlet WWW sites:
+
+ http://st-www.cs.uiuc.edu/users/chai/figlet.html
+ http://www.math.uiuc.edu/~chappell/figlet/
+
+The official FIGlet web page: http://st-www.cs.uiuc.edu/~chai/figlet.html
+
+If you like FIGlet (hey, even if you *hate* FIGlet), please send an
+e-mail message to <figlet@uiuc.edu>.
+
+We run an e-mail list dedicated to FIGlet software and font
+announcements, as well as general discussion about FIGlet. If you
+would like to be on this list, send e-mail to listserv@vmd.cso.uiuc.edu
+with the message body
+ subscribe figlet-l YOUR NAME
+where YOUR NAME should be replaced with your name. For those who don't
+want to be bothered with the discussions, the list can be configured so
+that you only see software update notices, or only software and font
+announcements.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..e772481
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+usr/bin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..2e624cb
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,5 @@
+README
+figfont.txt
+debian/README.Debian
+
+
diff --git a/debian/examples/moolets b/debian/examples/moolets
new file mode 100644
index 0000000..284ebd3
--- /dev/null
+++ b/debian/examples/moolets
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Prints "Moo" using every font installed on /usr/share/figlet
+# Written by Sandro Tosi <matrixhasu@gmail.com>
+
+> /tmp/moolets
+
+for file in /usr/share/figlet/*.flf ; do
+ FONT=`basename $file | sed 's|\(.*\)\.\(.*\)|\1|'`
+
+ echo -e "Font: $FONT \n" >> /tmp/moolets
+ figlet -f $FONT Moo >> /tmp/moolets
+ echo -e "\n\n" >> /tmp/moolets
+done
diff --git a/debian/figlet.el b/debian/figlet.el
new file mode 100644
index 0000000..c9e0ae6
--- /dev/null
+++ b/debian/figlet.el
@@ -0,0 +1,50 @@
+;; filename: figlet.el
+;; Kirby Files, 9/18/94. kfiles@bbn.com
+;; add font completion: James LewisMoss 27 Oct 2000, dres@debian.org
+;; feel free to modify and distribute; there's not a lot here.
+;; call M-x figlet-message to insert a large ascii text in your buffer.
+;; Current option is to center text. Feel free to change this if you'd
+;; like.
+(defvar fig-options "-c")
+
+(setq save-eval-depth max-lisp-eval-depth)
+(setq max-lisp-eval-depth 1000)
+
+(defun collapse-lists (da-list)
+ (cond ((stringp da-list) (list da-list))
+ ((null da-list) nil)
+ (t (append (collapse-lists (car da-list))
+ (collapse-lists (cdr da-list))))))
+
+(defun generate-figlet-font-list (loc-list)
+ "Generate a list of figlet fonts."
+ (mapcar
+ '(lambda (element)
+ (cons element nil))
+ (mapcar
+ '(lambda (one-file)
+ (let ((point (string-match ".flf" one-file)))
+ (substring one-file 0 point)))
+ (collapse-lists
+ (mapcar
+ '(lambda (dir-string)
+ (directory-files (expand-file-name dir-string)
+ nil ".*\.flf"))
+ loc-list)))))
+
+;; replace this with "figlet -I2" to get the default font dir
+(defvar fig-font-locations '("/usr/share/figlet"))
+
+(defvar fig-font-list (generate-figlet-font-list fig-font-locations))
+
+(defun figlet-message ()
+ "Inserts large message of text in ASCII font into current buffer"
+ (interactive)
+ (setq str (read-from-minibuffer "Enter message: "))
+ (setq font
+ (completing-read "Which font: " fig-font-list nil t))
+ (call-process "figlet" nil t t "-f" font fig-options str)
+ (message "Done printing"))
+
+
+(setq max-lisp-eval-depth save-eval-depth)
diff --git a/debian/figlist.6 b/debian/figlist.6
new file mode 100644
index 0000000..cdf7d5c
--- /dev/null
+++ b/debian/figlist.6
@@ -0,0 +1,52 @@
+.\" figlist by Glenn Chappell <ggc@uiuc.edu>
+.\" figlet release 2.1.1 -- 25 Aug 1994
+.\"
+.\" Lists all fonts and control files in figlet's default font directory.
+.\" Replaces "figlet -F", which was removed from figlet version 2.1.
+.\"
+.\" Usage: figlist [ -d directory ]
+.\"
+.\" Manual page by Jonathon Abbott, for the Debian Project
+.\" slightly modified by Francesco Tapparo, for the Debian Project
+.TH FIGLIST 6 "9 April 2001" "v2.2.1"
+
+.SH NAME
+figlist \- lists figlet fonts and control files
+
+.SH SYNOPSIS
+.B figlist
+[
+.B \-d
+.I directory
+]
+
+.SH DESCRIPTION
+Lists all fonts and control files in figlet's default font directory.
+Replaces "figlet -F", which was removed from figlet version 2.1.
+
+.SH EXAMPLES
+To use
+.B figlist
+with its default settings, simply type
+.RS
+
+.B example% figlist
+
+.RE
+
+To list all the font and control files in /usr/share/fonts/figlet
+.RS
+
+.B example% figlist -d /usr/share/fonts/figlet
+
+.RE
+
+.SH AUTHORS
+figlist was written by Glenn Chappell <ggc@uiuc.edu>
+
+This manual page was written by Jonathon Abbott for the Debian Project.
+
+.SH "SEE ALSO"
+.BR figlet (6),
+.BR chkfont (6),
+.BR showfigfonts (6)
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..394ab1c
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1,4 @@
+debian/chkfont.6
+figlet.6
+debian/figlist.6
+debian/showfigfonts.6
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..739f0f7
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$1" = configure ]; then
+ # Add an alternative for figlet
+ update-alternatives --install /usr/bin/figlet figlet \
+ /usr/bin/figlet-figlet 30
+fi
+
+#DEBHELPER#
+
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 0000000..6bc7471
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$1" = remove ]; then
+ # Remove alternative for figlet
+ update-alternatives --remove figlet /usr/bin/figlet-figlet
+fi
+
+#DEBHELPER#
+
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8ef102a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,80 @@
+#!/usr/bin/make -f
+# adapted from a sample in the the debhelper
+# package
+# GNU copyright 1997 to 1999 by Joey Hess.
+# GNU copyright 2000 to 2003 by Francesco Tapparo
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+export DH_COMPAT=4
+export DH_OPTIONS= -p figlet
+
+export installbin = install -g root -o root -m 755
+export installdoc = install -g root -o root -m 644
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ -mkdir debian/trash
+
+ # Add here commands to compile the package.
+ $(MAKE) DEFAULTFONTDIR="/usr/share/figlet" DESTDIR="/usr/bin"
+
+ touch stamp-build
+
+clean:
+ dh_testdir
+ rm -f build-stamp
+ rm -f install-stamp
+ -rm -rf debian/trash
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ find . -name '*~' -exec rm {} \;
+ -rm -f stamp-build
+ -rm -f debian/figlet.elc
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_installexamples debian/examples/moolets
+
+ # Add here commands to install the package into debian/tmp.
+ $(MAKE) install DESTDIR=debian/figlet/usr/bin \
+ DEFAULTFONTDIR=debian/figlet/usr/share/figlet \
+ MANDIR=debian/trash
+ mv debian/figlet/usr/bin/figlet debian/figlet/usr/bin/figlet-figlet
+ $(installbin) -d debian/figlet/usr/share/emacs/site-lisp
+ $(installdoc) debian/figlet.el \
+ debian/figlet/usr/share/emacs/site-lisp/figlet.el
+
+ $(installbin) -d debian/figlet/usr/share/emacs/site-lisp
+ $(installdoc) debian/figlet.el debian/figlet/usr/share/emacs/site-lisp
+
+ touch install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installman
+ dh_installchangelogs CHANGES
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/showfigfonts.6 b/debian/showfigfonts.6
new file mode 100644
index 0000000..dfbb754
--- /dev/null
+++ b/debian/showfigfonts.6
@@ -0,0 +1,67 @@
+.\" showfigfonts by Glenn Chappell <ggc@uiuc.edu>
+.\" figlet release 2.1.1 -- 25 Aug 1994
+.\" Based on showfigfonts by Greg Galperin <grg@ai.mit.edu>, Nov 1993.
+.\"
+.\" Prints a list of available figlet fonts, along with a sample of each
+.\" font. If directory is given, lists fonts in that directory; otherwise
+.\" uses the default font directory. If word is given, prints that word
+.\" in each font; otherwise prints the font name.
+.\"
+.\" Usage: showfigfonts [ -d directory ] [ word ]
+.\"
+.\" Manual page by Jonathon Abbott, for the Debian Project
+.\" slightly modified by Francesco Tapparo, for the Debian Project
+.TH SHOWFIGFONTS 6 "9 April 2001" "v2.2.1"
+
+.SH NAME
+showfigfonts \- prints a list of available figlet fonts
+
+.SH SYNOPSIS
+.B showfigfonts
+[
+.B \-d
+.I directory
+]
+[
+.I word
+]
+
+.SH "DESCRIPTION"
+Prints a list of available figlet fonts, along with a sample of each
+font. If directory is given, lists fonts in that directory; otherwise
+uses the default font directory. If word is given, prints that word
+in each font; otherwise prints the font name.
+
+.SH EXAMPLES
+To use
+.B showfigfonts
+with its default settings, simply type
+.RS
+
+.B example% showfigfonts
+
+.RE
+
+To print all the fonts in /usr/share/fonts/figlet
+.RS
+
+.B example% showfigfonts -d /usr/share/fonts/figlet
+
+.RE
+
+To print the word foo using all available fonts
+.RS
+
+.B example% showfigfonts foo
+
+.RE
+
+.SH "AUTHORS"
+showfigfonts was written by Glenn Chappell <ggc@uiuc.edu>
+
+This manual page was written by Jonathon Abbott for the Debian Project.
+
+.SH "SEE ALSO"
+.BR figlet (6),
+.BR chkfont (6),
+.BR figlist (6)
diff --git a/figlet.6 b/figlet.6
index fc6d8fd..8e183c0 100644
--- a/figlet.6
+++ b/figlet.6
@@ -1028,7 +1028,7 @@ Glenn Chappell <c486scm@semovm.semo.edu> did most of the work.
You can e-mail him but he is not an e-mail fanatic; people who e-mail
Glenn will probably get answers, but if you e-mail his best friend:
-Ian Chai <ianchai@usa.net>, who
+Ian Chai <ianchai@rbacomm.com>, who
.I is
an e-mail fanatic, you'll get answers, endless conversation about the
mysteries of life, invitations to join some 473 mailing lists and a