aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-05-14 17:28:56 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-06-02 00:58:45 +0100
commit4604f47979cd5b782dffff3bce7b43750afc35d3 (patch)
treedbb8a1b8ff87342e06a49820b4fe50bea54415a3
parent1d068f976aeb1f1cb9df1f8d9b2a5ea946d10e4c (diff)
downloadfiglet-4604f47979cd5b782dffff3bce7b43750afc35d3.tar.gz
Hardcode install flags and paths in Makefile
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/makefile_set_debian_buildflags.patch29
-rw-r--r--debian/patches/makefile_set_debian_paths.patch22
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules4
5 files changed, 57 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index cdaad76..c549312 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ figlet (2.2.5-1) UNRELEASED; urgency=low
been relicenced, or replaced with properly licenced alternatives; figlet
can re-enter the archive, and can move back to main from non-free. \o/
- Drop 2.2.2-1 patches, applied upstream
+ - New upstream makefile does not support setting variables from
+ debian/rules; Added makefile_set_debian_{buildflags,paths}.patch
+ accordingly.
* Improve packaging
- Update S-V to 3.9.3
- Bump Debhelper to v9
diff --git a/debian/patches/makefile_set_debian_buildflags.patch b/debian/patches/makefile_set_debian_buildflags.patch
new file mode 100644
index 0000000..2ea6e17
--- /dev/null
+++ b/debian/patches/makefile_set_debian_buildflags.patch
@@ -0,0 +1,29 @@
+Description: Set the appropriate Debian buildflags flags in Makefile
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Mon, 28 May 2012 00:37:27 +0100
+---
+--- figlet-2.2.4.orig/Makefile
++++ figlet-2.2.4/Makefile
+@@ -19,10 +19,11 @@
+ SHELL = /bin/sh
+
+ # The C compiler and linker to use
++CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+ CC = gcc
+-CFLAGS = -g -O2 -Wall
++CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+ LD = gcc
+-LDFLAGS =
++LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+
+ # Feature flags:
+ # define TLF_FONTS to use TOIlet TLF fonts
+@@ -62,7 +63,7 @@ DFILES = Makefile Makefile.tc $(MANUAL)
+ crc.h inflate.h zipio.h utf8.h run-tests.sh figmagic
+
+ .c.o:
+- $(CC) -c $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \
++ $(CC) -c $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) -DDEFAULTFONTDIR=\"$(DEFAULTFONTDIR)\" \
+ -DDEFAULTFONTFILE=\"$(DEFAULTFONTFILE)\" -o $*.o $<
+
+ all: $(BINS)
diff --git a/debian/patches/makefile_set_debian_paths.patch b/debian/patches/makefile_set_debian_paths.patch
new file mode 100644
index 0000000..992733e
--- /dev/null
+++ b/debian/patches/makefile_set_debian_paths.patch
@@ -0,0 +1,22 @@
+Description: Set the appropriate Debian paths in Makefile
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Mon, 28 May 2012 00:37:27 +0100
+---
+--- figlet-2.2.4.orig/Makefile
++++ figlet-2.2.4/Makefile
+@@ -30,13 +30,13 @@ LDFLAGS = $(shell dpkg-buildflags --get
+ XCFLAGS = -DTLF_FONTS
+
+ # Where to install files
+-prefix = /usr/local
++prefix = /usr
+
+ # Where the executables should be put
+ BINDIR = $(prefix)/bin
+
+ # Where the man page should be put
+-MANDIR = $(prefix)/man
++MANDIR = $(prefix)/share/man
+
+ # Where figlet will search first for fonts (the ".flf" files).
+ DEFAULTFONTDIR = $(prefix)/share/figlet
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5867dd5
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+makefile_set_debian_buildflags.patch
+makefile_set_debian_paths.patch
diff --git a/debian/rules b/debian/rules
index e132006..754017b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,7 @@
#export DH_VERBOSE=1
override_dh_auto_install:
- $(MAKE) install BINDIR=debian/figlet/usr/bin \
- DEFAULTFONTDIR=debian/figletusr/share/figlet \
- MANDIR=debian/trash
+ dh_auto_install
mv debian/figlet/usr/bin/figlet debian/figlet/usr/bin/figlet-figlet
dh_installdirs /usr/share/emacs/site-lisp
dh_install debian/figlet.el /usr/share/emacs/site-lisp