aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2013-08-05 23:50:43 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2013-08-07 00:02:43 +0100
commit7978d8ff923d07240a8791a3653f195732d48736 (patch)
tree48e484510d5bf312bdb34fdb751f3a74efac6d0d /debian
parent3996fd3a7717885528bea82787f5a6033cfbef60 (diff)
downloaddtv-scan-tables-7978d8ff923d07240a8791a3653f195732d48736.tar.gz
Set snapshot date as date of latest upstream commit
Diffstat (limited to 'debian')
-rw-r--r--debian/get-vcs-snapshot.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/get-vcs-snapshot.sh b/debian/get-vcs-snapshot.sh
index b1309f5..de39e9e 100644
--- a/debian/get-vcs-snapshot.sh
+++ b/debian/get-vcs-snapshot.sh
@@ -8,12 +8,12 @@ echo Downloading latest snapshot from git repository...
DEB_SOURCE_PACKAGE=`egrep '^Source: ' debian/control | cut -f 2 -d ' '`
VERSION_UPSTREAM=`dpkg-parsechangelog | grep ^Version: | sed -e 's/^Version:\s*//' -e s/-[^-]*$// -e s/\+git.*//`
-VERSION_DATE=`/bin/date --utc +%0Y%0m%0d`
git clone --depth 1 ${GIT}
GIT_SHA=`git --git-dir="${DEB_SOURCE_PACKAGE}/.git" show --pretty=format:"%h" --quiet | head -1 || true`
+VERSION_DATE=`git --git-dir="${DEB_SOURCE_PACKAGE}/.git" log --no-color -1 --date=iso | sed -ne "s/Date:\s\+\(.*\).*/\1/p" | cut -d" " -f1 | tr -d "-"`
VERSION_FULL="${VERSION_UPSTREAM}+git${VERSION_DATE}.${GIT_SHA}"
TARBALL="../${DEB_SOURCE_PACKAGE}_${VERSION_FULL}.orig.tar.gz"