aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e4b2a0f..7b05f25 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,14 @@
CC=gcc
SDIR=src
+INSTALL=/usr/bin/install -c
MODBUSLOGCFLAGS=-I/usr/include/modbus
MODBUSLOGLIBS=-lmodbus -lconfig
+MODBUSLOGBINDIR=/usr/sbin
+MODBUSLOGCFGDIR=/etc
+MODBUSLOGLOGDIR=/var/modbuslog
FTPHELPERCFLAGS=
FTPHELPERLIBS=-lconfig
+FTPHELPERDIR=/usr/bin
all: modbuslog ftphelper
@@ -12,3 +17,15 @@ modbuslog: $(SDIR)/modbuslog.c
ftphelper: $(SDIR)/ftphelper.c
$(CC) -o $(SDIR)/$@ $^ $(FTPHELPERCFLAGS) $(FTPHELPERLIBS)
+
+install: all
+ $(INSTALL) $(SDIR)/modbuslog $(MODBUSLOGBINDIR)/modbuslog
+ test -f $(MODBUSLOGCFGDIR)/modbuslog.cfg || $(INSTALL) -m 644 $(SDIR)/modbuslog.cfg $(MODBUSLOGCFGDIR)/modbuslog.cfg
+ @if [ ! -d $(MODBUSLOGLOGDIR) ]; \
+ then \
+ mkdir $(MODBUSLOGLOGDIR); \
+ mkdir $(MODBUSLOGLOGDIR)/interval; \
+ fi
+ test -f $(MODBUSLOGLOGDIR)/interval/interval.txt || $(INSTALL) -m 644 $(SDIR)/interval.txt $(MODBUSLOGLOGDIR)/interval/interval.txt
+ $(INSTALL) $(SDIR)/ftpupload $(FTPHELPERDIR)/ftpupload
+ $(INSTALL) $(SDIR)/ftphelper $(FTPHELPERDIR)/ftphelper
ons'>+1 2012-03-09* Rewrite init script to use lsb-base functionsJonathan McCrohan2-7/+13 - fixes issue where invoke-rc.d would return error status during installation 2012-03-09Add watchfile lintian override; Using upstream svn instead Jonathan McCrohan2-1/+4 2012-03-08Update to S-V 3.9.3Jonathan McCrohan2-2/+3 2012-03-08* Rewrite init script to use lsb-base functions.Jonathan McCrohan3-15/+16 - init.d-script-does-not-implement-optional-option 2012-03-08copyright-refers-to-symlink-licenseJonathan McCrohan2-2/+3 2012-03-08* Lintian fixesJonathan McCrohan2-4/+7 - spelling-error-in-manpage 2012-03-08Import upstream version 0.11.0~svn1180Jonathan McCrohan19-2871/+3952 2011-12-27Import upstream version 0.11.0~svn1165Jonathan McCrohan6-166/+495 2011-12-25Import upstream version 0.11.0~svn1164Jonathan McCrohan11-162/+315 2011-12-25Update libmysqlclient-dev virtual package in build-depends.Jonathan McCrohan1-1/+1 Thanks to Clint Byrum <clint@ubuntu.com> for the patch. 2011-08-31Import upstream version 0.11.0~svn1159Jonathan McCrohan4-5/+5 2011-08-30update debian/changelogReinhard Tartler1-1/+4 2011-08-28* New upstream snapshotJonathan McCrohan2-4/+11 * Make lcd4linux linux specific (requested by kFreeBSD team) * Add optional build targets build-indep and build-dep (thanks to lintian for catching this) 2011-08-26Import upstream version 0.11.0~svn1158Reinhard Tartler34-1743/+4490 2011-08-20normalize with wrap-and-sort(1)Reinhard Tartler2-17/+20 2011-08-20Make lcd4linux linux specificReinhard Tartler1-2/+1 on request of freebsd porters: http://permalink.gmane.org/gmane.linux.debian.devel.general/164670 2011-04-29add sqlite3-dev to build dependssiretart@tauware.de2-2/+4 2011-04-29mention new co-maintainersiretart@tauware.de1-0/+1 2011-04-29add libdbus-1-dev to build dependssiretart@tauware.de2-1/+3 2011-04-29normalize fields with wrap-and-sort(1)siretart@tauware.de2-18/+20 2011-04-29fix order of calling dh_autoreconf_cleansiretart@tauware.de1-1/+1 avoids leftover debhelper log file 2011-04-29Add Uploader details to Debian PackageJonathan McCrohan1-0/+1 2011-04-27Bug fix: "script lcd4linux/init.d/lcd4linux missing dependency onReinhard Tartler2-1/+5 $syslog", thanks to Petter Reinholdtsen (Closes: #582825). 2011-04-27No longer build the mpd module. Closes: #578226Reinhard Tartler1-0/+1 2011-04-27No longer compile against Python. Python 2.6 now links against libssl,Reinhard Tartler2-2/+3 which is in conflicts with the package license GPL.