aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2011-10-12 21:50:48 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2011-10-12 21:50:48 +0100
commit6cfbf2dee130cc36a72d57adea0e9c04bb31f620 (patch)
tree638bcaf4c63e3d3be17e0f5e7d74639394d15702 /tests/Makefile.am
downloadverteco-6cfbf2dee130cc36a72d57adea0e9c04bb31f620.tar.gz
Initial commit
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..2633873
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,41 @@
+EXTRA_DIST = README
+
+noinst_PROGRAMS = \
+ bandwidth-server-one \
+ bandwidth-server-many-up \
+ bandwidth-client \
+ random-test-server \
+ random-test-client \
+ unit-test-server \
+ unit-test-client \
+ version
+
+common_ldflags = \
+ $(top_builddir)/src/libmodbus.la
+
+bandwidth_server_one_SOURCES = bandwidth-server-one.c
+bandwidth_server_one_LDADD = $(common_ldflags)
+
+bandwidth_server_many_up_SOURCES = bandwidth-server-many-up.c
+bandwidth_server_many_up_LDADD = $(common_ldflags)
+
+bandwidth_client_SOURCES = bandwidth-client.c
+bandwidth_client_LDADD = $(common_ldflags)
+
+random_test_server_SOURCES = random-test-server.c
+random_test_server_LDADD = $(common_ldflags)
+
+random_test_client_SOURCES = random-test-client.c
+random_test_client_LDADD = $(common_ldflags)
+
+unit_test_server_SOURCES = unit-test-server.c unit-test.h
+unit_test_server_LDADD = $(common_ldflags)
+
+unit_test_client_SOURCES = unit-test-client.c unit-test.h
+unit_test_client_LDADD = $(common_ldflags)
+
+version_SOURCES = version.c
+version_LDADD = $(common_ldflags)
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/src
+CLEANFILES = *~