/* $Id: bar.c,v 1.4 2003/01/12 06:51:27 reinelt Exp $ * * generic bar handling * * Copyright 2002 by Michael Reinelt (reinelt@eunet.at) * * This program is free software; you can redistribute it and/or modify * it under the terms of the GNU General Public License as published by * the Free Software Foundation; either version 2, or (at your option) * any later version. * * This program is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU General Public License for more details. * * You should have received a copy of the GNU General Public License * along with this program; if not, write to the Free Software * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. * * * $Log: bar.c,v $ * Revision 1.4 2003/01/12 06:51:27 reinelt * fixed bug in bar compaction * * Revision 1.3 2002/08/19 07:52:19 reinelt * corrected type declaration of (*defchar)() * * Revision 1.2 2002/08/19 07:36:29 reinelt * * finished bar.c, USBLCD is the first driver that uses the generic bar functions * * Revision 1.1 2002/08/19 04:41:20 reinelt * introduced bar.c, moved bar stuff from display.h to bar.h * * */ /* * exported functions: * * int bar_init (int rows, int cols, int xres, int yres, int chars) * * void bar_clear(void) * * void bar_add_segment(int len1, int len2, int type, int ascii) * * int bar_draw (int type, int row, int col, int max, int len1, int len2) * * int bar_process (void(*defchar)(int ascii, char *matrix)) * * int bar_peek (int row, int col) * */ #include #include "bar.h" #include "debug.h" static int ROWS=0; static int COLS=0; static int XRES=0; static int YRES=0; static int CHARS=0; static int nSegment=0; static int fSegment=0; static SEGMENT Segment[128]; static BAR *Bar=NULL; int bar_init (int rows, int cols, int xres, int yres, int chars) { if (rows<1 || cols<1) return -1; ROWS=rows; COLS=cols; XRES=xres; YRES=yres; CHARS=chars; if (Bar) { free (Bar); } if ((Bar=malloc (ROWS*COLS*sizeof(BAR)))==NULL) { return -1; } bar_clear(); nSegment=0; fSegment=0; return 0; } void bar_clear(void) { int n; for (n=0; nmax) len1=max; if (len2<1) len2=1; else if (len2>max) len2=max; switch (type) { case BAR_L: len1=max-len1; len2=max-len2; rev=1; case BAR_R: while (max>0 && col=XRES) { Bar[row*COLS+col].len1=rev?0:XRES; len1-=XRES; } else { Bar[row*COLS+col].len1=rev?XRES-len1:len1; len1=0; } if (len2>=XRES) { Bar[row*COLS+col].len2=rev?0:XRES; len2-=XRES; } else { Bar[row*COLS+col].len2=rev?XRES-len2:len2; len2=0; } max-=XRES; col++;
Source: lcd4linux
Section: utils
Priority: extra
Maintainer: Samuel Mimram <samuel.mimram@ens-lyon.org>
Build-Depends: debhelper (>= 4.0.0), xlibs-dev
Standards-Version: 3.6.0

Package: lcd4linux
Architecture: any
Depends: xlibs, ${shlibs:Depends}
Description: Display informations on an external liquid crystal display
 Grab informations from the kernel and some subsystems and display it on an
 external liquid crystal display.
 .
 The use of special sequences (tokens) gives you full control of the layout,
 and therefore lcd4linux is completely independent from the display size.