#!/usr/bin/make -f # -*- makefile -*- # Sample debian/rules that uses debhelper. # GNU copyright 1997 to 1999 by Joey Hess. # Uncomment this to turn on verbose mode. #export DH_VERBOSE=1 DESTDIR=$(CURDIR)/debian/lcd4linux # These are used for cross-compiling and for saving the configure script # from having to guess our platform (since we know it already) DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) CFLAGS = -Wall -g ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) CFLAGS += -O0 else CFLAGS += -O2 endif ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) INSTALL_PROGRAM += -s endif config.status: configure dh_testdir CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr build: build-stamp build-stamp: config.status dh_testdir $(MAKE) #/usr/bin/docbook-to-man debian/lcd4linux.sgml > lcd4linux.1 touch build-stamp clean: dh_testdir dh_testroot rm -f build-stamp -$(MAKE) distclean dh_clean install: build dh_testdir dh_testroot dh_clean -k dh_installdirs $(MAKE) install DESTDIR=$(DESTDIR) mkdir -p $(DESTDIR)/etc cp lcd4linux.conf.sample $(DESTDIR)/etc/lcd4linux.conf # Build architecture-independent files here. binary-indep: build install # We have nothing to do by default. # Build architecture-dependent files here. binary-arch: build install dh_testdir dh_testroot dh_installchangelogs ChangeLog dh_installdocs # dh_installexamples dh_install dh_installdebconf dh_installinit # dh_installman dh_link dh_strip dh_compress dh_fixperms dh_makeshlibs dh_installdeb dh_shlibdeps dh_gencontrol dh_md5sums dh_builddeb binary: binary-indep binary-arch .PHONY: build clean binary-indep binary-arch binary install t name='qt'>
path: root/mkinstalldirs (unfollow)
AgeCommit message (Expand)AuthorFilesLines
2008-12-23indent runmichael1-4/+4
2008-11-25fix lcd4linux driver for multible onboard controllersmichux1-4/+4
2008-11-23fix automake - check for libftdimichux4-9/+173
2008-11-22update button_exec plugin - fix segfaultmichux1-3/+2
2008-11-22update fifo plugin - untestedmichux1-1/+1
2008-10-07Replace write to external variable usb_debug by calling usb_set_debug().bwalle7-16/+7
2008-10-06adding GPI to picoLCD for reading button events by Igor Mammedov <niallain@g...michael1-1/+22
2008-10-06properties fixedmichael11-3290/+2675
2008-10-05Rebuild auto-generated autoconf stuff due to last change in drivers.m4.bwalle3-2657/+3297
2008-10-05Add 'ULA200' driver when --with-drivers=all is specifiedbwalle1-0/+1
2008-09-14strftime_tz patch from Bernhard Wallemichael1-0/+11
2008-09-08strftime_tz() plugin by Bernhard Wallemichael1-0/+25
2008-09-03ULA200 driver by Bernhard Wallemichael7-2/+825
2008-09-03indentmichael1-4/+4
2008-08-31Increased the maximum bps to 230400, if defined in <termios.h>.sonic741-2/+7
2008-08-27git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@889 3ae390bd-cb1e-0410-...sonic741-18/+11
2008-08-27D4D updates by Svenmichael1-38/+60
2008-08-03driver for 4D Systems serial displays by Sven Killigmichael9-45/+846
2008-08-03signed/unsigned mismatchmichael1-3/+3
2008-07-26added command functionsmichux1-2/+130
2008-07-15added IRLCD driver by Jean-Philippe Civademichael10-5/+467
2008-07-15'autoreconf -f -i' run & config.rpath addedmichael8-370/+1617