#!/usr/bin/make -f # -*- makefile -*- # Sample debian/rules that uses debhelper. # GNU copyright 1997 to 1999 by Joey Hess. # Uncomment this to turn on verbose mode. #export DH_VERBOSE=1 DESTDIR=$(CURDIR)/debian/lcd4linux # These are used for cross-compiling and for saving the configure script # from having to guess our platform (since we know it already) DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) CFLAGS = -Wall -g ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) CFLAGS += -O0 else CFLAGS += -O2 endif ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) INSTALL_PROGRAM += -s endif config.status: configure dh_testdir CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr build: build-stamp build-stamp: config.status dh_testdir $(MAKE) #/usr/bin/docbook-to-man debian/lcd4linux.sgml > lcd4linux.1 touch build-stamp clean: dh_testdir dh_testroot rm -f build-stamp -$(MAKE) distclean dh_clean install: build dh_testdir dh_testroot dh_clean -k dh_installdirs $(MAKE) install DESTDIR=$(DESTDIR) mkdir -p $(DESTDIR)/etc cp lcd4linux.conf.sample $(DESTDIR)/etc/lcd4linux.conf # Build architecture-independent files here. binary-indep: build install # We have nothing to do by default. # Build architecture-dependent files here. binary-arch: build install dh_testdir dh_testroot dh_installchangelogs ChangeLog dh_installdocs # dh_installexamples dh_install dh_installdebconf dh_installinit # dh_installman dh_link dh_strip dh_compress dh_fixperms dh_makeshlibs dh_installdeb dh_shlibdeps dh_gencontrol dh_md5sums dh_builddeb binary: binary-indep binary-arch .PHONY: build clean binary-indep binary-arch binary install ue='master'/>
path: root/missing (unfollow)
AgeCommit message (Expand)AuthorFilesLines
2007-09-15GPS plugin V0.3 by michumichael1-40/+143
2007-09-15GPS plugin V0.2 by michumichael1-69/+267
2007-09-09email address changedmichael107-109/+109
2007-07-27Fix compilation with kernel 2.6.22 by Guillaume LECERFmichael1-1/+4
2007-07-27MPD plugin patch from michumichael1-1/+22
2007-07-27GPS plugin update by michumichael1-131/+248
2007-07-27indentationmichael2-106/+108
2007-06-21default for Brightness is 255volker1-1/+1
2007-06-20LCD::brightness in drv_X11 correctedvolker1-2/+10
2007-06-20global variable for backlight colorvolker1-0/+1
2007-06-20keypad support completed; new property brightness implementedvolker1-40/+175
2007-06-20maximum value for brightness is 8volker1-2/+2
2007-06-17buttons for X11 driver (thanks to Volker Gering)michael1-8/+49
2007-06-17Apple has no utsbuf.domainname (thanks to Volker Gering)michael1-1/+1
2007-06-17strndup() replacementmichael1-0/+24
2007-06-17better usage output by Volker Geringmichael1-4/+20
2007-06-08Image driver libgd dependancy fixmichael5-6/+31
2007-06-04big MPD patch from Robert Buchholzmichael1-79/+86
2007-05-19gps plugin, code by michu / www.neophob.commichael7-0/+580
2007-05-17compile error on m68k fixed (debian bug 405898)michael3-10/+170
2007-05-04typo in LUIse driver fixedmichael1-1/+1
2007-05-02some compiler warnings fixedmichael6-8/+14
2007-04-30LCD4Linux-0.10.1-RC2michael1-1/+1
2007-04-30ChangeLog updatedmichael1-1782/+3099
2007-04-30svn2cl moved and optimizedmichael1-6/+0