#!/usr/bin/make -f # -*- makefile -*- # Sample debian/rules that uses debhelper. # GNU copyright 1997 to 1999 by Joey Hess. # Uncomment this to turn on verbose mode. #export DH_VERBOSE=1 DESTDIR=$(CURDIR)/debian/lcd4linux # These are used for cross-compiling and for saving the configure script # from having to guess our platform (since we know it already) DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) CFLAGS = -Wall -g ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) CFLAGS += -O0 else CFLAGS += -O2 endif ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) INSTALL_PROGRAM += -s endif config.status: configure dh_testdir CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr build: build-stamp build-stamp: config.status dh_testdir $(MAKE) #/usr/bin/docbook-to-man debian/lcd4linux.sgml > lcd4linux.1 touch build-stamp clean: dh_testdir dh_testroot rm -f build-stamp -$(MAKE) distclean dh_clean install: build dh_testdir dh_testroot dh_clean -k dh_installdirs $(MAKE) install DESTDIR=$(DESTDIR) mkdir -p $(DESTDIR)/etc cp lcd4linux.conf.sample $(DESTDIR)/etc/lcd4linux.conf # Build architecture-independent files here. binary-indep: build install # We have nothing to do by default. # Build architecture-dependent files here. binary-arch: build install dh_testdir dh_testroot dh_installchangelogs ChangeLog dh_installdocs # dh_installexamples dh_install dh_installdebconf dh_installinit # dh_installman dh_link dh_strip dh_compress dh_fixperms dh_makeshlibs dh_installdeb dh_shlibdeps dh_gencontrol dh_md5sums dh_builddeb binary: binary-indep binary-arch .PHONY: build clean binary-indep binary-arch binary install nfo.c'>
path: root/plugin_meminfo.c (unfollow)
AgeCommit message (Collapse)AuthorFilesLines
2008-04-12clean upmichux1-171/+188
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@871 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-10Add the year 2008 to the copyrightmichux1-1/+1
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@870 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-10Add basic FIFO pluginmichux4-0/+197
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@869 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-04fixed autoconfmichux2-0/+3
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@868 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-04update autoconfmichux5-2392/+438
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@867 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-04Add asterisk plugin, thanks to mcarey@yostengineering.commichux3-1/+197
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@866 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-03fix typo, close #114michux1-1/+1
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@865 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-04-03update charset for Crystalfontz Model 632 and 634michux2-3/+87
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@864 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-03-05improve error messagesmichux1-7/+13
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@863 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-03-03reformat plugin_mpd - use c style commentsmichux1-8/+8
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@862 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-03-03correct code format (indent)michux1-2/+2
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@861 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
2008-03-03correct code format (indent)michux5-184/+185
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@860 3ae390bd-cb1e-0410-b409-cd5a39f66f1f