aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7e5a7f4..ef69b35 100644
--- a/configure.in
+++ b/configure.in
@@ -100,6 +100,10 @@ if test "$with_python" = "yes"; then
AC_PYTHON_DEVEL
fi
+# check for parport
+#AC_CHECK_HEADERS(asm/io.h)
+AC_CHECK_HEADERS([asm/io.h] [linux/parport.h linux/ppdev.h], [has_parport="true"], [has_parport="false"])
+
# drivers
sinclude(drivers.m4)
@@ -110,8 +114,6 @@ sinclude(plugins.m4)
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h sys/vfs.h syslog.h termios.h unistd.h])
-AC_CHECK_HEADERS(asm/io.h)
-AC_CHECK_HEADERS(linux/parport.h linux/ppdev.h)
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST