aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2005-06-10 11:22:28 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2005-06-10 11:22:28 +0000
commit2140b533b376fb859bc5ea8e9b46dd6cba035d2b (patch)
tree36abaeb726aab9cc4794a5f8c4aa0f75225c85b1 /configure.in
parent49853f2611471866847fbc5ae108e9a4ea976b85 (diff)
downloadlcd4linux-2140b533b376fb859bc5ea8e9b46dd6cba035d2b.tar.gz
[lcd4linux @ 2005-06-10 11:22:28 by reinelt]
double-check for X11 headers (AC_PATH_XTRA is buggy) git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@574 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to '')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 270b71e..bfdaf0c 100644
--- a/configure.in
+++ b/configure.in
@@ -47,9 +47,17 @@ AC_CHECK_CURSES
# Checks for X11
AC_PATH_XTRA
+# double-check for X11
+if test "$no_x" != "yes"; then
+ AC_CHECK_HEADERS(X11/Xlib.h X11/Xutil.h, [no_x="$no_x"], [no_x="yes"])
+ if test "$no_x" = "yes"; then
+ AC_MSG_WARN([configure thinks X11 is available while it is *not*])
+ AC_MSG_WARN([maybe someone wants to fix autoconf's AC PATH XTRA])
+ fi
+fi
# check for gd.h
-AC_CHECK_HEADERS(gd/gd.h gd.h, [has_gd="true";break], [has_gd="false"])
+AC_CHECK_HEADERS(gd/gd.h gd.h, [has_gd="true"; break], [has_gd="false"])
# check for usb.h
AC_CHECK_HEADERS(usb.h, [has_usb="true"], [has_usb="false"])