#!/bin/sh # # Slackware build script for wavemon # # Contributed by Christoph J. Thompson # CWD=`pwd` NAME=wavemon VERSION=0.5 ARCH=i586 BUILD=1 PKGNAME=$NAME PKGVER=$VERSION BASEDIR=$PKGNAME-$PKGVER ARCHIVE=$PKGNAME-current.tar.bz2 REPOSITORY=http://eden-feed.erg.abdn.ac.uk/wavemon FLAGS="-O2 -march=pentium -mtune=pentium -fno-strength-reduce \ -fomit-frame-pointer -ffast-math" PKG=/tmp/package-$NAME rm -rf $PKG mkdir -p $PKG # Obtain sources if [ ! -e $ARCHIVE ]; then if `wget "$REPOSITORY/$ARCHIVE"`; then true else exit 1 fi fi # Compile cd /tmp tar jxvf $CWD/$ARCHIVE cd $BASEDIR CFLAGS="${FLAGS}" CXXFLAGS="${FLAGS}" ./configure \ --prefix=/usr \ --mandir=/usr/man \ --sysconfdir=/etc \ --localstatedir=/var make CFLAGS="${FLAGS}" # Install make install DESTDIR=$PKG mkdir -p $PKG/install $PKG/usr/doc/$NAME-$VERSION cat > $PKG/install/slack-desc < $PKG/install/slack-required <= 5.6-i486-3 EOF install -m644 -g0 -o0 AUTHORS README \ $PKG/usr/doc/$NAME-$VERSION chmod 444 $PKG/usr/man/man?/*.? gzip -9nf $PKG/usr/man/man?/*.? strip \ $PKG/usr/bin/* || : chown -R root.root $PKG # Make package cd $PKG cat install/slack-desc | grep "$NAME:" > /tmp/$NAME-$VERSION-$ARCH-$BUILD.txt makepkg -l y -c n /tmp/$NAME-$VERSION-$ARCH-$BUILD.tgz e='grep'>log msg
AgeCommit message (Expand)AuthorFilesLines
2012-04-03nyancat.1: update myanpageJonathan McCrohan1-19/+51
2012-04-01:set spell ... I'm a bloody moron.Kevin Lange1-7/+7
2012-04-01Long options, help text for previousKevin Lange1-0/+4
2012-04-01Add options to not clear display and not set titleKevin Lange1-12/+49
2012-03-26Remove debug output that I completely forgot aboutKevin Lange1-2/+0
2012-03-25Added extra display optionsKevin Lange2-38/+124
2012-03-23(style)Kevin Lange1-3/+9
2012-03-23Add install targetKevin Lange1-1/+4
2012-03-23Command line options with getopt_longKevin Lange1-148/+196
2012-03-22Change package version systemJonathan McCrohan1-1/+1
2012-03-19include ctype.h for tolower()Tay Ray Chuan1-0/+1
2012-03-19provide struct winsize and TIOCGWINSZ on SolarisTay Ray Chuan1-0/+7
2012-03-18Remove more dh_make autogenerated filesJonathan McCrohan4-22/+0
2012-03-08Update myanpageJonathan McCrohan1-19/+4