#!/bin/sh # # Slackware build script for wavemon # # Contributed by Christoph J. Thompson # CWD=`pwd` NAME=wavemon VERSION=0.5 ARCH=i586 BUILD=1 PKGNAME=$NAME PKGVER=$VERSION BASEDIR=$PKGNAME-$PKGVER ARCHIVE=$PKGNAME-current.tar.bz2 REPOSITORY=http://eden-feed.erg.abdn.ac.uk/wavemon FLAGS="-O2 -march=pentium -mtune=pentium -fno-strength-reduce \ -fomit-frame-pointer -ffast-math" PKG=/tmp/package-$NAME rm -rf $PKG mkdir -p $PKG # Obtain sources if [ ! -e $ARCHIVE ]; then if `wget "$REPOSITORY/$ARCHIVE"`; then true else exit 1 fi fi # Compile cd /tmp tar jxvf $CWD/$ARCHIVE cd $BASEDIR CFLAGS="${FLAGS}" CXXFLAGS="${FLAGS}" ./configure \ --prefix=/usr \ --mandir=/usr/man \ --sysconfdir=/etc \ --localstatedir=/var make CFLAGS="${FLAGS}" # Install make install DESTDIR=$PKG mkdir -p $PKG/install $PKG/usr/doc/$NAME-$VERSION cat > $PKG/install/slack-desc < $PKG/install/slack-required <= 5.6-i486-3 EOF install -m644 -g0 -o0 AUTHORS README \ $PKG/usr/doc/$NAME-$VERSION chmod 444 $PKG/usr/man/man?/*.? gzip -9nf $PKG/usr/man/man?/*.? strip \ $PKG/usr/bin/* || : chown -R root.root $PKG # Make package cd $PKG cat install/slack-desc | grep "$NAME:" > /tmp/$NAME-$VERSION-$ARCH-$BUILD.txt makepkg -l y -c n /tmp/$NAME-$VERSION-$ARCH-$BUILD.tgz /debian/dtv-scan-tables.git/stats/isdb-t/br-mg-BordaDaMata?h=debian/0%2bgit20160503.4f192bd-1'>stats
AgeCommit message (Expand)AuthorFilesLines
2014-12-28Imported Upstream version 0+git20141218.b46a22cupstream/0+git20141218.b46a22cJonathan McCrohan535-639/+317
2014-10-20Release 0+git20141009.d26b627-1debian/0+git20141009.d26b627-1Jonathan McCrohan1-2/+2
2014-10-20Fix up packaging to account for move to DVBv5Jonathan McCrohan2-2/+6
2014-10-20delete d/dtv-scan-files.install; Upstream now supplies a MakefileJonathan McCrohan2-4/+1
2014-10-15d/control: update Standards Version to 3.9.6Jonathan McCrohan2-1/+3
2014-10-15d/control: add Build-Depends on dvb-toolsJonathan McCrohan2-1/+2
2014-10-15New Upstream Snapshot (commit d26b627)Jonathan McCrohan1-0/+10
2014-10-15Imported Upstream version 0+git20141009.d26b627upstream/0+git20141009.d26b627Jonathan McCrohan2010-11120/+159271
2014-07-23Release 0+git20140611.14bd6c7-1debian/0+git20140611.14bd6c7-1Jonathan McCrohan1-2/+2
2014-07-23New Upstream Snapshot (commit 14bd6c7)Jonathan McCrohan1-2/+3
2014-07-23Imported Upstream version 0+git20140611.14bd6c7upstream/0+git20140611.14bd6c7Jonathan McCrohan7-11/+60
2014-05-13New Upstream Snapshot (commit 1246b27)Jonathan McCrohan1-0/+6
2014-05-13Imported Upstream version 0+git20140512.1246b27upstream/0+git20140512.1246b27Jonathan McCrohan391-301/+3983
2014-04-05Release 0+git20140326.cfc2975-1debian/0+git20140326.cfc2975-1Jonathan McCrohan1-2/+2
2014-04-05d/control: update Homepage (upstream has moved from Gitweb to cgit)Jonathan McCrohan2-1/+2
2014-04-05New Upstream Snapshot (commit cfc2975)Jonathan McCrohan1-0/+6
2014-04-05Imported Upstream version 0+git20140326.cfc2975upstream/0+git20140326.cfc2975Jonathan McCrohan118-656/+877
2014-01-16Release 0+git20140107.1850cf8-1debian/0+git20140107.1850cf8-1Jonathan McCrohan1-2/+2
2014-01-16Update Standards Version to 3.9.5Jonathan McCrohan2-1/+9