aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.in b/Makefile.in
index 7a0ed30..f83daf8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -36,10 +36,10 @@ config.status: configure
configure: configure.ac
autoconf
-tags: $(wildcard *[ch])
+tags: $(MAIN) $(PURESRC) $(HEADERS)
ctags $^ > $@
-.PHONY: install uninstall clean distclean
+.PHONY: all install uninstall clean distclean
install: install-binaries install-docs
@@ -49,20 +49,20 @@ install-suid-root install-binaries: all
install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 0644 wavemon.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
- $(INSTALL) -m 0644 wavemonrc.5 $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
$(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
$(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
uninstall:
- @$(RM) $(bindir)/wavemon
- @$(RM) $(mandir)/man1/wavemon.1
- @$(RM) $(mandir)/man5/wavemonrc.5
+ @$(RM) $(bindir)/@PACKAGE_NAME@
+ @$(RM) $(mandir)/man1/@PACKAGE_NAME@.1
+ @$(RM) $(mandir)/man5/@PACKAGE_NAME@rc.5
@$(RM) -r $(datadir)
clean:
- @$(RM) *.o *.doc wavemon tags
+ @$(RM) *.o *~ tags @PACKAGE_NAME@
distclean: uninstall clean
@$(RM) config.status config.log config.cache Makefile