aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/02-reproducible-build.patch14
-rw-r--r--debian/patches/series1
3 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 19cff9c..aa9ecd5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
wavemon (0.8.1-2) UNRELEASED; urgency=medium
* d/control: update homepage to reflect move to github (Closes: #794535)
+ * d/patches: add patch from Reiner Herrmann <reiner@reiner-h.de> which adds
+ support for reproducible builds (Closes: #825544)
-- Jonathan McCrohan <jmccrohan@gmail.com> Wed, 04 Jan 2017 00:24:11 +0000
diff --git a/debian/patches/02-reproducible-build.patch b/debian/patches/02-reproducible-build.patch
new file mode 100644
index 0000000..f583e36
--- /dev/null
+++ b/debian/patches/02-reproducible-build.patch
@@ -0,0 +1,14 @@
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Sort object files for deterministic linking order
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -21,7 +21,7 @@
+ MAIN = @PACKAGE_NAME@.c
+ HEADERS = $(wildcard *.h)
+ PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
+-OBJS = $(PURESRC:.c=.o)
++OBJS = $(sort $(PURESRC:.c=.o))
+
+ %.o: %.c $(HEADERS)
+ @echo ' CC ' $<
diff --git a/debian/patches/series b/debian/patches/series
index 18ef635..d9aa474 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
01-patch-makefile.in-to-not-install-docs.patch
+02-reproducible-build.patch