aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2009-12-11 22:10:25 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:03:25 +0000
commitc93ad1a4ef2625ffb849b8868fe32f930594ac70 (patch)
tree944a0695cd44729cb14741ffa71b94d902e43d56 /Makefile.in
parent03dfbc2efa31d3c4fd7e576111883ea488e3e179 (diff)
downloadwavemon-c93ad1a4ef2625ffb849b8868fe32f930594ac70.tar.gz
Imported Debian patch 0.6.10-1debian/0.6.10-1
Diffstat (limited to '')
-rw-r--r--Makefile.in25
1 files changed, 10 insertions, 15 deletions
diff --git a/Makefile.in b/Makefile.in
index 7c81ad5..3bbc253 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -34,34 +34,29 @@ config.status: configure
configure: configure.ac
autoconf
-tags: $(MAIN) $(PURESRC) $(HEADERS)
+tags: $(wildcard *[ch])
ctags $^ > $@
-.PHONY: all install uninstall clean distclean
+.PHONY: install uninstall clean distclean
-install: install-binaries install-docs
-
-install-binaries: all
+install: wavemon wavemon.1 wavemonrc.5 $(DOCS)
$(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 0755 @PACKAGE_NAME@ $(DESTDIR)$(bindir)
-
-install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
+ $(INSTALL) -m 0755 wavemon $(DESTDIR)$(bindir)
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 wavemon.1 $(DESTDIR)$(mandir)/man1
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
- $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 wavemonrc.5 $(DESTDIR)$(mandir)/man5
$(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
$(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
uninstall:
- @$(RM) $(bindir)/@PACKAGE_NAME@
- @$(RM) $(mandir)/man1/@PACKAGE_NAME@.1
- @$(RM) $(mandir)/man5/@PACKAGE_NAME@rc.5
+ @$(RM) $(bindir)/wavemon
+ @$(RM) $(mandir)/man1/wavemon.1
+ @$(RM) $(mandir)/man5/wavemonrc.5
@$(RM) -r $(datadir)
clean:
- @$(RM) *.o *~ tags @PACKAGE_NAME@
+ @$(RM) *.o *.doc wavemon tags
distclean: uninstall clean
@$(RM) config.status config.log config.cache Makefile
- @$(RM) -r autom4te.cache