aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 0000000..1701c11
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,15 @@
+OBJECTS = nyancat.o
+
+all: nyancat
+
+nyancat: $(OBJECTS)
+ $(CC) $(LFLAGS) $(OBJECTS) -o $@
+
+clean:
+ -rm -f $(OBJECTS) nyancat
+
+check: all
+ # Unit tests go here. None currently.
+ @echo "*** ALL TESTS PASSED ***"
+
+.PHONY: all clean check