aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile
diff options
context:
space:
mode:
authorKevin Lange <kevin.lange@phpwnage.com>2011-11-30 22:12:44 -0800
committerKevin Lange <kevin.lange@phpwnage.com>2011-11-30 22:12:44 -0800
commit584fb40b7d158fb863dfbb77442486114956894b (patch)
treee6ecef21e6d002d7e8e8ef7d67e82f8a6c66e60d /src/Makefile
parentcb850e9ab9b70f183ef9afbda9952110b3922204 (diff)
parent900194edee61b6dded593e04b435e9b7c9ca0517 (diff)
downloadnyancat-584fb40b7d158fb863dfbb77442486114956894b.tar.gz
Merge pull request #2 from apeschel/autotools
[apeschel] Made project more in line with Autotools standard.
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 0000000..1701c11
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,15 @@
+OBJECTS = nyancat.o
+
+all: nyancat
+
+nyancat: $(OBJECTS)
+ $(CC) $(LFLAGS) $(OBJECTS) -o $@
+
+clean:
+ -rm -f $(OBJECTS) nyancat
+
+check: all
+ # Unit tests go here. None currently.
+ @echo "*** ALL TESTS PASSED ***"
+
+.PHONY: all clean check