aboutsummaryrefslogtreecommitdiffstats
path: root/util/lib
diff options
context:
space:
mode:
Diffstat (limited to 'util/lib')
-rw-r--r--util/lib/Makefile20
-rw-r--r--util/lib/lnb.c101
-rw-r--r--util/lib/lnb.h24
3 files changed, 0 insertions, 145 deletions
diff --git a/util/lib/Makefile b/util/lib/Makefile
deleted file mode 100644
index 5f55636..0000000
--- a/util/lib/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-
-CC = gcc
-CFLAGS = -MD -g -Wall -O2 -I../../include -I.
-LFLAGS = -g -Wall
-
-OBJS = lnb.o
-SRCS = $(OBJS:.o=.c)
-
-TARGET = lnb.o
-
-$(TARGET): $(SRCS)
-
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
-
-clean:
- $(RM) *.o *.d $(TARGET)
-
--include $(wildcard *.d) dummy
-
diff --git a/util/lib/lnb.c b/util/lib/lnb.c
deleted file mode 100644
index d082181..0000000
--- a/util/lib/lnb.c
+++ /dev/null
@@ -1,101 +0,0 @@
-#include <stdlib.h>
-#include <string.h>
-#include <ctype.h>
-#include "lnb.h"
-
-static char *univ_desc[] = {
- "Europe",
- "10800 to 11800 MHz and 11600 to 12700 Mhz",
- "Dual LO, loband 9750, hiband 10600 MHz",
- (char *)NULL };
-
-static char *dbs_desc[] = {
- "Expressvu, North America",
- "12200 to 12700 MHz",
- "Single LO, 11250 MHz",
- (char *)NULL };
-
-static char *standard_desc[] = {
- "10945 to 11450 Mhz",
- "Single LO, 10000 Mhz",
- (char *)NULL };
-
-static char *enhan_desc[] = {
- "Astra",
- "10700 to 11700 MHz",
- "Single LO, 9750 MHz",
- (char *)NULL };
-
-static char *cband_desc[] = {
- "Big Dish",
- "3700 to 4200 MHz",
- "Single LO, 5150 Mhz",
- (char *)NULL };
-
-static struct lnb_types_st lnbs[] = {
- {"UNIVERSAL", univ_desc, 9750, 10600, 11700 },
- {"DBS", dbs_desc, 11250, 0, 0 },
- {"STANDARD", standard_desc, 10000, 0, 0 },
- {"ENHANCED", enhan_desc, 9750, 0, 0 },
- {"C-BAND", cband_desc, 5150, 0, 0 }
-};
-
-/* Enumerate through standard types of LNB's until NULL returned.
- * Increment curno each time
- */
-
-struct lnb_types_st *
-lnb_enum(int curno)
-{
- if (curno >= sizeof(lnbs) / sizeof(lnbs[0]))
- return (struct lnb_types_st *)NULL;
- return &lnbs[curno];
-}
-
-/* Decode an lnb type, for example given on a command line
- * If alpha and standard type, e.g. "Universal" then match that
- * otherwise low[,high[,switch]]
- */
-
-int
-lnb_decode(char *str, struct lnb_types_st *lnbp)
-{
-int i;
-char *cp, *np;
-
- memset(lnbp, 0, sizeof(*lnbp));
- cp = str;
- while(*cp && isspace(*cp))
- cp++;
- if (isalpha(*cp)) {
- for(i = 0; i < (sizeof(lnbs) / sizeof(lnbs[0])); i++) {
- if (!strcasecmp(lnbs[i].name, cp)) {
- *lnbp = lnbs[i];
- return 1;
- }
- }
- return -1;
- }
- if (*cp == '\0' || !isdigit(*cp))
- return -1;
- lnbp->low_val = strtoul(cp, &np, 0);
- if (lnbp->low_val == 0)
- return -1;
- cp = np;
- while(*cp && (isspace(*cp) || *cp == ','))
- cp++;
- if (*cp == '\0')
- return 1;
- if (!isdigit(*cp))
- return -1;
- lnbp->high_val = strtoul(cp, &np, 0);
- cp = np;
- while(*cp && (isspace(*cp) || *cp == ','))
- cp++;
- if (*cp == '\0')
- return 1;
- if (!isdigit(*cp))
- return -1;
- lnbp->switch_val = strtoul(cp, NULL, 0);
- return 1;
-}
diff --git a/util/lib/lnb.h b/util/lib/lnb.h
deleted file mode 100644
index f78b7a6..0000000
--- a/util/lib/lnb.h
+++ /dev/null
@@ -1,24 +0,0 @@
-
-struct lnb_types_st {
- char *name;
- char **desc;
- unsigned long low_val;
- unsigned long high_val; /* zero indicates no hiband */
- unsigned long switch_val; /* zero indicates no hiband */
-};
-
-/* Enumerate through standard types of LNB's until NULL returned.
- * Increment curno each time
- */
-
-struct lnb_types_st *
-lnb_enum(int curno);
-
-/* Decode an lnb type, for example given on a command line
- * If alpha and standard type, e.g. "Universal" then match that
- * otherwise low[,high[,switch]]
- */
-
-int
-lnb_decode(char *str, struct lnb_types_st *lnbp);
-
reinelt3-176/+138 further matrixOrbital changes widgets initialized git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@301 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-10[lcd4linux @ 2004-01-10 10:20:22 by reinelt]reinelt2-14/+605 new MatrixOrbital changes git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@300 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-09[lcd4linux @ 2004-01-09 17:03:06 by reinelt]reinelt10-51/+420 initiated transfer to new driver architecture new file 'drv.c' will someday replace 'display.c' new file 'drv_MatrixOrbital.c' will replace 'MatrixOrbital.c' due to this 'soft' transfer lcd4linux should stay usable during the switch (at least I hope so) git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@299 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-09[lcd4linux @ 2004-01-09 04:16:06 by reinelt]reinelt28-193/+332 added 'section' argument to cfg_get(), but NULLed it on all calls by now. git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@298 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-08[lcd4linux @ 2004-01-08 06:00:28 by reinelt]reinelt1-8/+14 allowed '.' in key names allowed empty group keys (not only "group anything {", but "anything {") git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@297 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-08[lcd4linux @ 2004-01-08 05:28:12 by reinelt]reinelt3-42/+198 Luk Claes added to AUTHORS cfg: group handling ('{}') added git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@296 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-07[lcd4linux @ 2004-01-07 10:15:41 by reinelt]reinelt4-184/+436 small glitch in evaluator fixed made config table sorted and access with bsearch(), which should be much faster git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@295 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 23:01:37 by reinelt]reinelt3-4/+7 more copyright issues git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@294 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 22:33:13 by reinelt]reinelt14-472/+542 Copyright statements cleaned up git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@293 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 21:14:51 by reinelt]reinelt4-14/+7 more debianizing git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@292 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 18:22:41 by reinelt]reinelt1-3/+13 debian updates git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@291 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 17:56:43 by reinelt]reinelt3-1000/+2045 autotools update git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@290 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 17:37:00 by reinelt]reinelt1-0/+20 git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@289 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 17:33:45 by reinelt]reinelt6-28/+298 Evaluator: functions with variable argument lists Evaluator: plugin_sample.c and README.Plugins added git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@288 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-06[lcd4linux @ 2004-01-06 15:19:12 by reinelt]reinelt2-104/+136 Evaluator rearrangements... git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@287 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-05[lcd4linux @ 2004-01-05 11:57:38 by reinelt]reinelt7-8/+168 added %y tokens to make the Evaluator useable git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@286 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-02[lcd4linux @ 2004-01-02 14:20:15 by reinelt]reinelt10-0/+201 debianization added git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@285 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2004-01-02[lcd4linux @ 2004-01-02 14:18:54 by reinelt]reinelt2-0/+101 Changelog, TODO updated git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@284 3ae390bd-cb1e-0410-b409-cd5a39f66f1f 2003-12-19[lcd4linux @ 2003-12-19 06:27:33 by reinelt]reinelt4-8/+119 added XMMS plugin from Markus Keil git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@283 3ae390bd-cb1e-0410-b409-cd5a39f66f1f