aboutsummaryrefslogtreecommitdiffstats
path: root/util/lib
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test/lnb.c (renamed from util/lib/lnb.c)6
-rw-r--r--test/lnb.h (renamed from util/lib/lnb.h)2
-rw-r--r--util/lib/Makefile20
3 files changed, 3 insertions, 25 deletions
diff --git a/util/lib/lnb.c b/test/lnb.c
index d082181..9052d1c 100644
--- a/util/lib/lnb.c
+++ b/test/lnb.c
@@ -12,7 +12,7 @@ static char *univ_desc[] = {
static char *dbs_desc[] = {
"Expressvu, North America",
"12200 to 12700 MHz",
- "Single LO, 11250 MHz",
+ "Single LO, 11250 MHz",
(char *)NULL };
static char *standard_desc[] = {
@@ -47,7 +47,7 @@ static struct lnb_types_st lnbs[] = {
struct lnb_types_st *
lnb_enum(int curno)
{
- if (curno >= sizeof(lnbs) / sizeof(lnbs[0]))
+ if (curno >= (int) (sizeof(lnbs) / sizeof(lnbs[0])))
return (struct lnb_types_st *)NULL;
return &lnbs[curno];
}
@@ -68,7 +68,7 @@ char *cp, *np;
while(*cp && isspace(*cp))
cp++;
if (isalpha(*cp)) {
- for(i = 0; i < (sizeof(lnbs) / sizeof(lnbs[0])); i++) {
+ for (i = 0; i < (int)(sizeof(lnbs) / sizeof(lnbs[0])); i++) {
if (!strcasecmp(lnbs[i].name, cp)) {
*lnbp = lnbs[i];
return 1;
diff --git a/util/lib/lnb.h b/test/lnb.h
index f78b7a6..6370fd4 100644
--- a/util/lib/lnb.h
+++ b/test/lnb.h
@@ -1,4 +1,3 @@
-
struct lnb_types_st {
char *name;
char **desc;
@@ -21,4 +20,3 @@ lnb_enum(int curno);
int
lnb_decode(char *str, struct lnb_types_st *lnbp);
-
diff --git a/util/lib/Makefile b/util/lib/Makefile
deleted file mode 100644
index 5f55636..0000000
--- a/util/lib/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-
-CC = gcc
-CFLAGS = -MD -g -Wall -O2 -I../../include -I.
-LFLAGS = -g -Wall
-
-OBJS = lnb.o
-SRCS = $(OBJS:.o=.c)
-
-TARGET = lnb.o
-
-$(TARGET): $(SRCS)
-
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
-
-clean:
- $(RM) *.o *.d $(TARGET)
-
--include $(wildcard *.d) dummy
-