summaryrefslogtreecommitdiffstats
path: root/util/alevt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/alevt/Makefile')
-rw-r--r--util/alevt/Makefile130
1 files changed, 130 insertions, 0 deletions
diff --git a/util/alevt/Makefile b/util/alevt/Makefile
new file mode 100644
index 0000000..2f7c8da
--- /dev/null
+++ b/util/alevt/Makefile
@@ -0,0 +1,130 @@
+VER=1.7.0
+OPT=-O -g -w
+DEFS=-DWITH_PNG
+DEFS+=-DUSE_LIBZVBI
+FONT=vtxt
+MAN_DIR=man
+DESTDIR=
+PREFIX=/usr
+HOSTCC=$(CC)
+CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
+EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
+OBJS=main.o ui.o xio.o fdset.o vbi.o cache.o help.o search.o misc.o hamm.o lang.o $(EXPOBJS)
+TOBJS=alevt-date.o vbi.o fdset.o misc.o hamm.o lang.o
+COBJS=alevt-cap.o vbi.o fdset.o misc.o hamm.o lang.o $(EXPOBJS)
+
+ifneq ($(findstring WITH_PNG,$(DEFS)),)
+EXPLIBS=-lpng -lz -lm
+endif
+
+ifneq ($(findstring USE_LIBZVBI,$(DEFS)),)
+ZVBILIB=-lzvbi -lpthread
+EXPLIBS+=$(ZVBILIB)
+endif
+
+all: alevt alevt-date alevt-cap alevt.1 alevt-date.1 alevt-cap.1
+
+alevt: $(OBJS)
+ $(CC) $(OPT) $(OBJS) -o alevt -L$(PREFIX)/lib -L$(PREFIX)/lib64 -lX11 $(EXPLIBS)
+
+alevt-date: $(TOBJS)
+ $(CC) $(OPT) $(TOBJS) -o alevt-date $(ZVBILIB)
+
+alevt-cap: $(COBJS)
+ $(CC) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
+
+font.o: font1.xbm font2.xbm font3.xbm font4.xbm
+fontsize.h: font1.xbm font2.xbm font3.xbm font4.xbm
+ fgrep -h "#define" font1.xbm font2.xbm font3.xbm font4.xbm >fontsize.h
+
+font1.xbm: bdf2xbm $(FONT)-latin-1.bdf
+ ./bdf2xbm font1 <$(FONT)-latin-1.bdf >font1.xbm
+
+font2.xbm: bdf2xbm $(FONT)-latin-2.bdf
+ ./bdf2xbm font2 <$(FONT)-latin-2.bdf >font2.xbm
+
+font3.xbm: bdf2xbm vtxt-koi8.bdf
+ ./bdf2xbm font3 <vtxt-koi8.bdf >font3.xbm
+
+font4.xbm: bdf2xbm vtxt-iso8859-7.bdf
+ ./bdf2xbm font4 <vtxt-iso8859-7.bdf >font4.xbm
+
+bdf2xbm: bdf2xbm.c
+ $(HOSTCC) bdf2xbm.c -o bdf2xbm
+
+clean:
+ rm -f *.o page*.txt a.out core bdf2xbm font?.xbm fontsize.h
+ rm -f alevt alevt-date alevt-cap
+
+rpm-install: all
+ install -m 0755 alevt ${RPM_BUILD_ROOT}$(USR_X11R6)/bin
+ install -m 0755 alevt-date ${RPM_BUILD_ROOT}$(USR_X11R6)/bin
+ install -m 0755 alevt-cap ${RPM_BUILD_ROOT}$(USR_X11R6)/bin
+ install -m 0644 alevt.1 ${RPM_BUILD_ROOT}$(USR_X11R6)/$(MAN)/man1
+ install -m 0644 alevt-date.1 ${RPM_BUILD_ROOT}$(USR_X11R6)/$(MAN)/man1
+ install -m 0644 alevt-cap.1 ${RPM_BUILD_ROOT}$(USR_X11R6)/$(MAN)/man1
+ install -d 0755 $(RPM_BUILD_ROOT)$(USR_X11R6)/include/X11/pixmaps
+ install -m 0644 alevt.png $(RPM_BUILD_ROOT)$(USR_X11R6)/include/X11/pixmaps
+
+install: all
+ install -m 0755 alevt $(DESTDIR)$(PREFIX)/bin
+ install -m 0755 alevt-date $(DESTDIR)$(PREFIX)/bin
+ install -m 0755 alevt-cap $(DESTDIR)$(PREFIX)/bin
+ install -m 0644 alevt.1 $(DESTDIR)$(PREFIX)/share/man/man1
+ install -m 0644 alevt-date.1 $(DESTDIR)$(PREFIX)/share/man/man1
+ install -m 0644 alevt-cap.1 $(DESTDIR)$(PREFIX)/share/man/man1
+ install -m 0644 alevt.png $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 0644 alevt.desktop $(DESTDIR)$(PREFIX)/share/applications
+
+uninstall: clean
+ rm -f /usr/bin/alevt /usr/bin/alevt-cap /usr/bin/alevt-date \
+ /usr/share/pixmaps/alevt.png /usr/share/applications/alevt.desktop \
+ /usr/share/man/man1/alevt.1 /usr/share/man/man1/alevt-cap.1 \
+ /usr/share/man/man1/alevt-date.1
+
+depend:
+ makedepend -Y -- $(CFLAGS_none) -- *.c 2>/dev/null
+
+tar-html: alevt.1 alevt-date.1 alevt-cap.1
+ for i in alevt.1 alevt-date.1 alevt-cap.1 ; do \
+ j=`basename $$i .1` ; \
+ j=`basename $$j .1x` ; \
+ nroff -man $$i | { \
+ echo "<HTML><HEAD><TITLE>AleVT</TITLE></HEAD><BODY>" ; \
+ man2html -bare -uelem U -nodepage ; \
+ echo "</B0DY></HTML>" ; \
+ } | sed -e "s,</B> <B>, ,g" -e "s,</U> <U>, ,g" >~/exit/alevt/$$j.html ;\
+ done
+
+tar: tar-html clean
+ sed s/VERSION/$(VER)/g <alevt.lsm.in >~/exit/alevt/alevt-$(VER).lsm
+ sed s/VERSION/$(VER)/g <alevt.spec.in >alevt.spec
+ cd .. ;\
+ ln -s alevt alevt-$(VER) ;\
+ tar vcfz ~/exit/alevt/alevt-$(VER).tar.gz alevt-$(VER)/* ;\
+ rm alevt-$(VER)
+ cat <CHANGELOG >~/exit/alevt/changes
+
+# DO NOT DELETE
+
+alevt-cap.o: vt.h misc.h fdset.h dllist.h vbi.h cache.h lang.h export.h
+alevt-date.o: os.h vt.h misc.h fdset.h dllist.h vbi.h cache.h lang.h
+cache.o: misc.h dllist.h cache.h vt.h help.h
+exp-gfx.o: lang.h misc.h vt.h export.h font.h fontsize.h
+exp-html.o: lang.h misc.h vt.h export.h
+exp-txt.o: os.h export.h vt.h misc.h
+export.o: vt.h misc.h export.h
+fdset.o: dllist.h misc.h fdset.h
+font.o: font1.xbm font2.xbm font3.xbm font4.xbm
+hamm.o: vt.h misc.h hamm.h
+help.o: vt.h misc.h vt900.out vt901.out vt902.out vt903.out vt904.out vt905.out
+help.o: vt906.out vt907.out vt908.out vt909.out vt910.out vt911.out vt912.out
+lang.o: misc.h vt.h lang.h
+main.o: vt.h misc.h fdset.h dllist.h xio.h vbi.h cache.h lang.h ui.h
+main.o: search.h
+misc.o: misc.h
+search.o: vt.h misc.h cache.h dllist.h search.h
+ui.o: vt.h misc.h xio.h dllist.h vbi.h cache.h lang.h fdset.h
+ui.o: search.h export.h ui.h
+vbi.o: os.h vt.h misc.h vbi.h dllist.h cache.h lang.h fdset.h hamm.h
+xio.o: vt.h misc.h dllist.h xio.h fdset.h lang.h icon.xbm font.h fontsize.h
1-03-16 -lt. // 2000-04-04 Michael Reinelt <reinelt@eunet.at> // write a driver for PNG. This should be the first step towards a WWW-driver. // Done 2001-03-01 -lt. 2000-04-15 Thomas Skyt Jessen <thskyt@foni.net> show partition information (used, free, ...) 2000-04-25 Michael Mueller <m.mueller@netsystec.de> show process information // 2000-12-03 Ghassan Matar <gmatar@hexapods.com> // show other sensors than temperature // we have to use libsensors instead of parsing the proc files directly // Refused 2003-08-01 -mr // 2000-12-03 Ghassan Matar <gmatar@hexapods.com> // show contents of any text file // the file should only contain one line, with a fixed format // there are two possibilities: text and numbers // numbers can be used for bars, too // Done 2000-03-08, look at %x -lt // 2000-12-03 Ghassan Matar <gmatar@hexapods.com> // accept data from external sources (fifo?) // Done 2000-03-08, look at %x -lt // 2001-02-11 Carsten Nau <info@cnau.de> // connect a LED to a spare pin of the parallel port and show if ISDN // is online // Done with GPO's -mr // 2001-01-27 Axel Ehnert <axel@ehnert.net> // - display numer of emails in a mailbox // - display seti@home values // done. // 2001-03-05 Leo T�tsch <lt@toetsch.at> // rename some tokens: %o->%os, %v->%ov, %r->%or, %p->%op, // will be done with the big config-rework // done with the "Next Generation Layout" // 2001-03-05 Leo T�tsch <lt@toetsch.at> // replace T_EXTENDED with a Flag similar to 'bar' // rejected, T_EXTENDED does a good job -mr // 2001-03-07 Michael Reinelt <reinelt@eunet.at> // use ppdev instead of ugly outb() // done 2001-03-14 -mr // 2001-03-09 Michael Reinelt <reinelt@eunet.at> // replace udelay() assembly loop with rdtsc (read time stamp counter) // at least try to.... // done 2001-03-14 -mr // 2001-03-09 Leo T�tsch <lt@toetsch.at> // read configuration file earlier (before forking) so that specific drivers // (especially 'Text') would not fork. // There's a reason for forking that early, but I forgot... // done somewhere in mid 2003 MR // 2001-03-12 Michael Reinelt <reinelt@eunet.at> // remove USE_OLD_UDELAY after wide testing of new udelay code // done with the "Next Generation Layout" // 2001-03-12 Michael Reinelt <reinelt@eunet.at> // create a NEWS file with changes/enhancements of every release // done 2001-03-13 -mr 2001-03-14 Leopold Toetsch <lt@toetsch.at> improve unseen for mbox (check Status:) // 2001-03-14 Michael Reinelt <reinelt@eunet.at> // add a new Token 'nc' for 'network collisions' // done with the "Next Generation Layout" 2001-03-14 Michael Reinelt <reinelt@eunet.at> add translation tables ('german umlauts' don't follow any scheme on most displays) // 2001-03-15 Leopold Toetsch <lt@toetsch.at> // Text display has troubles with '\r' // done 2001-03-16, replace \r,\n with '_' -lt // 2001-03-24 Carsten Nau <info@cnau.de> // change network clients to support different devices // at the moment the sum of all eth* devices is calculated // %n* should be extended tokens // done with the "Next Generation Layout" // 2001-03-24 Brian Cleven <lcleven@home.com> // support 40x4 displays with two HD44780 chips on it // we need another 'Enable' line for this // this way one could connect two displays to one parallel port, too // done with 0.9.11 MR // 2001-05-25 Jens Garthe <outline@xslan.de> // detect wether curses.h and libncurses is installed, and // don't include the 'Text'-driver if not. // _should_ work now 2001-05-31 -lt // 2001-09-11 Michael Reinelt <reinelt@eunet.at> // use new extended tokens to split up several data sources // (CPU, Net, Disk, ISDN, ...) // e.g. '%nw' is 'network transmit' for _all_ devices // '%n0w' is 'network transmit' for eth0 // '%n1w' for eth1 // done with the "Next Generation Layout" // 2001-09-11 Michael Reinelt <reinelt@eunet.at> // remove bar code from drivers and create a common bar library // done somewhere in 2003 -mr // 2001-09-12 Carsten Nau <info@cnau.de> // make the output for emails shorter (at the moment up to 9999 emails) // done with the "Next Generation Layout" 2001-09-13 Michael Reinelt <reinelt@eunet.at> combine mail.c and mail2.c if there's an error getting mail info, display "?" instead of "0" 2001-09-14 Michael Reinelt <reinelt@eunet.at> do not disable mail check in first error instead use a number of retries errors can occur in case of short disconnects, but normal operation should resume 2002-02-15 Udo Altmann (udo.altmann@web.de) support for inversed/blinking text don't know if displays support this feature... // 2003-09-08 Michael Reinelt (reinelt@eunet.at> // at least one of my HD44780 displays use an inverted "P" instead of // a full block. Therefore a bar my look strange. Make the ASCII code // of the full block configurable... // done with the "Next Generation Layout" // see the "asc255bug" attribute // 2003-09-14 Markus <markus@norad.de> // change %t tokens from Byte/sec to kB/sec, ith one decimal places. // Either make it configurabel, or add new tokens. // done with the "Next Generation Layout" // 2003-10-29 Matt Thrailkill <xwred1@modestolan.com> // > To go off on another tangent... have you at all considered some sort of // > marquee support? I toyed with the row scrolling support which was // > recently added, and it is nifty. But marquees would be handy for doing // > something like horizontally scrolling, say, the title of the currently // > playing mp3. I've toyed with trying to dive in and add it, but I'm a // > pretty lazy guy and haven't done it. What do you think? // done with the "Next Generation Layout" 2003-12-31 Stefan ??? <nef17@gmx.net> add support for software-controlled backlight for HD44780 http://www.jalcds.de/images/4x20backlight.gif 2004-01-25 Michael Reinelt <reinelt@eunet.at> add attribute "blinking" to text widgets 2004-01-25 Xavier VELLO <xavier66@free.fr> add "inverse" attribute to text widget possible with Cwlinux and all graphics displays 2004-01-25 Xavier VELLO <xavier66@free.fr> add an "image" widget 2004-01-25 Xavier VELLO <xavier66@free.fr> icons should not only be updated regularly, but shown only when a certain expression returns 1