summaryrefslogtreecommitdiffstats
path: root/lib/libesg/encapsulation/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libesg/encapsulation/Makefile')
-rw-r--r--lib/libesg/encapsulation/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/libesg/encapsulation/Makefile b/lib/libesg/encapsulation/Makefile
new file mode 100644
index 0000000..2f222ed
--- /dev/null
+++ b/lib/libesg/encapsulation/Makefile
@@ -0,0 +1,28 @@
+# Makefile for linuxtv.org dvb-apps/lib/libesg/encapsulation
+
+.PHONY: sub-error-encapsulation
+
+sub-error-encapsulation:
+ $(error You can't use this makefile directly.)
+
+ifneq ($(lib_name),)
+
+objects += encapsulation/container.o \
+ encapsulation/fragment_management_information.o \
+ encapsulation/data_repository.o \
+ encapsulation/string_repository.o
+
+sub-install += encapsulation
+
+else
+
+includes = container.h \
+ fragment_management_information.h \
+ data_repository.h \
+ string_repository.h
+
+include ../../../Make.rules
+
+lib_name = libesg/encapsulation
+
+endif
>Jonathan McCrohan1-2/+5 2012-02-11Remove forced install of examples in rules.Jonathan McCrohan1-2/+2 2012-02-11Fix Examples.Jonathan McCrohan6-34/+17 2012-02-11Remove makefile.Jonathan McCrohan1-7/+0 2012-02-11Move *.docs, *.install and *.examples to -dev.Jonathan McCrohan7-2/+2 2012-02-11Move to single -dev package.Jonathan McCrohan2-14/+12 2012-02-08Update package changelog.Jonathan McCrohan1-1/+1 2012-02-08Partial manual revert of move to libconfig*8.Jonathan McCrohan4-12/+12 2012-02-08Add my name to debian copyright.Jonathan McCrohan1-2/+3 2012-02-08Atomic commit. Rollback to libconfig8 packaging names.Jonathan McCrohan10-8/+8 2012-02-07Rename libconfig9 to libconfig8 to aid release teamJonathan McCrohan1-14/+14 2012-02-07Fix "closes typo"Jonathan McCrohan1-1/+1 2012-02-07Revert "Add symbols"Jonathan McCrohan3-739/+1 2012-02-07Revert "Fix b0rked symbol file."Jonathan McCrohan1-1/+1 2012-02-07Revert "Second attempt"Jonathan McCrohan2-0/+194 2012-01-29Second attemptJonathan McCrohan2-194/+0 2012-01-29Fix b0rked symbol file.Jonathan McCrohan1-1/+1 2012-01-29Add symbolsJonathan McCrohan3-1/+739 2012-01-26add examples properlyJonathan McCrohan1-0/+2 2012-01-26Update changelogJonathan McCrohan1-3/+6 2012-01-26fix typoJonathan McCrohan1-1/+1 2012-01-26fix accidental description changesJonathan McCrohan1-2/+2 2012-01-26more fucking around to please lintianJonathan McCrohan1-5/+2 2012-01-25Linitan fixesJonathan McCrohan2-3/+2 2012-01-25Split out debug packagesJonathan McCrohan2-1/+6 2011-12-31Fix debian/rulesJonathan McCrohan1-1/+1 2011-12-31Remove shlibsJonathan McCrohan1-2/+0 2011-12-31Remove NMU from changelogJonathan McCrohan1-1/+0 2011-12-31Lintian FixesJonathan McCrohan1-2/+4 2011-12-31Remove Makefile patchJonathan McCrohan1-1/+0 2011-12-31Update MakefilesJonathan McCrohan10-248/+8222 2011-12-31Updated makefilesJonathan McCrohan1-0/+1