summaryrefslogtreecommitdiffstats
path: root/lib/libdvben50221/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libdvben50221/Makefile')
-rw-r--r--lib/libdvben50221/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lib/libdvben50221/Makefile b/lib/libdvben50221/Makefile
new file mode 100644
index 0000000..797ea2a
--- /dev/null
+++ b/lib/libdvben50221/Makefile
@@ -0,0 +1,49 @@
+# Makefile for linuxtv.org dvb-apps/lib/libdvben50221
+
+includes = asn_1.h \
+ en50221_app_ai.h \
+ en50221_app_auth.h \
+ en50221_app_ca.h \
+ en50221_app_datetime.h \
+ en50221_app_dvb.h \
+ en50221_app_epg.h \
+ en50221_app_lowspeed.h \
+ en50221_app_mmi.h \
+ en50221_app_rm.h \
+ en50221_app_smartcard.h \
+ en50221_app_tags.h \
+ en50221_app_teletext.h \
+ en50221_app_utils.h \
+ en50221_errno.h \
+ en50221_session.h \
+ en50221_stdcam.h \
+ en50221_transport.h
+
+objects = asn_1.o \
+ en50221_app_ai.o \
+ en50221_app_auth.o \
+ en50221_app_ca.o \
+ en50221_app_datetime.o \
+ en50221_app_dvb.o \
+ en50221_app_epg.o \
+ en50221_app_lowspeed.o \
+ en50221_app_mmi.o \
+ en50221_app_rm.o \
+ en50221_app_smartcard.o \
+ en50221_app_teletext.o \
+ en50221_app_utils.o \
+ en50221_session.o \
+ en50221_stdcam.o \
+ en50221_stdcam_hlci.o \
+ en50221_stdcam_llci.o \
+ en50221_transport.o
+
+lib_name = libdvben50221
+
+CPPFLAGS += -I../../lib -DLOG_LEVEL=1 # FIXME
+
+.PHONY: all
+
+all: library
+
+include ../../Make.rules
an>/+2 2012-02-11Fix Examples.Jonathan McCrohan6-34/+17 2012-02-11Remove makefile.Jonathan McCrohan1-7/+0 2012-02-11Move *.docs, *.install and *.examples to -dev.Jonathan McCrohan7-2/+2 2012-02-11Move to single -dev package.Jonathan McCrohan2-14/+12 2012-02-08Update package changelog.Jonathan McCrohan1-1/+1 2012-02-08Partial manual revert of move to libconfig*8.Jonathan McCrohan4-12/+12 2012-02-08Add my name to debian copyright.Jonathan McCrohan1-2/+3 2012-02-08Atomic commit. Rollback to libconfig8 packaging names.Jonathan McCrohan10-8/+8 2012-02-07Rename libconfig9 to libconfig8 to aid release teamJonathan McCrohan1-14/+14 2012-02-07Fix "closes typo"Jonathan McCrohan1-1/+1 2012-02-07Revert "Add symbols"Jonathan McCrohan3-739/+1 2012-02-07Revert "Fix b0rked symbol file."Jonathan McCrohan1-1/+1 2012-02-07Revert "Second attempt"Jonathan McCrohan2-0/+194 2012-01-29Second attemptJonathan McCrohan2-194/+0 2012-01-29Fix b0rked symbol file.Jonathan McCrohan1-1/+1 2012-01-29Add symbolsJonathan McCrohan3-1/+739 2012-01-26add examples properlyJonathan McCrohan1-0/+2 2012-01-26Update changelogJonathan McCrohan1-3/+6 2012-01-26fix typoJonathan McCrohan1-1/+1 2012-01-26fix accidental description changesJonathan McCrohan1-2/+2 2012-01-26more fucking around to please lintianJonathan McCrohan1-5/+2 2012-01-25Linitan fixesJonathan McCrohan2-3/+2 2012-01-25Split out debug packagesJonathan McCrohan2-1/+6 2011-12-31Fix debian/rulesJonathan McCrohan1-1/+1 2011-12-31Remove shlibsJonathan McCrohan1-2/+0 2011-12-31Remove NMU from changelogJonathan McCrohan1-1/+0 2011-12-31Lintian FixesJonathan McCrohan1-2/+4 2011-12-31Remove Makefile patchJonathan McCrohan1-1/+0 2011-12-31Update MakefilesJonathan McCrohan10-248/+8222 2011-12-31Updated makefilesJonathan McCrohan1-0/+1