aboutsummaryrefslogtreecommitdiffstats
path: root/util/szap/Makefile
diff options
context:
space:
mode:
authorMark Purcell <msp@debian.org>2012-05-13 19:42:13 +1000
committeretobi <git@e-tobi.net>2013-09-03 09:48:54 +0200
commita537361120f6d717bfdf2793c82d2435ee0c9126 (patch)
tree73c81bb7e5d5d7e7b604b785d3a3ca7e46537850 /util/szap/Makefile
parent96bce3638e9b6d3f3bac79494e11d877857de81e (diff)
parent5501530a778ad588a8ccd3f1584ea58f74c0cec9 (diff)
downloadlinux-dvb-apps-debian/1.1.1+rev1483-1.tar.gz
Imported Debian patch 1.1.1+rev1483-1debian/1.1.1+rev1483-1
Diffstat (limited to 'util/szap/Makefile')
-rw-r--r--util/szap/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/util/szap/Makefile b/util/szap/Makefile
index 48d7149..837e989 100644
--- a/util/szap/Makefile
+++ b/util/szap/Makefile
@@ -1,5 +1,11 @@
# Makefile for linuxtv.org dvb-apps/util/szap
+# get DVB API version
+VERSION_FILE := "/usr/include/linux/dvb/version.h"
+
+DVB_API_MAJOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION" $(VERSION_FILE)) )
+DVB_API_MINOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION_MINOR" $(VERSION_FILE)) )
+
objects = lnb.o util.o
binaries = azap \
@@ -12,6 +18,7 @@ inst_bin = $(binaries)
.PHONY: all
all: $(binaries)
+$(info DVB API is $(DVB_API_MAJOR).$(DVB_API_MINOR))
$(binaries): $(objects)